none
AD RMS add role problem RRS feed

  • Question

  • I tried to add the AD RMS role on Windows Server 2008 computers, but I always get this error:

     

    "The account you are logged on with is not valid for installing the AD RMS server role.  Log on with a domain account that is a member of the local Administrators group."

     

    I tried adding the role on a W2k8 DC and two different Member Servers but I get the same error message, what makes me think that may be a AD releated issue. I used this guide (http://technet.microsoft.com/en-us/library/cc771789.aspx), but had no luck. I tried using a local administrator, domain admin and enterprise admin.

    As far as we know, we never deployed earlier RMS versions in our AD domain. I checked and there are no Rights Management SCP registered on the Configuration Partition.

     

    In a lab environment it works fine.

     

    Tks for any help.

    Tuesday, October 28, 2008 12:01 PM

All replies

  • I had this probem also.
    Spent a lot of time on it.
    My fix was to install RC2 of Service Pack 2 for Win2k8 Server.
    • Proposed as answer by Clint Boessen Tuesday, April 7, 2009 1:35 AM
    Monday, April 6, 2009 11:49 PM