locked
U3 Compatibility RRS feed

  • Question

  • U3 had complete functionality at first on Win 7 Pro 32.
    After a few days suddenly I got the error message that all drive letters were taken and that I should try freeing them up.
    Few drive letters were actually in use but still I freed up everything but C: in disk manager without success.
    Tried changing the U3 assigned drive letters in disk manager without success.
    Tried an older U3 drive with the same result.
    I assume this is a common bug given the error message I got.
    Is there a fix in the works for this?

    Tried U3 forums but nobody mentioned this particular issue.
    Wednesday, December 9, 2009 2:50 PM

Answers

  • I wonder if there are a lot of ghost connections in Device Manager. By that I mean entries for devices that are no longer connected, or perhaps Windows 7 is having problems releasing the U3 flash drive for some reason.

    Remove the U3 drive
    Open a Command Prompt and enter set devmgr_show_nonpresent_devices=1
    Next, enter devmgmt.msc
    Click on View then Show Hidden Device s

    Expand Disk Drives , Storage Volumes and Universal Serial Bus Controllers and see if there are any grayed out entries that you don't recognize or that you know are for devices not connected to your computer. If yes, right click and uninstall them. See if that frees things up so you can use it again.
    Rich
    • Marked as answer by Andy Song Monday, December 21, 2009 10:19 AM
    Thursday, December 10, 2009 1:02 AM