none
List Item Crawled but not shown in Search Results RRS feed

  • Question

  • Hi there,

    we are using SPS2010 with FAST Search, which was running fine over the last months, but now we got the issue that newly created items do not show up in the search results.

    This seems to happen not just only in one particular list or document library but also farm wide.

    I checked the crawl logs and one item which is not showing up in the results is crawled successfully.
    It is a simple list item/entry (no document, no pdf). If I search for other items which have been created earlier this year they do show up in the search results. So search is working in general, but items created recently do not show up in the results even if they got crawled successfully.

    Has anyone got some advice?

       

    Thursday, November 13, 2014 10:54 AM

Answers

  • Christian,
    If the items are getting crawled successfully, the issue may be related to FAST backend.
    Could you run the below command to check if you have any "not_indexed" documents:
    %FASTSearch%\bin> indexerinfo -a status

    You should get an output with all the master indexers and back indexers (if any).
    For example below, it shows 338325 documents not indexed.

    <documents size="7565997027682.000000" total="10932467" indexed="10594142" not_indexed="338325"/>

    Also form the output check the status of indexers and heartbeat to ensure they show the status as below.

    " status="running ok" heartbeat="Running"

    If you have unindexed docs, you may want to consider resetindex from the FAST backend.


    Friday, November 14, 2014 2:15 PM

All replies

  • Christian,
    If the items are getting crawled successfully, the issue may be related to FAST backend.
    Could you run the below command to check if you have any "not_indexed" documents:
    %FASTSearch%\bin> indexerinfo -a status

    You should get an output with all the master indexers and back indexers (if any).
    For example below, it shows 338325 documents not indexed.

    <documents size="7565997027682.000000" total="10932467" indexed="10594142" not_indexed="338325"/>

    Also form the output check the status of indexers and heartbeat to ensure they show the status as below.

    " status="running ok" heartbeat="Running"

    If you have unindexed docs, you may want to consider resetindex from the FAST backend.


    Friday, November 14, 2014 2:15 PM
  • Hello Patrick,

    thanks for your reply. I checked for unindexed docs and reseted the Index. This solved the issue.

    Monday, November 24, 2014 8:29 AM