none
Device Cannot Start (Code 10) Please Please Help RRS feed

  • Question

  • This device cannot start. (Code 10) Help me Please!<!-- google_ad_section_end -->
    <!-- google_ad_section_start -->Okay let me lay out my probelm and detail everything i have done to try to fix it that has not worked.

    Recently i purchased a Asix AX887728 Usb2.0 To Fast ethernet in other terms,
    Sabrent NT-USB20 USB 2.0 to RJ45 Fast Ethernet 10/100 Base-T Network Adapter

    So when i purchased the product i installed it onto my pc and everything worked fine, i used the device for 3 days no issues. Well i went to sleep last night woke up and started my pc. And the device was not recognized and that i had the Error device cannot start (code 10) As well in the device manger there is a yellow exclamation mark beside it So i tried multiple things.

    - Reinstalled the drivers to the device/ Failed still got error
    - Followed the Microsoft trouble shoot wizard/ Epic fail
    - Took it as far as reinstalling a fresh copy of xp just recently, updated all my drivers and everything to date. Still got the DAMN error.

    Im to the point to thinking this hunk of plastic was made to ____ me off.

    This is a display and image of the device i am talking about that has the code 10 error

    http://www.amazon.com/Sabrent-NT-USB.../dp/B000LWESXW

    So now im clueless what to do i know it can't be the hardware i mean i have not even touched it hardly since i plugged it in, and my pc is virus free and runs like new, Although i do remember a blue led light coming on and now it wont come on when i plug it into usb, i dont know if it has to function properly for the lead to come on or what.

    So if anyone can please explain to be what to do to resolve this issue it would be nice, i am sick of wireless and my Regular ethernet adapter in my pc is just screwed up, the Ethernet light comes on only when i push my cord to the TOP of the slot.


    Sorry for all the details i just need to get it narrowed down, aswell i forgot to say there is no driver updates for the device im using the disk it came with like i sad it worked great for 3 days no damage done to it then stopped one morning reinstalled windows and updated all my **** still nothing.

    Aswell i know it can't be hardware the computer can detect the device plugged in just the Damn Device will not start (Code 10)

    Anyways thank you and please help.
    Saturday, January 9, 2010 2:22 AM

All replies

  • Hi Tyler,

    This is not the correct forum for your question.  Can you try that device in another machine?  That would be one way to determine if it is a hardware failure.  The other thing you may want to try to do is post this to one of the Windows Forums to see if anyone there can assist.  Best of luck to you!

    Best regards,
    Jeff Willis
    Saturday, January 9, 2010 6:39 AM