none
Problem with OWA and Mobile Connectivity RRS feed

  • Question

  • Hi Guys,

    I really need your help with this one.

    Windows Server 2003 R2 x64 SP2
    Exchange Server 2007 SP1 (Build 240.6)

    So here's the problem :

    - Certificate expired. Bought a new one and replace it with the new one. Simple right? Well not that simple!

    After the certificate Upgrade, OWA stop working. When I'd try to access it, we got the following error :

    Server Error in '/owa' Application.

    After searching to fix that, I've found the need to rename de web.config file form the iis root directory and OWA start to work again, which is a good thing.

    However, there's a bigger problem. All Mobiles (iPhones, Android and Windows phone) aren't able to connect to our exchange server.

    I did a lot of fixes, like the "check box" to get all the permissions to be herited on the account I use for testing, suppressing the account on the phone and re-create it, etc. But nothing works and I need the Mobiles to be able to connect to exchange again.

    Just to let you know, I did contact Digicert from where came my new certificate to get them validate the certificate and everything is ok on there side.

    Any Q about what I can do to fix this?

    Thanks! 

    Wednesday, August 6, 2014 6:19 PM

Answers

  • Please test using the https://testconnectivity.microsoft.com/ and check for error.


    MAS

    Thursday, August 7, 2014 5:05 AM
  • Hi Johnny,

    How about the https://testconnectivity.microsoft.com/ result that MAS suggested? Please paste the errors without sensitive information for the further troubleshooting.

    According to your first post, I know that the only issue now is Mobile cannot connect to Exchange server. Please correct me if there is any misunderstanding.

    Please run following command to check whether the ActiveSynce is eanbled on Exchange server:

    Get-CASMailbox -Identity testaccount | fl

    Please check whether the ActiveSyncEnabled Parameter's value is True. If it is Fals, please run following commant to enable all users' ActiveSync on this Exchange server:

    Get-CASMailbox | Set-CASMailbox -ActiveSyncEnalbed $True 

    Is there any error message pop up when mobile cannot connect to Exchange server?

    Also suggest ask ActiveSync forum for help so that you can get more professional suggestions. For your convenience:

    http://social.technet.microsoft.com/Forums/exchange/en-US/home?forum=exchangesvrmobility

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support


    Tuesday, August 12, 2014 4:41 PM
    Moderator

All replies

  • By the way, I would like to upgrade to at least Exchange 2007 SP2, but I need to fix couple of problems before to be able to do so.
    Wednesday, August 6, 2014 6:24 PM
  • Did you try uninstalling and installing CAS role?

    If not please try that. Go to Add/Remove programs. Click Exchange2007 --> click uninstall

    Remove tick Client access. Restart server and install CAS again using the exchange2007 media


    MAS

    Wednesday, August 6, 2014 7:05 PM
  • No, I didn't try this option. I was thinking about to do it but, I wasn't sure I would be able to do is with the fact both domain controllers are W2K3 R2 SP1.
    Wednesday, August 6, 2014 7:28 PM
  • Please test using the https://testconnectivity.microsoft.com/ and check for error.


    MAS

    Thursday, August 7, 2014 5:05 AM
  • Hi Johnny,

    How about the https://testconnectivity.microsoft.com/ result that MAS suggested? Please paste the errors without sensitive information for the further troubleshooting.

    According to your first post, I know that the only issue now is Mobile cannot connect to Exchange server. Please correct me if there is any misunderstanding.

    Please run following command to check whether the ActiveSynce is eanbled on Exchange server:

    Get-CASMailbox -Identity testaccount | fl

    Please check whether the ActiveSyncEnabled Parameter's value is True. If it is Fals, please run following commant to enable all users' ActiveSync on this Exchange server:

    Get-CASMailbox | Set-CASMailbox -ActiveSyncEnalbed $True 

    Is there any error message pop up when mobile cannot connect to Exchange server?

    Also suggest ask ActiveSync forum for help so that you can get more professional suggestions. For your convenience:

    http://social.technet.microsoft.com/Forums/exchange/en-US/home?forum=exchangesvrmobility

     

    Thanks

    Mavis


    Mavis Huang
    TechNet Community Support


    Tuesday, August 12, 2014 4:41 PM
    Moderator