none
Formula Malfunction RRS feed

  • Question

  • MS Project 2016 Professional (no EPM).

    I am using the following formula in a custom flag field.

    ([Number3]<[Number4]) And ([Actual Finish]="NA")

    When I open a project and try to run a view that uses this formula for a filter I find that it reports zero tasks applicable because the flag field is not reporting anything as "Yes".

    I can go into the custom flag field and cut the "AND" part, then OK. The field immediately calculates the "number" part. Then I paste back the AND part and the flag continues to calculate OK. Until next time I open the project.

    I need this flag to be reliable. What am I doing wrong?

    Thanks.

    Friday, May 25, 2018 12:34 PM

Answers

  • Hi,

    Try the following:

    ([Number3]<[Number4]) And ([Actual Finish]=projdatevalue("NA"))

    Just tested it and it works fine.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    • Marked as answer by MorphaToo Friday, May 25, 2018 1:43 PM
    Friday, May 25, 2018 1:03 PM
    Moderator

All replies

  • Hi,

    Try the following:

    ([Number3]<[Number4]) And ([Actual Finish]=projdatevalue("NA"))

    Just tested it and it works fine.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    • Marked as answer by MorphaToo Friday, May 25, 2018 1:43 PM
    Friday, May 25, 2018 1:03 PM
    Moderator
  • Whats Going Ahn,

    First of all I don't see a conditional statement (i.e. "IIF"). Second, you can't directly test for "NA" ("NA" is a text representation of a very large number). Try the following formula, it should work better for you.

    Flag1=IIf([Number3]<[Number4] And [Actual Finish]<100000,true,false)

    Hope this helps.

    John

    Friday, May 25, 2018 1:14 PM
  • Works great. Thanks.
    Friday, May 25, 2018 1:43 PM