none
Cannot Edit Timesheet After Upgrade RRS feed

  • Question

  • Hi,

    We upgraded from SharePoint and Project Server 2010 to SharePoint and Project Server 2013. We are running into several weird issues:

    * The timesheet displays but is disabled for all users. I have tried refreshing, after several consecutive refreshes, it gets enabled and i can save my time then on postback it gets disabled again.

    * If I recall an approved timesheet, nothing happens. It remains in the approved status.

    * If i try to edit any resource, as soon as i click Save, the system indicates that the resource is checked out in another session.

    The error log has no helpful errors recorded although I have enabled verbose logging. The OS is Windows Server 2012 R2 and the database is SQL Server 2014. 

    Any help would be appreciated. Thanks.


    • Edited by Moezz Tuesday, December 16, 2014 2:50 PM
    Tuesday, December 16, 2014 2:50 PM

Answers

All replies

  • Hi Moezz,

    This type of issue could happen after a migration when the migration process has duplicated the webpart, making the ribbon enable to find the right webpart. Please refer to this blog post for a way to solve this issue.

    Then a question comes to my mind: did you also migrated your IE browser version? Which IE version are you using?


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Tuesday, December 16, 2014 5:42 PM
    Moderator
  • I will try the post and let you know if it solves the issue.. most of my users are still on IE 9. However, I tested on both IE10 and 11 but got the same results.
    Wednesday, December 17, 2014 3:51 AM
  • I checked the webparts page, there is only one instance of the webpart on the page. I tried removing the webpart and adding it again but no change in the behaviour.
    Wednesday, December 17, 2014 4:49 AM
  • Have you add the PWA URL to the trusted site in IE settings and also to the compatibility sites?

    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Wednesday, December 17, 2014 2:07 PM
    Moderator
  • Yes, it was in the compatibility sites and i tried removing it but no change.
    Wednesday, December 17, 2014 5:40 PM
  • And the trusted sites?

    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Wednesday, December 17, 2014 5:52 PM
    Moderator
  • Yup it is in trusted sites as well
    Wednesday, December 17, 2014 6:52 PM
  • it turned out to be an issue with the web.config.

    For some reason, impersonation was set to false. Changing that to true resolved the issue.

    Wednesday, December 17, 2014 7:57 PM