none
CAPTURE fails with SYSPREP error Win 10 1511 RRS feed

  • Question

  • I'm getting a SYSPREP error when trying to CAPTURE my Windows 10 1511 WIM using MDT. The Error is Expected image state is IMAGE_STATE_GENERALIZE_RESEAL_TO_OOBE actual image state is IMAGE_STATE_COMPLETE sysprep did not succeed.

    Checking setupact.log SYSPREP Package Microsoft.ConnectivityStore_1.1509.1.0_x64_8wekyb3d8bbwe was installed for a user, but not provisioned for all users. This package will not function properly in the sysprep image.

    I only get this error with Windows Update tasks enabled in the task sequence. The updates are coming from our WSUS server. When I first got the error it was with a different package. I'm running the install on a VM with 2 CPU and 2GB of memory.

    Can anyone tell me why this is happening

    Tuesday, September 13, 2016 12:16 PM

All replies

  • Because Windows updates.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Wednesday, September 14, 2016 1:12 AM
    Moderator
  • The frustrating part is that this worked a few months ago. Just tried it again with the same error for the same App. Leaving all Updates in the Deploy task sequence just slows that up far too much, so I need to get them into this Capture.
    Wednesday, September 14, 2016 7:31 AM
  • Sysprep is telling you that your image has been sealed and is not in a generalize state. If you're using a VM did you roll back your image to the state it was in before you let it run sysprep and capture? Once it does that it seals the image.

    If this post is helpful please vote it as Helpful or click Mark for answer.

    Wednesday, September 14, 2016 2:22 PM
  • The Sysprep/Capture process works fine when Windows Updates are disabled in the task sequence, but fails once they are enabled. So it cannot be a problem with the Sysprep steps and must be an Update installing something just for the account used by the task sequence.
    Thursday, September 15, 2016 7:04 AM
  • If your starting with 1511 but along the way Windows update upgrades you to 1607, then it would break the ability to capture. If that's happening you need to import 1607 ISO and build your image from that.

    If this post is helpful please vote it as Helpful or click Mark for answer.

    Thursday, September 15, 2016 1:57 PM
  • Nope it's all 1511. As we use WSUS for updates we have not approved 1607 yet, nor will we until we have tested everything thoroughly.
    Thursday, September 15, 2016 2:57 PM