none
After restoring Project Server Databases and reprovisioning the PWA instance, URL shows an empty value RRS feed

  • Question

  • Hello

    I have restored the 05 databases from my production environment to my Test Environment and after the reprovision process finished, the Project sites are empty. I have tried to use the bulk option to try to relink the projects with its Project sites without success.

    There is a tools to relink it like in Project Server 2007? My environment is Project Server 2010.

    I have tried to relink one Project running an update directly in the Published DB as described below:

    SELECT WADMIN_CURRENT_STS_SERVER_UID FROM MSP_WEB_ADMIN

    update dbo.MSP_PROJECTS set WSTS_SERVER_UID='COPY THE STRING OBTAINED EARLIER HERE' PROJ_NAME = 'Project 1'

    After that, this Project shows its Project site, so my question is: Is this the correct way to relink all my projects with its sites?

    Thanks in advanced,

    Marco Botega 


    Marco Aurélio Botega - MCP

    Tuesday, October 1, 2013 12:51 AM

All replies

  • Hi,

    With Project Server 2010 the correct way to relink project sites with their projects is to use the Bulk Update Project Sites option in Server Settings. You need to be sure you pick the correct source and destination options.

    If this doesn't work, can you verify that all your project sites were in the SharePoint DB containing your /PWA site? On your test site, make yourself a site collection administrator of that site collection and then go looking for your sites, you should be able to see them, even if they are not linked up to underlying projects.


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Tuesday, October 1, 2013 2:54 AM
    Moderator
  • Hello Alexander, I have 100% of sure that the site collection of PWA and my sites are there in my content database. As I tried to describe earlier, after updated the WSTS_SERVER_UID field in the Published database, the site pass to be presented in the Project Sites. I have already tried to use the bulk option but it doesn't work. I didn't change the pwa name, so, I have selected the same web application and pwa name to try to relink through bulk option, but without success. I have 10k projects and consequently 10k project sites, and when I did the restore of 5 databases and provisioned the pwa 500 projects were relinked with its sites, then I did a query to compare the differences between one that was correctly relinked with one that wasn't, and the WSTS_SERVER_UID field got my attention. Do you have another suggestion? Thanks

    Marco Aurélio Botega - MCP

    Tuesday, October 1, 2013 10:42 AM