none
Static IP address does not appear in the IPv4 properties dialog after setting an exiting dialog. On reentry to the dialog you see dynamic, but the system is running with the static IP. RRS feed

  • Question

    1. The IPv4 interface was set to 'Obtain address automatically'.
    2. Changed this setting to 'Use the following IP address, e.g., 192.168.254.66, 255.255.255.0
    3. Went back to the dialog to set it back to 'dynamic' but the dialog displays that it is dynamic.  The system is still running with the previous static IP.    I can set the interface to another static IP, but I have to set it to this value twice before it takes.
    4. I can click on okay on the interface that is displaying dynamic, but I need to disable the interface, wait 30 seconds, then enable the interface for dynamic to take affect.
    5. I have followed the procedures outline here and in a MS article for WS2003 to novail: https://social.technet.microsoft.com/Forums/windowsserver/en-US/70762c1c-da6d-45b7-b3bf-b7079abf8469/windows-server-2008-can-not-see-static-ip
    • The laptop is running Windows 8.1 with the latest SP.  The laptop is a Lenovo W540.
    • The laptop is standalone, not part of any domain, nor has it ever been a domain member.

    Any help or suggestions to get this to work as designed... Thanks!

    Friday, February 13, 2015 9:57 PM

Answers

  • Hello luofang,

    You need to set the static IP address twice and it will work?
    As you use laptop, does this issue occur in all network environment and wireless and wired network?

    Please take the following steps for troubleshooting:
    1. If the issue only occur in wired network, try to update the driver from the manufacturer website
    2. Use the command netsh int ip reset to reset TCP/IP

    http://support.microsoft.com/kb/299357

    3. Go to Control Panel\All Control Panel Items\Troubleshooting\All Categories and run the Network adapter troubleshooter and Internet Connections Troubleshooter

    Best regards,
    Fangzhou CHEN


    Fangzhou CHEN
    TechNet Community Support

    Friday, February 20, 2015 6:53 AM
    Moderator

All replies

  • Hi Luofang

    Open up a cmd promt as administrator and run ipconfig /release then ipconfig /renew

    This will release the lease of the ip address it was previously using and request a new one from DHCP

    Hope that helps.

    Friday, February 13, 2015 10:29 PM

  • Hello luofang,

    What is your current situation?

    Please use the command ipconfig /all to show the IP information.
    And thenSet to 'Obtain address automatically', use the command ipconfig /release then ipconfig /renew to renew the IP.

    Then again, use the command ipconfig /all to show the new IP information.

    Compare the difference.

    Best regards,
    Fangzhou CHEN


    Fangzhou CHEN
    TechNet Community Support


    Monday, February 16, 2015 5:59 AM
    Moderator
  • This issue is that the IP properties dialog doesn't show that it using a static IP after setting the static IP. When you set the static IP and exit the dialog, on return it shows it is set to using dhcp. I've tried the steps outlined in the tech article to no avail.
    Monday, February 16, 2015 7:29 PM
  • Hello luofang,

    You need to set the static IP address twice and it will work?
    As you use laptop, does this issue occur in all network environment and wireless and wired network?

    Please take the following steps for troubleshooting:
    1. If the issue only occur in wired network, try to update the driver from the manufacturer website
    2. Use the command netsh int ip reset to reset TCP/IP

    http://support.microsoft.com/kb/299357

    3. Go to Control Panel\All Control Panel Items\Troubleshooting\All Categories and run the Network adapter troubleshooter and Internet Connections Troubleshooter

    Best regards,
    Fangzhou CHEN


    Fangzhou CHEN
    TechNet Community Support

    Friday, February 20, 2015 6:53 AM
    Moderator
  • This doesn't necessarily fix the issue.  I have the same issue on my system (8.1, Lenovo T430, Intel 82579LM).  I can set a Static IP, I click OK, it accepts the settings.  If I go back in, say to update the settings, the GUI appears to show that I'm set to Dynamic - even though I have a Static IP setup.  If I change the IP, it will ADD the IP to the list of Static IPs, not replace the existing one.  Same with the GW.

    If I switch back to Dynamic IP addressing, the Static IP(s) and gateway(s) will still appear next to the Dynamic IP, although they aren't able to be used.

    My drivers are the most current, and it's happened with different driver versions - i.e. it's always occurred.  I've reset TCP/IP stacks and Winsock, and it helps for about a week.  I've removed and reinstalled the devices from DevMgmt; including and excluding removing drivers - same outcome.

    While I do criticize Intel for having poor drivers for their network cards (Intel 7260AC, anyone?!), I don't think it's a driver issue since it's continuing to manifest as an entry in the Windows Registry.

    Registry Image (since I can't add images here?!): http://i.imgur.com/OaAEcDV.png

    NIC Images (again, since I can't add images here?!): http://i.imgur.com/3tI8QeY.png

    • Edited by IIT_MattK Wednesday, July 15, 2015 1:27 PM Added Images for Description
    Wednesday, July 15, 2015 1:18 PM
  • For some reason, removing the binary registry entry called "Config" under the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network fixes this issue.  This entry may have to be deleted several times to permanently fix this issue.

    Shawn


    • Proposed as answer by VLF4986 Wednesday, April 17, 2019 1:54 PM
    • Edited by VLF4986 Wednesday, April 17, 2019 2:18 PM
    Wednesday, April 17, 2019 1:54 PM