none
Exchange 2010 with multiple domains and disabling autodiscover for one of them

    Question

  • Hello - I'm an Exchnage newbie and have the following issue - we have an Exchange 2010 server accepting mail for multiple domains and want to migrate one of them to O365. I found that if you:

     Set-ClientAccessServer –Identity “CASxx” –AutoDiscoverServiceInternalUri $NULL   

    you're essentially removing the on-premises information with regard to Autodiscover; thus eliminating the conflict that your end users are experiencing between the O365 autodiscover and the on-premises one.

    Does this ps command disable AutoDiscover for ALL the domains?

    How would you remove AutoDiscover for just 1 of them?

    I do have a CNAME record pointing to autodiscover.outlook.com in DNS for this domain.




    • Edited by JoeatApex Friday, March 18, 2016 4:07 PM
    Friday, March 18, 2016 4:00 PM

Answers

  • Thanks to all for your replies. I discovered adding the following registry entries in regedit fixes this issue and Outlook now points externally to O365 as mentioned:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0 14.0 for Outlook 2010\Outlook\AutoDiscover



    • Edited by JoeatApex Wednesday, March 23, 2016 9:45 PM
    • Marked as answer by JoeatApex Wednesday, March 23, 2016 9:46 PM
    Wednesday, March 23, 2016 9:44 PM

All replies

  • That removes the Autodiscover URL for all connections by domain-joined computers connecting from the local network or by VPN.  I'm not sure whether Outlook will then try the standard set of external client Autodiscover URLs afterward.

    I'm not sure why you think you need to do this.  All the domains' clients need to look to your Exchange server for Autodiscover, no?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Friday, March 18, 2016 5:28 PM
    Moderator
  • Ed - thank you for your prompt response.

    We no longer want to use the on premise EX2010 server for this particular domain. We authenticate to abc.com on the desktops and have 123.com for email on the EX2010 server with 7 other domains. I just want to migrate abc.com to O365. I'm looking to get the desktops to point to O365 for email.



    • Edited by JoeatApex Friday, March 18, 2016 6:47 PM
    Friday, March 18, 2016 6:46 PM
  • Exchange servers aren't domain-specific unless they're in separate forests so I'm not sure what you're asking.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Friday, March 18, 2016 8:26 PM
    Moderator
  • Are you configuring hybrid mode for the domain being moved to Office 365? If so, then your existing servers will direct client to Office 365 for their mailboxes.

    If you are not setting up hybrid mode then you need to remove the domain from your on-premises Exchange as an accepted domain and configure the autodiscover.yourdoamin.com dns record as indicated by Office 365. This will be cname to Office 365 if I recall correctly, but Office 365 provides the necessary records when you add the domain.


    Byron Wright (http://byronwright.blogspot.ca)

    Friday, March 18, 2016 8:48 PM
  • Look like the desktops maybe unable to remove the SCP object from AD completely. I found this on Intermedia KB:

    If you have users on the in-house Exchange server that are not supposed to be migrated to Intermedia at all, this can sometimes result in inability to really remove SCP object from Active Directory completely or update AutoDiscoverServiceInternalUri (because some users are located on the old server). The fix also applies if you don't have access to the in-house servers.  Note: Public Autodiscover DNS record should be pointing to Outlook online. The fix is to create the following Registry keys on necessary machines: Navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\12.0 14.0 for Outlook 2010\Outlook\AutoDiscover and create these DWORD values:

    "PreferLocalXML"

    "ExcludeHttpRedirect"

    "ExcludeHttpsAutodiscoverDomain"

    "ExcludeHttpsRootDomain”

    "ExcludeScpLookup"

    "ExcludeSrvLookup"

    "ExcludeSrvRecord"

    They should be set to either 1 or 0 (“0” = False and “1” = True).

    For example, this is how these values are supposed to look like if you want to make Outlook check only DNS for Autodiscover:

    "PreferLocalXML"=dword:0

    "ExcludeHttpRedirect"=dword:0

    "ExcludeHttpsAutodiscoverDomain"=dword:0

    "ExcludeHttpsRootDomain"=dword:1

    "ExcludeScpLookup"=dword:1 (forces Outlook to exclude SCP object check)

    "ExcludeSrvLookup"=dword:1

    "ExcludeSrvRecord"=dword:1

    Friday, March 18, 2016 9:03 PM
  • Hi,

    We can use GPO to modify the behavior for Autodiscover service works in Outlook client as you mentioned above.

    However, we cannot disable Autodiscover in Exchange server. Also, it should works correctly if you want to configure Hybrid environment. For your reference:
    https://blogs.technet.microsoft.com/uktechnet/2015/04/10/dns-the-key-to-a-successful-office-365-migration/

    Therefore, I want to double confirm the reason why you want to disable autodiscover for this individual domain.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Monday, March 21, 2016 9:23 AM
    Moderator
  • Thanks to all for your replies. I discovered adding the following registry entries in regedit fixes this issue and Outlook now points externally to O365 as mentioned:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0 14.0 for Outlook 2010\Outlook\AutoDiscover



    • Edited by JoeatApex Wednesday, March 23, 2016 9:45 PM
    • Marked as answer by JoeatApex Wednesday, March 23, 2016 9:46 PM
    Wednesday, March 23, 2016 9:44 PM