none
MDT 2013 & SCCM 2012 R2 - Slow MDT Download

    Question

  • MDT Use toolkit package inside of OSD takes a very long time to download.<br>


    MDT is only around 40mb total size, so i can't understand why it's taking so long on only this section.

    Typically the use toolkit package where MDT downloads locally inside of OSD takes around 5-7 minutes, each of the files are small in size but the download time is ridiculous! I transfer a 6bg .wim file in 2 minutes when it comes to applying the image so i know the network speed is ok, something is going wrong with the MDT package and downloading it.

    Running a normal TS without MDT runs fine, and the image installs ok.

    Pulling my hair out with how long MDT takes, it's adding on an extra 15-20 minutes onto my sequence just by downloading toolkit files!


    Anyone had similar or know what I may be able to try?


    The setup is a lab environment. I have a standalone primary, with local SQL, 1 DP & 3 physical clients.





    • Edited by JackD86 Tuesday, February 04, 2014 9:32 AM
    Tuesday, February 04, 2014 9:30 AM

Answers

  • It appears that MS support was able to find a solution for my environment.

    Immediately after enabling the "allow clients to connect anonymously" setting on each distribution point the time it took for the MDT Toolkit package to download went from 30 minutes to around 20 seconds.

    The support tech was unable to explain why this setting was required following the R2 upgrade in our environment. He verified that in his lab environment he did NOT have this setting configured on the DP and he saw no issue downloading the MDT toolkit package.

    As much as I would like to have a root cause for this issue I'm just happy that my OSD process isnt taking 3 hours now!

    • Marked as answer by JackD86 Wednesday, April 02, 2014 10:47 AM
    Thursday, March 20, 2014 8:31 PM

All replies

  • I am not sure why it would take that long, but I can explain why it might appear to be slow if you are watching the task sequence run.  There is a 30 second sleep in the script called by this action (ZtiSCCM.wsf).  Mike Niehaus talks about it here.  He also explains that he recalls who added it but not why :-).

    Therefore you can safely edit this script to comment out the sleep, update the MDT package on your DPs and save yourself 30 seconds for each time this action runs during the task sequence.

    Test this out and let us know if it helps.  If you still think that the Use Toolkit Package action is slow then please post your SMSTS.log and ZtiSCCM.log.  If your TS deployment is set to download content when needed is it this part that is slow or the execution of the action itself?

    Mark.

    Tuesday, February 04, 2014 2:18 PM
  • Hi Mark,

    I've already set the sleep option to be commented out, made no difference :(

    The TS is just a standard OS Deployment, so it'll download all content locally when needed, which includes the MDT Toolkit step i guess. I timed it earlier and it took 7 minutes to download 40mb worth of files! and it does this twice.

    After the format and partition it moves onto downloading the .wim which is 6.7gb, and does that in 2 minutes!

    Not sure if there's any authentication going on when the files are being downloaded in the first place for the MDT Toolkit Package? That would probably figure as to why the MDT Toolkit would take longer as it's multiple files... but not sure.

    I'll gather some ZTI logs :)

    Jack

    Tuesday, February 04, 2014 2:58 PM
  • Is this an R2 site with all the latest OSD hotfixes installed.  There are a few that help with imaging time and Task Sequence Variable issues. 

    Not sure why it would take an extra 15 mins but there is a hot fix for imaging when you have a DP on a site server. 

    http://myitforum.com/myitforumwp/docs/configuration-manager-2012-r2-known-issues/

    here is a list that you can use to link to other issues and hotfixes.


    http://www.sccm-tools.com http://sms-hints-tricks.blogspot.com

    Tuesday, February 04, 2014 3:10 PM
  • Thanks Matthew,

    It is an R2 site, along with the hotfixes applied. I encountered the slow .wim download a while back and have already applied the hotfix, which thankfully worked :)

    This was a clean install, rather than an upgrade

    Tuesday, February 04, 2014 3:15 PM
  • It is better to enable verbose logging for smsts.log to get more detailed info. Maybe it helps us know what is going on there.

    http://myitforum.com/myitforumwp/2012/12/05/how-to-enable-debug-logging-for-an-os-deployment-task-sequence/


    Juke Chou

    TechNet Community Support

    Tuesday, February 04, 2014 4:12 PM
    Moderator
  • Hi Jack.

    Did you ever get to the bottom of this as we are experiencing the same issue after having upgraded to R2?

    The hotfixes have been applied and OSD sequences which do not use MDT run fine but task sequences using MDT take ages to download the toolkit. 

    Any ideas would be much appreciated. Thanks.

    Thursday, February 20, 2014 3:31 PM
  • Hi Erson,

    Unfortunately not, it's taking around 2 minutes or so, but the weirdest thing is: I randomly ran 10 clients on OSD at one time, and it was quicker on the download toolkit package!? - i can't explain it :-S I have a strange feeling it may be to do with authentication of the clients when downloading the file - only a hunch but i can't find anything as of yet to back that theory up. All my colleagues are at a loss and i can't find the issue anywhere else online lol.

    My system was a clean install of R2 on a lab environment, to go production soon. so i don't think it's upgrade related. I had installed MDT 2012 and tried that, but the same probleem still occured.

    The only hotfix i've applied is for the one in R2 which addresses the slow .wim download in the TS which it sounds like you've already done, and facing same bit as me.


    Jack

    Thursday, February 20, 2014 4:07 PM
  • Thanks for the quick response, Jack.

    We will carry on investigating too so if we find a fix I will let you know on here!

    Thursday, February 20, 2014 5:42 PM
  • Having the exact same issue.  Slow Toolkit, fast .wim. Please post updates if you find anything, it's killing me!

    My environment is all new 2012 R2, all post R2 hotfixes installed.  All servers are 2008 R2 (not my choice).

    Thursday, February 20, 2014 10:27 PM
  • Still nothing as yet.

    The original DP was on the site server so we have built a new separate DP and reapplied the hotfix but still the same problem....

    Tuesday, February 25, 2014 2:38 PM
  • You would have to monitor the traffic using Wireshark etc ... I've seen a situation where AD sites / links where not set up correctly and the client was contacting a DC at the other end of the world for each file to be downloaded. It had to be done only once for the wim but hundreds of times for all toolkit files.

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, February 25, 2014 6:16 PM
  • Thank you Torsten. 

    Very useful information and something to investigate further tomorrow.

    Tuesday, February 25, 2014 10:25 PM
  • Have got both my DC's setup on the same lab which is on a VM server below it, still nothing.

    Bah! 

    Erson, just out of curiosity what speed are your clients running at? 100 or 1gbps? I've swapped between 1gbps, back to 100mbps - and even then there isn't a difference at what the 1gbps was going at.

    I've managed to get my build down to 39 minutes to install everything i require, but if i could shave off the extra 5 minutes MDT takes, across our 3,000 machines that adds up to alot of time saved


    Jack

    Wednesday, February 26, 2014 9:17 AM
  • Erson, are you using 8.1 ADK ?

    I've just advertised the use toolkit package to a built windows machine and it absolutely flew through the download. So narrowing it down it's definitely PE that's the issue.

    Wonder if it's the latest 8.1 boot images that could be causing problems


    Jack

    Thursday, February 27, 2014 3:54 PM
  • Thursday, February 27, 2014 4:06 PM
  • Already have that applied torsten, that fixes the slow .wim download that initially happens in R2, but not the MDT Toolit Download part :(

    Jack

    Thursday, February 27, 2014 4:35 PM
  • Hi Jack,

    Yes, we are using 8.1 ADK too.

    I have also tried running a task sequence with use toolkit to an already built machine and it works fine.

    What is odd is that I have tried moving boundaries over to a distribution point at a DR site and it builds fine over the link using MDT OSD which possibly indicates an issue at the other site?

    I am running some network captures now to see if that gives any clues.

    Machines I am building are VM's so have a legacy adapter (For PXE) and a synthetic adapter.

    Legacy adapter is connected @ 100mbps, synthetic adapter @ 10Gbps.

    What I have noticed is sometimes the files are being downloaded by the legacy NIC & then next time I test they are being downloaded by the synthetic NIC so no consistency.

    However, whichever adapter they use, it is really slow.

    Friday, February 28, 2014 11:03 AM
  • Interesting.

    Same setup as you pal, all on VM's - only thing is mine is currently a lab environment at present with just one primary and one DP, before we roll it out onto production.

    I did come across this about NIC Teaming... not sure if this would entirely resolve the issue, but i don't  have the resources to do so unfortunately.

    WinPE 4 Slow Lan Transfer Speeds

    Starting to run out of idea's now! It's not the end of the world, but that extra 5 mins could make alot of difference across all the machines we're upgrading :)


    Jack


    • Edited by JackD86 Friday, February 28, 2014 11:17 AM
    Friday, February 28, 2014 11:16 AM
  • Same problem here in two environments.

    Both environments. 

    Server 2012r2, MDT 2013 and SCCM 2012 r2. Fix for slow PE installed, and works for donwloading the wim files. Small files are very slow.

    Other setups with SCCM 2012 sp1 and MDT 2012 Update, run fine.

    All my environments run under VMWare 5.5 with a VMNET3 nic and a dedicated SQL server. (Also tried E1000E but no succes and other problems)

    Is it possible that BranceCaching has something to do with it ?

    Monday, March 03, 2014 1:18 PM
  • I am seeing the same issues with ConfigMgr 2012 R2 deploying both to physical and Virtual machines. Downloading small files such as those in the MDT Toolkit are taking way too long but the WIM is downloading quickly.

    I have already applied KB2905002 which fixes the WIM download issues..however I have not yet installed KB2910552:

    http://support.microsoft.com/kb/2910552

    Johan has suggested in his blog that although you think the patch may not apply to you it fixes other issues and it should be installed if you are using OSD with CM 2012 R2.

    I will be testing the patch later this week but it would be good to hear from anyone who has already installed KB2910552

    

    Monday, March 03, 2014 2:15 PM
  • Tried the KB2910551 but failed to install on the 3rd step, haven't had time to troubleshoot it yet but even running the extracted msi manually just throws up a random error :/

    @Sjoerd - doubt it, i don't think branchcache will communicate over WinPE, but i may be mistaken. Either way I've tested with BranchCache enabled, and disabled, but still the same results.


    Jack

    Tuesday, March 04, 2014 9:55 AM
  • I too have seen significant slowness downloading the MDT 2013 Toolkit package since upgrading my DEV environment (physical server and clients) to SCCM 2012 R2. It takes almost 20 minutes to download the package.

    Watching SMSTS.LOG I can see that it taking about 2 second to download each file in the package. 617 files multiplied by 2 seconds comes out to right around 20 minutes.

    Last night I installed the most recent hotfix (KB2910552) but I just confirmed that it did not improve the speed of the MDT toolkit package download.

    I’m planning on opening a case with MS support today.

    I'll report back with my findings.

    Tuesday, March 04, 2014 4:11 PM
  • I can confirm that KB2910552 is NOT the solution.

    When I deploy to multiple systems (+10) at the same time. I get a error on 50% of the machines in the task sequince on te MDT package (can't be downloaded). So I've disabled the toolkit package step.

    I don't use multicast.

    Tuesday, March 04, 2014 6:27 PM
  • Found something interesting...

    In my DEV environment (R2) I deployed a basic package (5 files = 30MB) via a task sequence and it install in a few minutes. I then took the same package and added 1000 empty text files to it (still only 30MB) and it took 35 minutes to download and install.

    I then took the same package (1000 extra files) and deployed in my production environment (2012 SP1 CU2) and it downloaded and installed in about 3 minutes.



    Tuesday, March 04, 2014 9:17 PM
  • @Sjoerd - unfortunately i need the toolkit package so no choice to disable it on my evironment.

    @mgouldthorp

    Same issue here, if i deploy that toolkit package in a built machine it all downlaods fine.

    So from what i can gather and tests tried previously it looks to be a downloading issue inside of WinPE - not sure if it's authentication, or what. But when downloading the .wim file all is fine, so doesn't make a great deal of sense. 

    The only difference is that there are multiple files inside the toolkit package compared to the one .wim image. could this be an authentication matter when downloading the files initially? 

    Can't figure it out still and annoying me so much! It's only an extra 4-5 minutes it's adding to my sequence but those 5 minutes add up over the 3,000 machines i need to upgrade lol.


    Jack

    Wednesday, March 05, 2014 8:33 AM
  • @JackD86

    My issue appears to be slightly different. Im seeing the slow package downloads while in the client operating system BEFORE the computer boot into WinPE. Once in WinPE all my packages appears to download normally.

    Wednesday, March 05, 2014 3:37 PM
  • I too have seen significant slowness downloading the MDT 2013 Toolkit package since upgrading my DEV environment (physical server and clients) to SCCM 2012 R2. It takes almost 20 minutes to download the package.

    Watching SMSTS.LOG I can see that it taking about 2 second to download each file in the package. 617 files multiplied by 2 seconds comes out to right around 20 minutes.

    Last night I installed the most recent hotfix (KB2910552) but I just confirmed that it did not improve the speed of the MDT toolkit package download.

    I’m planning on opening a case with MS support today.

    I'll report back with my findings.

    Any update here? Can I ask if anyone is seeing the issue when using HTTPS?

    @mgouldthorp1 - Have you raised a case yet and if so any updates?

    Thanks.

    Friday, March 07, 2014 12:50 PM
  • @mgouldthorp1

    Different to me, i'm not running my OS from windows but actually pxe booting directly into WinPE.

    When i run it as a single step as a test in windows it runs fine. something different there.

    @Surj_K - Not using HTTPS


    Jack

    Friday, March 07, 2014 1:32 PM
  • No update yet. MS support is supposed to call me today.
    Friday, March 07, 2014 2:02 PM
  • No update yet. MS support is supposed to call me today.

    Any other updates? I will be opening a case later this week too so I will post up any updates.
    Wednesday, March 12, 2014 1:22 PM
  • This morning I received the following information from MS support...

    Considering the observations, following are the things that we may need to check:

    • We can configure the task sequence (that they have been and experiencing slow downloads with) to install the MDT Toolkit packages from DP instead of downloading it locally. If achievable with MDT toolkit package then we can notice the amount of time it takes. This can be a work around for us if desired quickness is achieved in downloading the MDT Toolkit package.
    • We can also check copying the same MDT Toolkit package over SMB within WinPE5.0 and see if it still takes 30 minutes.

    Wednesday, March 12, 2014 1:30 PM
  • Hi, Just wondered if you had got any further with this issue?

    Thanks.

    Monday, March 17, 2014 4:42 PM
  • The MS support tech was unable to replicate the issue in his dev environment.

    I'm expecting a follow up call today to troubleshoot in greater detail.


    Monday, March 17, 2014 4:46 PM
  • It appears that MS support was able to find a solution for my environment.

    Immediately after enabling the "allow clients to connect anonymously" setting on each distribution point the time it took for the MDT Toolkit package to download went from 30 minutes to around 20 seconds.

    The support tech was unable to explain why this setting was required following the R2 upgrade in our environment. He verified that in his lab environment he did NOT have this setting configured on the DP and he saw no issue downloading the MDT toolkit package.

    As much as I would like to have a root cause for this issue I'm just happy that my OSD process isnt taking 3 hours now!

    • Marked as answer by JackD86 Wednesday, April 02, 2014 10:47 AM
    Thursday, March 20, 2014 8:31 PM
  • Many thanks for posting this information.

    Have tried enabling anonymous connections on the DP and MDT downloads are now working exactly as they were prior to the R2 upgrade so this has resolved the issue in our environment as well.

    Wednesday, April 02, 2014 10:45 AM
  • Thank god I came across this! I've had a similar issue to this, but at the Driver Package download stage.

    Went from 4 mins to 50 mins each time we re-imaged a machine after R2 was installed.

    Ticked the Allow Clients to connect anonymously on all my DP's and now driver packages take 4 mins to download again!

    Thanks!

    Thursday, April 10, 2014 5:53 AM
  • This is fixed it for me too.

    I didn't have this checked, and have been running R2 since end of January, but all of sudden at around noon today, I got reports of the Toolkit Package taking forever to download.

    After enabling this setting on the DP, it was downloading normally again. I would love to know what changed from this morning to this afternoon, and why this fixes it, but regardless I'm glad it was a simple fix. 

    Thanks.

    Wednesday, July 09, 2014 7:21 PM
    • Proposed as answer by Patricke2e Tuesday, September 02, 2014 12:58 PM
    Thursday, July 10, 2014 12:21 PM
  • What if you use https? you can't check it so another workaround would have to be found.

    joeblow

    Friday, July 11, 2014 5:26 PM
  • This seems to do with Cert checking in HTTPS mode. If you look at the SMSTS log while the download is happening, you will see it looking for a cert for every file it is downloading, instead of just checking the cert once. If we can get an answer for those who use HTTPS mode (As per Microsoft's own recommendations) that would be great
    Friday, September 05, 2014 8:18 PM
  • We had the same issue and resolved it after enabling the 'Anonymous Authentication' on the Virtual DP.

    Open IIS on the affected DP which is in HTTPS mode -> Select the Virtual DP 'NOCERT_SMS_DP_SMSPKG$ -> Authentication -> Anonymous Authentication -> Enable.

    This should resolve the issue as it did for us.

    • Proposed as answer by Ferranti ICT Thursday, February 05, 2015 1:47 PM
    Wednesday, October 01, 2014 1:49 PM
  • I am also experiencing this issue - and have enabled HTTPS on all our DPs. I followed the steps provided by GeoKG and it did not resolved our issue. This download time is ridiculous and adds 20-30 minutes to all task sequences that are initiated from within the Windows Operating system.

    Anyone have any updates on this?

    Tuesday, October 07, 2014 12:31 PM
  • Same here.

    Any updates?

    Issue persists with SCCM 2012 R2 SP1 CU1. 

    Enabling anonymous authentication doesn't work.

    Wednesday, December 30, 2015 3:08 PM
  • Have you already examined smsts.log and IIS logs of the DP where the files were downloaded from? Do you see anything in there that might cause that delay (cert checking etc). Wireshark can also be useful (see my reply above).

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, December 30, 2015 3:13 PM
  • I am in the same boat.

    Have you figured this one out?

    It is only in my lab but it is seriously slowing down my image creation and testing!

    Monday, January 25, 2016 6:49 PM
  • I am in the same boat


    What have you examined so far?

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, January 26, 2016 7:15 AM
  • Same here.

    Any updates?

    Issue persists with SCCM 2012 R2 SP1 CU1. 

    Enabling anonymous authentication doesn't work.

    Same Situation here at a Customer...

    Any News ?

    Monday, February 29, 2016 12:34 PM
  • Same question here ... I already provided some initial troubleshooting steps.  What have you already checked so far?

    Torsten Meringer | http://www.mssccmfaq.de

    Monday, February 29, 2016 1:32 PM
  • Changed DP from https to http.

    Which IIS Logs should I check?

    I can check the smsts.log after the Installation finishs...

    Monday, February 29, 2016 1:49 PM
  • I know it is an old thread. Did you manage to solve this problem?
    Friday, July 08, 2016 12:35 PM
  • Hi Torsten,

    Just an apology sorry it took me an age to reply!

    As it was a lab setup I scrapped it and re configured, no issues now.

    Thanks again for the quick reply.


    Cheers,

    Richie

    Consultant

    Blog: http://www.sccmog.com  LinkedIn:

    Note: Posts are just here to either get an answer or help with someone with an answer. ConfigMgr FTW!

    Sunday, November 06, 2016 9:25 AM
  • Hi Torsten

    I have the same issue in my enviroment. I run SCCM1610 fully updated.

    When running TS from PXE the download speed is normal. When I run the TS from within Windows, download is extremely slow (But state store capture to SMP is fast).

    Nothing interresting to see in my iis -logs, but my smsts.log is running wild! What I see is the TS constantly checking sertificates with success. Even when downloading a single small file the cert checs are running constantly.

    Any ideas?


    Thursday, February 09, 2017 9:14 AM
  • We had the same issue and resolved it after enabling the 'Anonymous Authentication' on the Virtual DP.

    Open IIS on the affected DP which is in HTTPS mode -> Select the Virtual DP 'NOCERT_SMS_DP_SMSPKG$ -> Authentication -> Anonymous Authentication -> Enable.

    This should resolve the issue as it did for us.


    This fixed it for me too!
    Saturday, February 11, 2017 11:05 AM
  • I allready tried this solution, still no cigar. Or more correctly: It did boost the speed a litle bit but not much.

    The only abnormal activity I can see is the constant checking of certificates.

    I started a new thread for our problem: https://social.technet.microsoft.com/Forums/en-US/cafe94d1-0fdd-4220-b363-92a8692bb63c/task-sequence-downloading-packages-from-within-windows-extremely-slow?forum=ConfigMgrCBGeneral

    Monday, February 13, 2017 11:44 AM
  • I have also got issues downloading the MDT package in 1610. Not had a problem on previous version but it just takes ages on this client site. Option to connect anonymously appears to of been removed, not that that is a fix its a sticking plaster. DP running in HTTP not HTTPS.

    I would say its an issue with downloading small files. MDT package is small files and if you watch the DP traffic there is only 100+kb going out when the devices is downloading MDT package. When it gets to the WIM file it goes up to 800Mbps. When we get to the driver pack, again smaller files were in the utalising 100kbs to 5mbps Max.

    I'm using the MDT boot images but they are using the 1607 ADK boot file versions. Not had a problem with these before. I have also added the NIC to the boot image incase the one in the boot image was a bit iffy.


    Tuesday, February 21, 2017 10:14 AM
  • So I have been thinking about this issue every time I see a comment come in on this post.. Although it is no longer affecting my self as I have since upgraded my lab quite a few times either due to breaking it or just cleaning up :)

    There is now a new Task sequence variable.

    SMSTSPersistContent

    You could set this at the beginning of your task sequence to cache the MDT package after the first download.

    This i know not ideal would then allow the TS to refer back to the package instead of downloading it every time!

    Secondly, now this is the slightly mad idea but I'm trying to come up with a solution for it:

    Why not Zip the MDT toolkit within the toolkit folder..... then Unzip it on the fly... This would then download as one file...

    You would have to edit the BDD_Autorun.inf I believe (not 100% on this just thinking on the fly?) in the MDT package to call a PowerShell or VBS script perhaps to do this and then call the BDD_Autorun.wsf?(don't forget to pop PowerShell into the boot image.)

    Look these are just ideas, but i think I might be onto something here..

    I know the likes of Torsten are watching this post so I'm sure he will correct me where I am going way to far outside the box!


    Cheers,
    Richie
    Consultant
    Blog: http://www.sccmog.com  LinkedIn:

    Note: Posts are just here to either get an answer or help with someone with an answer. ConfigMgr FTW!

    Tuesday, February 21, 2017 10:45 AM
  • The issue is not just with MDT but any package with lots of small files.

    I have just made this change to IIS and now everything is downloading rapidly.

    SMS_DP_SMSPKG$ -> Authentication -> Anonymous Authentication -> Enable.

    My 63 min build before this setting change is now down to 23mins :)

    this is defernatley a sticking plaster not a real fix.

    Tuesday, February 21, 2017 1:04 PM
  • Very true you don't want that on for security reasons, I've only experienced it with the toolkit package as this issue was effecting me in my Lab. I will have a play with what I mentioned though and post it on my blog if I succeed.

    Cheers,
    Richie
    Consultant
    Blog: http://www.sccmog.com  LinkedIn:

    Note: Posts are just here to either get an answer or help with someone with an answer. ConfigMgr FTW!

    Tuesday, February 21, 2017 1:14 PM
  • I have allready done this with no success.

    Right now I'm in contact with Microsoft Pro Support, hoping to solve this problem.

    All my updates on this issue will be posted on this thread:

    https://social.technet.microsoft.com/Forums/en-US/cafe94d1-0fdd-4220-b363-92a8692bb63c/task-sequence-downloading-packages-from-within-windows-extremely-slow?forum=ConfigMgrCBGeneral

    Tuesday, February 21, 2017 1:15 PM
  • If I change  SMS_DP_SMSPKG$ -> Authentication -> Anonymous Authentication -> Enable.

    after 24 hours it reverts to disabled. anyone know how to prevent the switch back?

    Thursday, February 23, 2017 10:18 AM
  • If I change  SMS_DP_SMSPKG$ -> Authentication -> Anonymous Authentication -> Enable.

    after 24 hours it reverts to disabled. anyone know how to prevent the switch back?

    Hi Gilbert,

    This is because the DP settings in CfgMgr are not set to allow Anonymous access.

    Go to your CfgMgr GUI and click Administration, Then Distribution Points, right click the DP you are wanting to make this change to and click properties.

    On the General Tab bellow HTTP tick the check box for "Allow clients to connect anonymously".

    This though is a security risk so I would still try to resolve the issue that is causing you to assign this setting.


    Cheers,
    Richie
    Consultant
    Blog: http://www.sccmog.com  LinkedIn:

    Note: Posts are just here to either get an answer or help with someone with an answer. ConfigMgr FTW!

    Thursday, February 23, 2017 11:11 AM
  • spookey, Ive just set the setting, Didn't see it had moved up on that page. ;)

    thought it had been dropped as an option.

    all sorted now.

    Thursday, February 23, 2017 11:18 AM
  • I've finally found a solution to this problem that works in most scenarios.

    It looks like this problem is caused by how the cm client downloads files initiated from a task sequence from within windows.
    When testing the same 400+ files package as an application package deployment the package speed is as expected. It controls the client certs for every file, but only once.

    My solution is to switch from “Download content locally when needed by the running task sequence” to “Download all content locally before starting task sequence” under the Distribution Points tab in the TS deployment.

    This solution will not work in all scenarios. If you have TS deployments that should be available to run from windows and pxe you need to make seperate deployments for "Only Configuration Manager Clients" with the setting to “Download content locally when needed by the running task sequence” and "Only media and PXE" where the setting is set to “Download all content locally before starting task sequence”

    See this thread for more info: https://social.technet.microsoft.com/Forums/en-US/cafe94d1-0fdd-4220-b363-92a8692bb63c/task-sequence-downloading-packages-from-within-windows-extremely-slow?forum=ConfigMgrCBGeneral

    Thursday, March 02, 2017 1:06 PM