SxS error when sequencing Adobe CS3 apps


  • Hi,

    I'm trying to sequence the Adobe CS3 apps to distribute in our computer labs. However, I've yet to get these guys to work. Every time I do the sequencing, it fails for me with a 53256 error. Looking at the log, I find (space added to prevent smilies) :

    [09/06/2007 10:52:13 WRN VFSX] SxSPE:: parseUTF : Unsupported UTF format for file Q:\ADOBECS3.LAB\PHOTOSHP\Adobe Photoshop CS3\FileInfo.dll (format # 3).

    Adding FileInfo.dll to the ignore list doesn't seem to make the sequencing work -- however, if I delete FileInfo.dll, sequencing *does* complete. I can even launch the app. Of course, then it doesn't work right, as it's missing its DLL.

    Any suggestions on this one? I'm at wit's end. Why would the sequencer care if a DLL uses UTF?

    I'm running Sequencer 4.2, build 303 on a Windows XP machine. Not that it should matter, but I've tried this on both a VMWare image (hosted on XP) and in Parallels (hosted on OS X).

    Thursday, September 6, 2007 4:06 PM


All replies

  • Make sure that the setup.exe has stoped running when the PhotoShop CS3 sequence was saved. The setup process can lock certain files including fileinfo.dll.


    Sanity check that one and let me know ..... else watch the install process with procmon to see if you can see and process holding open that file.



    Justin Zarb  

    Thursday, September 6, 2007 10:18 PM
  • This is something I've seen before and is something  a couple of the guys here are looking at.  So far I haven't seen a way to virtualize CS3 successfully but I'm hoping we'll have an answer soon.  As soon as we get something concrete I'll be sure to post it.


    J.C. Hornbeck, MCSE: Security

    Microsoft Corporation


    Monday, September 10, 2007 3:24 PM
  • Thanks! I won't burn any more hours trying to sequence it until I hear a bit more...

    Monday, September 10, 2007 4:11 PM

    I have a strange feeling this might resolve your issue:



    I also commented on this at


    Hope this helps.


    J.C. Hornbeck, MCSE: Security

    Microsoft Corporation

    The SoftGrid Team blog:

    The SMS & MOM Team blog:


    Wednesday, September 19, 2007 1:18 PM
  • Yup! That did the trick. FWIW, I used PE Explorer from Heaven Tools to kill the manifest. If anyone's interested, here's my modified FileInfo.dll:

    (Standard caveats about downloading files from strangers apply. If the Adobe guys get angry about me putting that online, it might go away again.)

    Thanks for the heads-up!
    Monday, September 24, 2007 8:19 PM
  • One final note: the broken FileInfo.dll will likely appear both in C and in Q -- be sure to fix both of them.
    Monday, September 24, 2007 8:21 PM
  • Awesome, thanks for the update Nathan.  Glad you were able to get this working.


    J.C. Hornbeck, MCSE: Security

    Microsoft Corporation

    The SoftGrid Team blog:

    The SMS & MOM Team blog:


    Tuesday, September 25, 2007 1:51 PM
  • I have the same problem with Acrobat 8 Pro.

    The log file complained about FileInfo.dll which I replaced as Nathan sugested.

    Now I no longer get an error on that File, Now I get the same Error on versioncueui.dll.


    I guess I'll have to "fix" that one my self.




    Tuesday, October 2, 2007 1:53 PM
  • Hello, I can see where the manifest was deleted from the other dll by comparing the 2 but when I looked into the versioncueui.dll I could not find the same thing.  Did you have any luck "fixing" it?


    I also noticed the error seemed  a little diffent only because the fromat # has changed from 3 to 4.


    [10/12/2007 16:28:22 WRN VFSX] SxSPE:Stick out tonguearseUTF : Unsupported UTF format for file Q:\acro8\Adobe\Acrobat 8.0\Acrobat\versioncueui.dll (format # 4).



    Friday, October 12, 2007 8:33 PM
  • I did find the "maifest" & delete it which resolved the error in sequencing.
    Sadly the app didnt actualy work in the end Sad

    Oh well never mind,

    Sunday, October 14, 2007 10:57 AM
  • What happened with the app in the end? We've found the apps work just fine, though sequencing takes a long, long time -- for the whole suite, it was sequencing blocks for around 48 hours.
    Tuesday, October 16, 2007 3:31 PM
  • Hi,

    I've sequenced Adobe Flash CS3 the same way as described above and got it working, BUT it only works on certain computers. On the computer where it fails, all the other CS3 Flash program works (Bridge, Device Central, Video Encoder etc) but when I try to launch Flash CS3 Pro I get Launch failed. Below is what the log said:


    [10/16/2007 15:24:47.779 VSCM INF] {tid=1590}
    Starting automatic service 'Bonjour Service'.

    [10/16/2007 15:24:49.013 SWAP INF] {hap=E6:app=Adobe Flash CS3 Professional 055:tid=1590:usr=danand}
    Elapsed time for upload: 3.609 seconds

    [10/16/2007 15:24:49.466 ???? ERR] {tid=1590:usr=danand}
    Unable to CreateProcess (rc 0060922C-800736B1)

    [10/16/2007 15:24:49.466 SWAP ERR] {hap=E6:app=Adobe Flash CS3 Professional 055:tid=1590:usr=danand}
    The client could not launch Q:\flashcs3_055\flash\Adobe Flash CS3\Flash.exe (rc 0060922C-800736B1, last error 0).

    [10/16/2007 15:25:03.949 TRAY ERR] {tid=2D4:usr=danand}
    The SoftGrid Client could not launch Adobe Flash CS3 Professional 055.


    I've tried making the package again but got the same error. The computers that I've tried on are identical so I tried to log on with my user account and I got the same error. Strange.... Why does it work on my computer and not the users? Please help I'm getting frustrated.




    Monday, October 22, 2007 6:08 AM
  • What happened with the app in the end?

    It packaged OK DElivered Ok but then could not create a PDF from a word document as it couldnt load a module.

    I'm guessing it was having problems with comunicating  with word across the virtulisation barrier.

    I'm going to have a longer look at this some time but I've got other things that need work just now...

    Is it just me or does any one elese find it frustrating that message boards let you put all sorts of wizzy fonts Smilies & Colures in a text but have no spell checker......
    Monday, October 22, 2007 10:03 AM
  • I dont know if anyone else has had this issue yet but after I had sequenced CS3 (replacing the dlls that had bad manifests) I went back in to Acrobat to run updates for CS3.  I made the mistake of not replacing those same dlls after the updates so when I stopped monitering, it bombed out on FileInfo.dll again.  Now since I had already installed the updates, my only choice was to revert to a clean vmware image so they could reinstalled. 


    You can open the SFT back up to do upgrades on the package but you cant apply CS3 updates unless CS3 is actually installed.  That means I will have to completely reinstall CS3, how Im going to get it to the exact state it was in when I sequenced it Im not surem, then open the SFT for upgrade and continue.


    The safest bet would be to just resequence the entire thing with updates but given that CS3 Design takes me more then 40 hours to sequence, thats not something Im looking forward to. 

    Friday, October 26, 2007 12:30 PM