locked
SharePoint 2010 Timer service was unable to re-start after Reboot RRS feed

  • Question

  • When I was working on SharePoint 2010 Timer service, It was stuck in ‘Stopping’ status for nearly a day and was unable to re-start so I have rebooted the system but still the Timer Service is not getting  Started.

    Could anybody tell the reason and solution for it..

    Tuesday, April 24, 2012 9:41 AM

All replies

  • What account does the sptimerv4 service run under?

    Please check this http://www.wictorwilen.se/Post/Fix-the-SharePoint-DCOM-10016-error-on-Windows-Server-2008-R2.aspx

    1. Corrected DCOM error if this is occurring following above article.
    2. Cleanly stopped sptimerv4 service from service manager.
    3. Restarted timer service

    Check this also http://technet.microsoft.com/en-us/library/ee924649.aspx
    Tuesday, April 24, 2012 9:48 AM
  • Hi -vijay,

    You can try to basically do the following steps:

    1. Open Services by using services.msc or Start > Administrative Tools > Services)
    2. Right click SharePoint 2010 Timer service and then select Properties.
    3. In the SharePoint 2010 Timer Properties windows, click Log On tab.
    4. Select This account and type your account carefully.
    5. Back to General tab, at the Startup type setting, select Automatic.
    6. Click Recovery tab, keep default at the First failure and Second failure. At the Subsequent failure, select Run a Program and then click Browse under Run program and navigate to "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN\OWSTIMER.EXE". You can copy this path and then paste.
    7. Right click SharePoint 2010 Timer service and select Restart.

    Hope these steps help you resolve the problem.

    Regards,

    T.s


    SharePoint Vietnam | Blog | Twitter

    Tuesday, April 24, 2012 9:51 AM
  • Hi

    what are all the reasons behind this issue ???

    Could anybody point-out all those reasons !

    Tuesday, April 24, 2012 9:58 AM
  • Thuan,

    what are all the reasons behind this issue ???

    Could you point-out all those reasons !

    Tuesday, April 24, 2012 10:01 AM
  • I think there was somthing changed in your Active Directory and this made your service credential account served for SharePoint 2010 Timer service changed. This case is the same case of stopping Web Application when application pool account is changed.

    T.s


    SharePoint Vietnam | Blog | Twitter

    Tuesday, April 24, 2012 10:07 AM
  • Thuan,

    Could you be more specific in your answer ?

    Tuesday, April 24, 2012 10:11 AM
  • You can find Details related to OWSTIMER.EXE in Event Viewer or ULS Logs.
    Thursday, April 26, 2012 3:58 AM