locked
Word 2016 and templates XML RRS feed

  • Question

  • Hi,

    I managed templates for Word according this article:

    https://technet.microsoft.com/en-us/library/cc178976(v=office.14).aspx

    In Word 2016 it stopped working (templates are not deploying to Word 2016) older versions without problem.

    I think, that the problem is, that older Word versions using lcid language code, but 2016 is using UILanguageTag value instead of LCID in configuration XML file.

    <o:featuredcontent lcid="1033" xmlns:o="urn:schemas-microsoft-com:office:office">

    I did not found anywhere anything about this problem.

    Please help! :)

    Thanks.

    Friday, September 23, 2016 7:09 AM

Answers

  • Hi,

    >> I think, that the problem is, that older Word versions using lcid language code, but 2016 is using UILanguageTag value instead of LCID in configuration XML file.

    Based on my testing, this is not the cause. I tried and managed to deploy a template in Word 2016.

    Firstly, I put the XML file and the .dotx template in the same folder, it created the [ProviderName] folder under Custom but it didn't show the customized template.

    After that, I put the XML file and the .dotx template to different folders. For example, put the XML file in D:\Public and put the .dotx template in C:\Users\%username%\Desktop. Changed the following attribute in the XML file from:

    <o:featuredtemplate title="Template 1" source="D:\Public\template.dotx" >

    to:

    <o:featuredtemplate title="Template 1" source="C:\Users\%username%\Desktop\template.dotx" >

    Lastly, I ran the gpupdate /force command and then I can see the custom template now:

    BTW, I also modified the featured templates data from:

    <o:featuredtemplates startdate="2011-03-01" enddate="2013-03-01">

    to:       

    <o:featuredtemplates startdate="2016-03-01" enddate="2019-03-01">

    Hope this helps.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Steve Fan Monday, October 3, 2016 9:07 AM
    • Marked as answer by Steve Fan Tuesday, October 11, 2016 10:02 AM
    Tuesday, September 27, 2016 3:02 AM

All replies

  • Hi,

    >> I think, that the problem is, that older Word versions using lcid language code, but 2016 is using UILanguageTag value instead of LCID in configuration XML file.

    Based on my testing, this is not the cause. I tried and managed to deploy a template in Word 2016.

    Firstly, I put the XML file and the .dotx template in the same folder, it created the [ProviderName] folder under Custom but it didn't show the customized template.

    After that, I put the XML file and the .dotx template to different folders. For example, put the XML file in D:\Public and put the .dotx template in C:\Users\%username%\Desktop. Changed the following attribute in the XML file from:

    <o:featuredtemplate title="Template 1" source="D:\Public\template.dotx" >

    to:

    <o:featuredtemplate title="Template 1" source="C:\Users\%username%\Desktop\template.dotx" >

    Lastly, I ran the gpupdate /force command and then I can see the custom template now:

    BTW, I also modified the featured templates data from:

    <o:featuredtemplates startdate="2011-03-01" enddate="2013-03-01">

    to:       

    <o:featuredtemplates startdate="2016-03-01" enddate="2019-03-01">

    Hope this helps.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Steve Fan Monday, October 3, 2016 9:07 AM
    • Marked as answer by Steve Fan Tuesday, October 11, 2016 10:02 AM
    Tuesday, September 27, 2016 3:02 AM
  • How to apply templates for Visio and Project ? What is the application id for Visio and Project? I tried VO for visio but not working and not sure what is the application id for Project.

    With Regards Shree

    Thursday, May 10, 2018 5:25 AM