locked
Schedule Skype meetings on behalf of meeting room RRS feed

  • Question

  • Hi,

    Environment: Skype for Business (Online), Exchange Online, Outlook 2016 - hybrid with Azure AD Sync

    We have a Room mailbox (let's say "Conf.Room.1"). Some of our users try the following:

    - Create new meeting request within the Room mailbox' calendar

    - Press button "Skype Meeting"

    - Expected result is to create Skype URL connected to the "Conf.Room.1" - and that meeting request comes from "User1 on behalf of Conf.Room.1"

    What happens is that user gets this error message:
           "You do not have permissions to schedule Skype Meetings on behalf of the owner of this account. Please contact the owner of the account to get delegate permissions in Skype for Business"

    So I tried the following:

    - Added "Editor" rights (for end user) to Calendar of Conf.Room.1

    - Enabled Enterprise Voice on Conf.Room.1

    - Enable-CsMeetingRoom on Conf.Room.1

    No avail. Still same error.

    Tried giving Conf.Room.1 a license - and tried finding "Call forwarding" menu option when logged on with that account - but could not find that menu option. As I understand it from all the articles I have read I need to set up delegation in both Outlook and Skype - but until now I believe I have only been able to do it in Outlook (Exchange).

    Reason why they want to do it like this I think is because they have a "conference room device" with a built-in Skype client and they want that one to be logged in at all times. Meaning that they don't want to use their own user to initiate the meeting. Conference room is mostly used by board members without their own account.

    Questions:

    - Are we trying to do something that will never work?

    - Can you see any glitches in what I am doing? I am not a Skype expert at all...

    Regards,

    Tom

    Friday, December 22, 2017 11:25 AM

Answers

  • To configure SFB delegation:

    https://support.microsoft.com/en-us/help/2671103/delegates-can-t-schedule-a-lync-online-meeting-in-office-365-dedicated

    I believe, once you have added SFB Online delegation, your issue would be solved. 

    Saturday, December 23, 2017 3:56 AM
  • Hi jneks,

    Agree with Matrix,

    After the delegate is added, the delegator must sign out and then sign back in to the Skype for Business client.

     

    If the issue persists, please check the following prerequisites of the “delegate Skype for Business meeting” feature:

     

    1. On the owner’s Outlook delegate setting, the delegate (admin assistants) must be listed to have correct delegate permission. To set the permission in the Outlook for Windows (this cannot be set up on the Outlook for Mac client):

    a. Configure the owner’s account on the Outlook for Windows client, click File > Account Settings > Delegate Access > Add.

    b. Find and add the name of the person who is going to be the delegate.

    c. Click the Calendar menu, and select Editor right.

    2. On the owner’s machine, Outlook must be running default profile that align with the current sign-in Skype for Business account.

    3. Both owner and delegate must be running Skype for Business full client, basic client does not support this feature. A full Skype for Business application can only be downloaded from Office 365 ProPlus, Office 365 Enterprise E3, E4 and E5 subscriptions’ portal.

    4. On the owner’s Skype for Business client, the delegate must be listed, this will happen after ExchangeDelegateSync completed. (This is an automatic sync, performed at backend)


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, December 25, 2017 6:00 AM

All replies

  • To configure SFB delegation:

    https://support.microsoft.com/en-us/help/2671103/delegates-can-t-schedule-a-lync-online-meeting-in-office-365-dedicated

    I believe, once you have added SFB Online delegation, your issue would be solved. 

    Saturday, December 23, 2017 3:56 AM
  • Hi jneks,

    Agree with Matrix,

    After the delegate is added, the delegator must sign out and then sign back in to the Skype for Business client.

     

    If the issue persists, please check the following prerequisites of the “delegate Skype for Business meeting” feature:

     

    1. On the owner’s Outlook delegate setting, the delegate (admin assistants) must be listed to have correct delegate permission. To set the permission in the Outlook for Windows (this cannot be set up on the Outlook for Mac client):

    a. Configure the owner’s account on the Outlook for Windows client, click File > Account Settings > Delegate Access > Add.

    b. Find and add the name of the person who is going to be the delegate.

    c. Click the Calendar menu, and select Editor right.

    2. On the owner’s machine, Outlook must be running default profile that align with the current sign-in Skype for Business account.

    3. Both owner and delegate must be running Skype for Business full client, basic client does not support this feature. A full Skype for Business application can only be downloaded from Office 365 ProPlus, Office 365 Enterprise E3, E4 and E5 subscriptions’ portal.

    4. On the owner’s Skype for Business client, the delegate must be listed, this will happen after ExchangeDelegateSync completed. (This is an automatic sync, performed at backend)


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, December 25, 2017 6:00 AM
  • Are there any update for this issue, if the reply is helpful to you, please try to mark it as an answer, it will help others who has similar issue.

    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, December 27, 2017 8:16 AM
  • To configure SFB delegation:

    https://support.microsoft.com/en-us/help/2671103/delegates-can-t-schedule-a-lync-online-meeting-in-office-365-dedicated

    I believe, once you have added SFB Online delegation, your issue would be solved. 

    Hi,

    Thank you for your answer. As it is christmas, and thus not in the office these days I have not answered until now. I also found the article that you referred to, but I could not find the "Call forwarding" option in my full Skype client.

    But I found this article (https://technet.microsoft.com/en-us/library/skype-for-business-online-service-description.aspx?f=255&MSPPError=-2147217396) where it says that Call forwarding (and delegation) is not available when using E3 license (which we are).

    Is it correct to say that E5 license is mandatory to achieve what I want?


    Wednesday, December 27, 2017 9:10 AM
  • Hi jneks,

    Yes, you could use E5 license to achieve it.


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, December 28, 2017 9:14 AM
  • Hi jneks,

    Yes, you could use E5 license to achieve it.


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thanks,

    Could use - or must use? We have only E3 licenses today.

    Regards,

    Tom

    Thursday, December 28, 2017 9:46 AM
  • I cannot find any other way to achieve it ,based on my understanding,you must use E5 license to achieve it.

    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, January 1, 2018 5:33 AM
  • Thank you both! I will then investigate if we should go for E5!

    Regards,

    Tom

    Tuesday, January 2, 2018 8:36 AM
  • So..

    - I gave my user E5 license

    - I enabled Enterprise Voice (EnterpriseVoiceEnabled = True)

    - I am using Skype for Business 2016 MSO.. I think this is Skype for Business Full version and not Basic, I did not find a good way of 100% confirming this, but I think it is the Full version.

    - AllowCallForwarding and EnableDelegation are both set to True in the "Default" VoicePolicy

    - VoicePolicy for my user is empty - thus I think it contains the Default/Global policy?

    - I also tried creating a new VoicePolicy with EnableDelegation and AllowCallForwarding set to True - and granting this to my user

    I still cannot see the "Call forwarding" menu option in my Skype for Business.

    Anybody know why? Would the next step for me be to contact Microsoft?

    Tom

    Friday, January 12, 2018 11:10 AM