locked
No client computers have contacted WSUS server RRS feed

  • Question

  • Hi All,

    I stood up a 2012R2 WSUS server several weeks ago and although synchronizations are going well "no client PCs or servers have contacted the server."  I looked in the Application log and it verified this situation displaying a warning event ID 13051.  What did I fail to configure?


    Francisco Mercado Jr.

    Thursday, July 2, 2015 5:19 PM

Answers

  • by default, no, they will have to wait until next Wednesday. but if you have set the policy to re-check and re-apply missed updates you can work around it.

    you can also have systems power on through power management for patching, although this one rarely works as expected.

    go through the WSUS GPOs, you will see options on how to handle missed updates.

    • Proposed as answer by DonPick Thursday, July 9, 2015 9:18 PM
    • Marked as answer by dvua Friday, July 10, 2015 3:44 PM
    Thursday, July 9, 2015 7:21 PM

All replies

  • Have you configured client machines (via registry settings or Group Policy), to refer to your WSUS?

    Client machines do not "discover" WSUS through any mechanism - each machine must be configured for the hostname (or IP address) of a WSUS, otherwise the WUAgent on the client will continue to default to windowsupdate.com


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Thursday, July 2, 2015 9:20 PM
  • Yes I have.  I configured a test group and have 6 PCs in it.  I applied a windows update GPO and its location points to the newly created WSUS server.

    Francisco Mercado Jr.

    Friday, July 3, 2015 4:40 PM
  • did you include the proper port number in the GPO? 8530 if you're not using SSL

    use rsop.msc on one of the clients to ensure the GPO is actually propagating down to the client as expected

    Friday, July 3, 2015 5:18 PM
  • Hi,

    First thing to check, the wsus client log : %windir%\Windowsupdate.log

    help about how to read it : https://support.microsoft.com/en-en/kb/902093/en?wa=wsignin1.0

    It will tell you where it's blocking, and eventually give you error code.

    Here is a goog troubleshooting guide : http://social.technet.microsoft.com/wiki/contents/articles/2491.wsus-troubleshooting-survival-guide.aspx

    Julien

    Friday, July 3, 2015 10:36 PM
  • I have WSUS under "Update Source and Proxy Server" port number is set to 8530. Computers is set to "Use the Update Services Console."

    Francisco Mercado Jr.

    Saturday, July 4, 2015 8:11 PM
  • I have WSUS under "Update Source and Proxy Server" port number is set to 8530. Computers is set to "Use the Update Services Console."

    No, the port 8530 setting does not refer to "update source and proxy server".

    WSUS itself, if you use WS2012 or WS2012R2, is published/listening on port 8530.

    Older versions of WSUS listened on port 80.

    When you set the GPO for clients configurations:
    "Specify Intranet Microsoft update service location", and in this, you set the address of your WSUS (so your clients can locate/connect to your WSUS), because you are using WS2012/WS2012R2 you must specify the 8530 port, for this setting.

    e.g.:
    Set the intranet update service for detecting updates: http://wsus-01.contoso.com:8530
    Set the intranet statistics server: http://wsus-01.contoso.com:8530

    https://technet.microsoft.com/en-us/library/dn595129.aspx#BKMK_Comp14


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    • Proposed as answer by DonPick Thursday, July 9, 2015 9:17 PM
    Sunday, July 5, 2015 4:43 AM
  • Hi,

    For my 2012R2 WSUS server, I did not have port 8530 specified.  I have set it and will update you over the next 24 to 48 hours as to the status.


    Francisco Mercado Jr.

    Monday, July 6, 2015 1:51 AM
  • Setting the port in the GPO did the trick for me, thank you.

    Question, the computers that I have associated with the wsus test group policy, should I be able to go into control panel\window update\ and from within the box search for updates?  I am getting an error code 80072efd and am not sure if this is do to my wsus gpo config or something else that I need to worry about.


    Francisco Mercado Jr.

    Thursday, July 9, 2015 4:14 PM
  • Setting the port in the GPO did the trick for me, thank you.

    Question, the computers that I have associated with the wsus test group policy, should I be able to go into control panel\window update\ and from within the box search for updates?  I am getting an error code 80072efd and am not sure if this is do to my wsus gpo config or something else that I need to worry about.


    Francisco Mercado Jr.

    You do have to clear the C:\Windows\SoftwareDistribution folder if you had clients pointing to Microsoft/Windows update and/or and older version of WSUS (e.g. 3.2). First stop the wuauserv then remove the contents of the folder and restart the wuauserv. That should clear up the error code you are seeing on the clients. Hope this helps.

    • Proposed as answer by DonPick Thursday, July 9, 2015 9:17 PM
    Thursday, July 9, 2015 5:35 PM
  • Yup, that worked for me!  One more question please, I have a wsus policy that will download and install updates on workstations at 1am on Wednesdays.  Those machines that are powered down and not on the corporate network at that time will pull the updates once they are powered on later that morning?

    Francisco Mercado Jr.

    Thursday, July 9, 2015 6:05 PM
  • by default, no, they will have to wait until next Wednesday. but if you have set the policy to re-check and re-apply missed updates you can work around it.

    you can also have systems power on through power management for patching, although this one rarely works as expected.

    go through the WSUS GPOs, you will see options on how to handle missed updates.

    • Proposed as answer by DonPick Thursday, July 9, 2015 9:18 PM
    • Marked as answer by dvua Friday, July 10, 2015 3:44 PM
    Thursday, July 9, 2015 7:21 PM