locked
Gadgets Hidden with Remote Desktop RRS feed

  • Question

  • Hi,

    When I log into my Windows 7 Hyper-V VM via Remote Desktop, I notice that the Sidebar Gadgets do not display on the Desktop.

    If I right-click on the Desktop and select Gadgets, they then appear.

    Is there any way to ensure that when logging in via Remote Desktop that the Gadgets appear on the Desktop without having to right-click the Desktop and select Gadgets?

    If I add a RemoteFX 3D Videao Adapter to the VM, then I do not experience this problem via Remote Desktop. However, I have to install the Remote Desktop Services Role on the Hyper-V Server and add the Remote Desktop Virtualisation Host Role Service with RemoteFX and Core Services in order to add the RemoteFX 3D Videao Adapter to the VM. This seems to negatively affect performance of the Hyper-V Server and its virtual machines. Also, I#m not sure if the Remote Desktop Services Role will function without a Remote Desktop License, which I don't have.

    Also, the Gadgets display fine when going through the Hyper-V console.

    Any thoughts will be greatly apprecaited.

    Kind Regards,

    Johan Küstner

    Friday, July 8, 2011 8:14 AM

Answers

  • Hi,

     

    First, I suggest that you may try to right click the Gadgets and set Gadgets to “Always on top” as a test, then check whether the issue disappears.

     

    “If I right-click on the Desktop and select Gadgets, they then appear.”

     

    I suspect that Gadget didn’t start up at that time. So I suggest you may check the whether sidebar.exe was running in Task Manager before you do that.

     

    Also you may add C:\Program Files\Windows Sidebar\sidebar.exe in to Startup and it should work fine, I have tested it in my computer.

     

    Hope that helps


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, July 14, 2011 2:59 AM

All replies

  • Hi,

     

    First, I suggest that you may try to right click the Gadgets and set Gadgets to “Always on top” as a test, then check whether the issue disappears.

     

    “If I right-click on the Desktop and select Gadgets, they then appear.”

     

    I suspect that Gadget didn’t start up at that time. So I suggest you may check the whether sidebar.exe was running in Task Manager before you do that.

     

    Also you may add C:\Program Files\Windows Sidebar\sidebar.exe in to Startup and it should work fine, I have tested it in my computer.

     

    Hope that helps


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, July 14, 2011 2:59 AM
  • Hi Zhen,

    Thank you very much for your response. I have tried specifying that each gadget appear always on top. The trouble with that is that they will always be on top of every window, which I don't want, as they can get in the way. Therefore, I removed this setting for each gadget.

    I will have a look the next time I start the machine up if sidebar.exe is running or not. If it is not running after a few minutes, I will add sidebar.exe to Startup. I will let you know how it goes.

    Regards,

    Johan.

    Thursday, July 14, 2011 8:12 AM
  • Hi Zhen,

    Indeed, sidebar.exe was not running at startup and I have now added C:\Program Files\Windows Sidebar\sidebar.exe to Startup.

    Regards

    Johan



    Friday, July 15, 2011 7:28 AM
  • Hi Johan,

     

    Glad to see that helpful for you!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Sunday, July 17, 2011 12:45 PM