DPM restore error - Cannot detect the volume RRS feed

  • Question

  • DPM 2012 R2.  I pushed the agent to this particular server via the DPM console, no problem. Set up protection group and backups are occurring without issues. Agent status always shows 'OK' in the DPM console.

    I want to restore data from volume E: to volume G: on the same server. Stepping through the recovery process, DPM lets me browse to the G: volume to recover to alternate location, so clearly it can see the volume. I can access it via other means, as well (e.g. Admin ($) share, etc.).

    However, when I try to recover, I always get error: "DPM cannot detect the volume G:\ on server 'xxxx' (ID: 31085)"

    The error recommends refresh the state using 'Get-Datatsource -ProductionServer -Inquire'.

    I haven't been able to get this command to work. If I run 'get-dpmdatasource -Inquire', it prompts for a production server name. Any hostname or fqdn results in the following error:

    Get-DPMDatasource : Cannot bind parameter 'ProductionServer'. Cannot convert the "server fqdn here" value of type "System.String" to type "Microsoft .Internal.EnterpriseStorage.Dls.UI.ObjectModel.OMCommon.ProductionServer".
    At line:1 char:1
    + get-dpmdatasource -Inquire
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [Get-DPMDatasource], Parame
        + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,Microsoft.Interna


    I've tried a number of iterations, but can't get the command to run. A simple 'get-production server' command works fine but only gives basic info.

    Any help appreciated.

    Wednesday, June 8, 2016 6:28 PM

All replies

  • I've made it a little farther, but still no luck...

    The 'get-datasource' command shows both volumes (E: and G:) for this server, but still can't get the restore to work.

    I still haven't figured out the proper syntax to pass the 'Inquire' command, but have no idea fi this will help or not at this point...

    Wednesday, June 8, 2016 8:20 PM
  • Hi,

    The command has to be done in two commands to first put your production server into a variable.

    Run the following to rows in an elevated powershell-session on your DPM-server (and replace MyProdServer with the name of your server inside the quotes).

    $ProdServer = Get-ProductionServer | Where-Object {$_.ServerName -eq "MyProdServer"}
    Get-DPMDatasource -ProductionServer $ProdServer -Inquire
    Kind Regards
    Markus Eliasson

    • Edited by MarkusEliasson Friday, June 10, 2016 12:46 PM Formatting fix
    Friday, June 10, 2016 12:45 PM
  • Finally able to run the command it recommends, but unfortunately, I'm still getting that the same error as the OP, "DPM cannot detect the volume G:\ on server 'xxxx' (ID: 31085)"
    Tuesday, June 5, 2018 8:51 PM