none
Auto send welcome email to new staff in Exchang 2013

    Question

  • Dear Expert Exchange Team,

    I would like to configure auto send welcome email to new staff who join with my company, so do you have another method to configure ? please me thank in advance.


    Note: i try to configure follow this block but didn't work in my environment, my current exchange server setup Mailbox and CAS together. https://blogs.technet.microsoft.com/sukum/2014/07/10/send-welcome-email-to-new-mailbox-new-users/ 

    Warning Message when create new user email.

    the cmdlet extension agent with the index 5 has thrown an exception in OnComplete(). The exception is: Microsoft.Exchange.Provisioning.ProvisioningException: ScriptingAgent: Exception thrown while invoking scriptlet for OnComplete API: Exception calling "Send" with "1" argument(s): "Transaction failed. The server response was: 5.6.0 Invalid message content". ---> System.Management.Automation.MethodInvocationException: Exception calling "Send" with "1" argument(s): "Transaction failed. The server response was: 5.6.0 Invalid message content" ---> System.Net.Mail.SmtpException: Transaction failed. The server response was: 5.6.0 Invalid message content at System.Net.Mail.DataStopCommand.CheckResponse(SmtpStatusCode statusCode, String serverResponse) at System.Net.Mail.DataStopCommand.Send(SmtpConnection conn) at System.Net.Mail.SmtpClient.Send(MailMessage message) at CallSite.Target(Closure , CallSite , Object , Object ) --- End of inner exception stack trace --- at System.Management.Automation.ExceptionHandlingOps.ConvertToMethodInvocationException(Exception exception, Type typeToThrow, String methodName, Int32 numArgs, MemberInfo memberInfo) at CallSite.Target(Closure , CallSite , Object , Object ) at System.Dynamic.UpdateDelegates.UpdateAndExecute2[T0,T1,TRet](CallSite site, T0 arg0, T1 arg1) at System.Management.Automation.Interpreter.DynamicInstruction`3.Run(InterpretedFrame frame) at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame) --- End of inner exception stack trace --- at Microsoft.Exchange.ProvisioningAgent.ScriptingAgentHandler.OnComplete(Boolean succeeded, Exception e) at Microsoft.Exchange.Provisioning.ProvisioningLayer.OnCompleteImpl(Task task, Boolean succeeded, Exception exception)
    button. There is 1 message in the pop-up window. 1: Warning,The cmdlet extension agent with the index 5 has thrown an exception in OnComplete‎()‎. The exception is: Microsoft.Exchange.Provisioning.ProvisioningException: ScriptingAgent: Exception thrown while invoking scriptlet for OnComplete API: Exception calling "Send" with "1" argument‎(s)‎: "Transaction failed. The server response was: 5.6.0 Invalid message content". ---> System.Management.Automation.MethodInvocationException: Exception calling "Send" with "1" argument‎(s)‎: "Transaction failed. The server response was: 5.6.0 Invalid message content" ---> System.Net.Mail.SmtpException: Transaction failed. The server response was: 5.6.0 Invalid message content at System.Net.Mail.DataStopCommand.CheckResponse‎(SmtpStatusCode statusCode, String serverResponse)‎ at System.Net.Mail.DataStopCommand.Send‎(SmtpConnection conn)‎ at System.Net.Mail.SmtpClient.Send‎(MailMessage message)‎ at CallSite.Target‎(Closure , CallSite , Object , Object )‎ --- End of inner exception stack trace --- at System.Management.Automation.ExceptionHandlingOps.ConvertToMethodInvocationException‎(Exception exception, Type typeToThrow, String methodName, Int32 numArgs, MemberInfo memberInfo)‎ at CallSite.Target‎(Closure , CallSite , Object , Object )‎ at System.Dynamic.UpdateDelegates.UpdateAndExecute2[T0,T1,TRet]‎(CallSite site, T0 arg0, T1 arg1)‎ at System.Management.Automation.Interpreter.DynamicInstruction`3.Run‎(InterpretedFrame frame)‎ at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run‎(InterpretedFrame frame)‎ --- End of inner exception stack trace --- at Microsoft.Exchange.ProvisioningAgent.ScriptingAgentHandler.OnComplete‎(Boolean succeeded, Exception e)‎ at Microsoft.Exchange.Provisioning.ProvisioningLayer.OnCompleteImpl‎(Task task, Boolean succeeded, Exception exception)‎

    Tuesday, October 3, 2017 2:49 AM

Answers

  • https://answers.microsoft.com/en-us/office/forum/office_2007-outlook/554-560-invalid-content-these-messages-are-sent/32cfd98e-e0a8-4a88-9826-5fe1a14f5c6e?auth=1

    Try with a very simple msg - make sure that it works with that first....


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, October 4, 2017 12:33 AM

All replies

  • https://answers.microsoft.com/en-us/office/forum/office_2007-outlook/554-560-invalid-content-these-messages-are-sent/32cfd98e-e0a8-4a88-9826-5fe1a14f5c6e?auth=1

    Try with a very simple msg - make sure that it works with that first....


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, October 4, 2017 12:33 AM
  • Hi Kimnou,

    For the issue "5.6.0 Invalid message content", generally it may be caused by the following reasons:

    1.The message is being blocked by a content filtering policy on the Exchange Server
    2. This could be an anti-malware plugin

    If there are, you can check these settings and disable them temporally and check if the script works as expected.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    Wednesday, October 4, 2017 3:39 AM
    Moderator
  • Hi Kimnou,

    I'm just writing to check how's everything going? If you have any questions or needed further help on this issue, please feel free to post back. If the issue has been resolved, please mark the helpful replies as answers, this will make answer searching in the forum easier and be beneficial to other community members as well.

     

    Thanks for your understanding.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 17, 2017 10:00 AM
    Moderator
  • Dear Niko Cheng,

    Thank for your support but still didn't, so i changed script configuration now it work for me.

    Link reference https://blogs.msdn.microsoft.com/emeamsgdev/2014/07/23/exchange-automating-a-welcome-email-to-new-users/

     

    Thursday, October 19, 2017 7:16 AM
  • Hi Kimnou,

    Great, thanks for your sharing.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 19, 2017 7:42 AM
    Moderator