none
Unable to disable Sticky keys through GPO

    Question

  • Unable to disable Sticky key from registry.

    Have modified sticky key value from 510 to 506 it just un-checks the option.

    I need a computer base gpo which disables it completely, can anyone suggest 

    Tuesday, July 10, 2018 9:30 AM

Answers

  • Hi Eshaan,

    Please try to deny "sethc.exe" file as I achieved same in my test environment by denying "NT Authority\System".

    Tuesday, July 17, 2018 7:17 AM

All replies

  • Also Navigate to HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response key in the left pane.
    Locate Flags in the right pane, double click it and set its value to 122.

    And Go to the HKEY_CURRENT_USER\Control Panel\Accessibility\ToggleKeys key in the left pane.
    Locate Flags in the right pane and set its value to 58.
    Tuesday, July 10, 2018 10:14 AM
  • Have tried that also still users are able to enable it. 

    Also tried to 

    Computer Configuration > Policies > Windows Settings > Security Settings > File System>sethc.exe as denied still user is able to check it from the log on screen from Ease of Access.


    Tuesday, July 10, 2018 10:22 AM
  • Hello,

    Thanks for your post.

    According to my knowledge, there is no group policy as such to disable Sticky keys. But we could use group policy preference to set the registry. Could you please tell me that if you want to disable sticky keys locally or remotely?

    I am not sure that where the register did you modify, the HKEY_CURRECT_USER or HKEY_USERS?

    So, please try the following two paths to see if they can help. If you have try one of the paths, please try another path.

    Path 1:

    Disable Sticky Keys for the current user (usually me): [HKEY_CURRENT_USER\Control Panel\Accessibility\StickyKeys] “Flags”=”506”

    Disable Filter Keys [HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response] “Flags”=”122”

    Disable Toggle Keys [HKEY_CURRENT_USER\Control Panel\Accessibility\ToggleKeys] “Flags”=”58”

    Path 2:

    Disable Sticky Keys for the all new user: [HKEY_USERS\.DEFAULT\Control Panel\Accessibility\StickyKeys] “Flags”=”506”

    Disable Filter Keys [HKEY_USERS\.DEFAULT\Control Panel\Accessibility\Keyboard Response] “Flags”=”122”

    Disable Toggle Keys [HKEY_USERS\.DEFAULT\Control Panel\Accessibility\ToggleKeys] “Flags”=”58”

    And if it still not work, we can try to use 26 instead of 506 to see if they can help.

    [HKEY_USERS\.DEFAULT\Control Panel\Accessibility\StickyKeys] or [HKEY_CURRENT_USER\Control Panel\Accessibility\StickyKeys] “Flags”=”26”

    Hope above information could help you. If you have anything unclear, please feel free to let me know.

    Best Regards,

    Kallen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 11, 2018 9:18 AM
  • Hi Kallen,



    Have tried both the above scenario's but still if a user is pressing 5 times shift key than he can enable the sticky key, or from the Ease of access console he can enable it again.

    This GPO is just un-checking the option "Turn of Sticky Key". Its no disabling the option if "Turn of Sticky key when shift is pressed 5 times".

    I need a solution which doesn't allow a user to enable sticky key by any means.

    or 

    It should disable the  "Turn of Sticky Key" option along with "Turn of Sticky key when shift is pressed 5 times"


    Friday, July 13, 2018 7:43 AM
  • Hi Eshaan,

    Please try to deny "sethc.exe" file as I achieved same in my test environment by denying "NT Authority\System".

    Tuesday, July 17, 2018 7:17 AM