locked
MDT 2012 - Pre-Deployment File Deletion RRS feed

  • Question

  • Hi,

    I have a small problem with migrating XP to Win 7 using MDT. Basically, I have about 200 machines to migrate but the TS will not allow me to copy user data. The error I get is "A supported previous version of Windows was not found on this computer. Data and settings cannot be restored".

    After a lot of digging around, it seems that the cause is a Program Files (x86) directory on the local disk which was put there by an Outlook Archiving add-on. I'm guessing that when MDT scans the disk, it sees this and 'thinks' it's an x64 OS. I know for a fact that this is the cause of the problem, as, when I delete the folder manually and re-run the TS, it all works perfectly, the migration of data occurs, Win 7 installs and the data is put back - no issues at all.

    Is there a way to configure the TS to remove or ignore this directory before the disk is scanned? I've tried using a command-line rmdir /q but I can't get it to work and, if I'm honest, not entirely sure it will work the way I've done it.

    Hopefully someone can put me out of this misery as I don't particularly want to manually remove it on all machines prior to deployment.

    Thanks

    Paul
    Thursday, May 1, 2014 3:15 PM

All replies

  • Where in the sequence did you put the command to remove the directory? Are these machines all on a domain? You could maybe create a logon script that removes the directory.

    If this post is helpful please vote it as Helpful or click Mark for answer.

    Thursday, May 1, 2014 9:42 PM
  • I don't think it's deleting because the directory is not empty, try using this:

    if exist <PATH> rd <PATH> /s /q

    or

    rd <PATH> /s /q


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    Friday, May 2, 2014 1:44 AM
  • Dan - I've tried putting this command in various different places of the TS. Firstly at the top of the State Capture section and then at Initialization, which hasn't made a difference.

    I don't want to do this as a logon script for the domain as there are already a handful of Win7 machines on the domain, which could cause an issue.

    Frank - rd <PATH> /s /q was what I initially tried and this wasn't successful, neither was the other, but I'm guessing I may not have it in the correct position within the TS?

    Tuesday, May 6, 2014 11:37 AM