none
Cannot open database "SharePoint_config" requested by the login.

All replies

  • Hi,

    Can you please confirm the following things?

    Go to your SQL Server and check the SQL security settings for this users, this users have the server roles: dbcreator, public, securityadmin.

    Also this users must have a User Mapping on the SP_Config DB with db_owner, SPDataAccess, WSS_Content_Application_Pools rights.

    Please confirm that the account mentioned password has changed or expired?

    You can check AD to make sure the account is in good order (not disabled, expired etc.)

    If you believe the password may have be changed you will need to update it check below blog link for more info regarding Managed Accounts

    http://blogs.technet.com/b/wbaer/archive/2010/04/11/managed-accounts.aspx

    Please confirm that if this user is a service account? And spservice is also running the Farm Account and Distributed cache. 

    If the user have all the appropriate permissions you need to check if the SharePoint Server can communicate with your SQL box. Maybe there is some Firewall setting preventing this.

    You can easily check this by creating a basic test udl file (with a user that has enough permissions on SQL databases) on the SharePoint box, like described in this article: http://blogs.msdn.com/b/farukcelik/archive/2007/12/31/basics-first-udl-test.aspx


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Monday, March 06, 2017 10:51 PM
  • Here you go

    https://social.technet.microsoft.com/Forums/office/en-US/3ee7b624-a9c4-4a55-975f-d5e3620daf65/event-id-6389-critical-cannot-open-database-sharepointconfig-requested-by-the-login?forum=sharepointadmin

    http://jinivthakkar.blogspot.com/2014/05/cannot-open-database-sharepointconfig.html


    Please remember to click Mark as Answer on the answer if it helps you

    Monday, March 06, 2017 11:08 PM
  • Hi,

    Can you please confirm the following things?

    Go to your SQL Server and check the SQL security settings for this users, this users have the server roles: dbcreator, public, securityadmin.

    Also this users must have a User Mapping on the SP_Config DB with db_owner, SPDataAccess, WSS_Content_Application_Pools rights.

    No, I can not set those roles: dbcreator becoz I dont have permission

    Please confirm that the account mentioned password has changed or expired?

    no, it doesn't

    You can check AD to make sure the account is in good order (not disabled, expired etc.)

    Please confirm that if this user is a service account? And spservice is also running the Farm Account and Distributed cache. 

    If the user have all the appropriate permissions you need to check if the SharePoint Server can communicate with your SQL box. Maybe there is some Firewall setting preventing this.

    I'd disabled the firewall, also I try to use the SharePoint power Shell, and I got

    The local farm is not accessible. Cmdlets with FeatureDependencyId are not registered.

    Tuesday, March 07, 2017 3:30 PM
  • Looks like your farm admin account lost the permission on the SharePoint_config db. You should fix the permissions.

    • Make Sure account have DBO rights on the SharePoint_Config db
    • SharePoint_config db exist on the SQL server
    • You can access the SQL server from your SharePoint server.


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -Waqas Sarwar(MVP) Blog: http://krossfarm.com

    Tuesday, March 07, 2017 4:16 PM
    Moderator