locked
Remote Desktop connection RRS feed

  • Question

  • hello all,

    i am experiencing an error when using the RDP from a Window Vista to connect to a Windows Server Ent 2008. This error comes from a data error in encryption key and my connection is lost. so someone have any suggestion?

    thx.
    alexandre
    Tuesday, October 21, 2008 1:18 PM

Answers

  • Hi,

     

    If I don't misunderstand, you tried to use the RDP session to connect from Windows Vista to the Windows Server 2008, after the session was established, you encountered the following error:
     

    "Remote Desktop disconnected because of error in data encryption, this session will end."

     

    Based on the experience, we may encounter the exact same error due to a Bad on-board NIC.

     

    Solution:

     

    If possible, please install a PCI-NIC into the Windows Server 2008 based box, and then reboot it, and then disabled the on-board NIC to  make the new added NIC work.

     

    Please note: For DELL server, we need to replace the motherboard.

     

    Meanwhile, please check if there is any LinkSYS router between the Windows Vista computer and the problematic Window Server 2008 box. If so, we need to upgrade the firmware of the router to prevent the potential issue.

     

    Hope it helps.


    David Shen - MSFT
    • Marked as answer by David Shen Monday, October 27, 2008 8:00 AM
    Wednesday, October 22, 2008 11:02 AM

All replies

  • Hi,

     

    If I don't misunderstand, you tried to use the RDP session to connect from Windows Vista to the Windows Server 2008, after the session was established, you encountered the following error:
     

    "Remote Desktop disconnected because of error in data encryption, this session will end."

     

    Based on the experience, we may encounter the exact same error due to a Bad on-board NIC.

     

    Solution:

     

    If possible, please install a PCI-NIC into the Windows Server 2008 based box, and then reboot it, and then disabled the on-board NIC to  make the new added NIC work.

     

    Please note: For DELL server, we need to replace the motherboard.

     

    Meanwhile, please check if there is any LinkSYS router between the Windows Vista computer and the problematic Window Server 2008 box. If so, we need to upgrade the firmware of the router to prevent the potential issue.

     

    Hope it helps.


    David Shen - MSFT
    • Marked as answer by David Shen Monday, October 27, 2008 8:00 AM
    Wednesday, October 22, 2008 11:02 AM
  • thx for your help. this help me to fix my error.

    aenb
    Monday, October 27, 2008 9:54 AM