locked
UAG NLB missing Use integrated NLB checkbox on trunk RRS feed

  • Question

  • I've set up a single UAG server as an array master and given it a VIP in the "Network Load Balancer" Admin settings.
    The docs for UAG NLB say to "On the main properties page of the trunk, click Use integrated NLB ." but I see no such checkbox.
    Also missing is the "
    In Virtual IP , specify the VIP on which the external network is listening".

    Anyone know why this is missing or what needs to be done to make it appear?
    Thursday, March 11, 2010 12:40 AM

Answers

  • Then this is the reason why you do not get the Use Integrated NLB  checkbox.

    As soon as you will successfully add an additional UAG server to this AMS, the UI will change and the option will become visible.

     

    -Ran

     

     

     

     

    • Marked as answer by techaccnt Thursday, March 11, 2010 11:29 PM
    Thursday, March 11, 2010 2:50 PM

All replies

  • Hi

    Are you saying that your UAG array consists of just one single server - the array manager (AMS), or have you joined another UAG server to the array?

    -Ran
    Thursday, March 11, 2010 6:35 AM
  • At the moment the array consists of a single server.
    Thursday, March 11, 2010 1:55 PM
  • Then this is the reason why you do not get the Use Integrated NLB  checkbox.

    As soon as you will successfully add an additional UAG server to this AMS, the UI will change and the option will become visible.

     

    -Ran

     

     

     

     

    • Marked as answer by techaccnt Thursday, March 11, 2010 11:29 PM
    Thursday, March 11, 2010 2:50 PM
  • This seems strange logic to me...many customers want to deploy a single server array to prepare for additional servers coming sooner or later. This way you can define services using the NLB VIP addresses and then just add additional array members later when needed without making changes to DNS and/or trunk configuration.

    You can do this with ISA/TMG from memory, so a bit disappointed you can't with UAG :(

    Cheers

    JJ
    Jason Jones | Forefront MVP | Silversands Ltd
    Thursday, March 11, 2010 3:25 PM
  • I agree with Jason. I have a single server array and I can configure NLB. The problem for me is that "techaccnt" is not looking for NLB settings in the right place. Check in the Main Menu->Admin-> Network Load Balancing. There is nothing about NLB in the properties of the trunk (maybe the instructions come from legacy IAG documentation where high availablity were configured in a per-trunk basis)

    Hope it helps
    // Raúl - I love this game
    Thursday, March 11, 2010 4:27 PM
  • In Main Menu->Admin-> Network Load Balancing all I see is the ability to add a VIP and select the type (Unicast/Multicast).
    I cannot change the trunk to use the VIP, it doesn't allow that as a choice.

    In this thread I see an image that shows setting for NLB on the trunk, I see no such settings on my trunk.
    http://forums.forefrontsecurity.org/default.aspx?g=posts&t=357

    I'm going to try adding a second array member and see if they magically show up. If they do I'm going to be really disappointed, but happy I found them.
    • Edited by techaccnt Thursday, March 11, 2010 5:26 PM formatting
    Thursday, March 11, 2010 5:23 PM
  • RMoros, if you aren't seeing those settings on your trunk then you probably aren't actually using the built in NLB.

    I do hope this UI gets changed later, you really should be able to set it up with one machine they add additional array members later.

    In any case Ran was correct, once I added another machine to my array the options for NLB appeared in the trunk configuration.
    Thursday, March 11, 2010 11:35 PM
  • techaccnt, Jason, Raul,

    Thank you for your feedback, I'll forward it to the relevant people

    Regards,
    -Ran
    Friday, March 12, 2010 11:54 AM
  • techaccnt, Jason, Raul,

    Thank you for your feedback, I'll forward it to the relevant people

    Regards,
    -Ran

    Thanks Ran - good feedback I think ;)
    Jason Jones | Forefront MVP | Silversands Ltd
    Friday, March 12, 2010 12:58 PM
  • I agree :)

    -Ran
    Friday, March 12, 2010 1:04 PM
  • I have a similar issue even after adding my second array member.  I have the check box, but no VIPs are listed.  Any idea how to resolve this?

    When I select under Do not use integrated NLB the master shows All internal and external VIPs, but the second member only shows the DIP for the internal NIC.

    Thursday, February 3, 2011 6:41 PM