none
Slow Data Connection between DPM 2010 and Storage Server 2008 Cluster RRS feed

  • Question

  • Running into an issue with connectivity speeds between Data Protection Manager 2010 3.0.7707 and a Windows Storage Server 2008 Cluster.  The cluster only has 2 nodes, and are running Storage Server 2008 SP2 with SAN attached volumes.  The clustered servers have the same AV / Firewall rules as all other protected servers.

    When any task is run from the DPM server, they schedule, run, and are able to pull data at roughly 10-100K/second unthrottled.  These servers both have Gig Nics, and are on the same blade switch -during an activity, trying to ping the Protected Server from the DPM server or vice versa times out.   While that is happening, I can ping both servers from my laptop without any issue.  I checked with a network admin, and while the issue was happening he could ping both servers directly from the switch without any issues as well.

    Disabling firewalls & AV had no affect, at which point cluster validation and roll over tests were performed.  The only performance issue is between the protected server and the DPM server.  This is not my only cluster (which also have SAN attached storage from the same SAN), but it is my only cluster using the Storage Server 2008 platform.  Cross referencing between Storage Server 2008 and 2008 Standard, I did notice that the UAC only allows for Enabled/Disabled in Storage Server.  Is it possible that the UAC is interfering with the DPMRA service? 

    There are multiple entries on techNet about large file servers, storage server specifically, AV, and firewalls causing interference.  The problem persists with Chimney Offload explicetly disabled, the AV policy works with all other Protected Servers (and the issue persists when AV services are stopped / disabled / terminated), and the Firewall rules are correct (and the issue persists when disabled).  Nic drivers, and windows updates are current.  To test the connectivity itself, I transferred 2GB of data in under a minute from the SAN volume to the DPM server via windows explorer.

    I'm grasping at straws here as there are no DPM Alerts.  I'm not getting any VSS Errors, DCOM errors, Windows Error Reporting is clean.  Looking at the DPMErr*.logs on the protected server, and the DPM server I do find some errors.

    Protected Server -
    agentutils.cpp(2624)  WARNING  Failed: Hr: = [0x80070645] : U: lVal : hr

    DPM Server I am unable to determine an association directly to this protected server.

    1. Does the UAC for Storage Server 2008 matter when a tasks is initiated from DPM?

    2. What else is there to test?

    Wednesday, June 22, 2011 7:49 PM

All replies

  • Hi!!!

     

    Did you have this issue resolved?


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    Tuesday, December 27, 2011 5:54 AM