none
Install Agent from Secondary DPM 2010 to Primary DPM 2010 RRS feed

  • Question

  • Hello,
    I am trying to install DPM 2010 Agent from A Secondary DPM 2010 server into a Primary DPM 2010 Server. This two servers located into geographically different location like Washington, DC to London, UK in a heavily firewall protected environment. Both servers are into same Domain.  I opened following Ports into firewall:
    TCP: 135, 5718, 5719, 88, 389, 139, 445, 6075
    UDP: 53, 88, 389, 137, 138
    During installing Agent from Secondary DPM 2010 server to Primary DPM server, I am getting below error message: 
     Error: 405 and 346
     
    Please help us to resolve this problem.
    Thank you
    Abul Hasnat

    Thursday, November 29, 2012 12:15 AM

All replies

  • Hi,

    In case you want to protect a primary DPM server from a Secondary DPM server, then there is no need to install any agent on the Primary DPM server. We need to just attach the Primary DPM server on the secondary DPM server from the DPM console.

    While attaching the Primary DPM server, just type in the name of the Primary DPM server and follow the wizard.


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All. Regards, AJ (MSFT)

    • Proposed as answer by ANUJ_MSFT Friday, November 30, 2012 7:48 PM
    • Unproposed as answer by ANUJ_MSFT Friday, November 30, 2012 9:41 PM
    Friday, November 30, 2012 7:48 PM
  • Thank you Anuj,

    The agent installations or attachment is not the case. It is mostly related to Firewall. We opened below ports into our Firewalls but we are not getting connection between two servers. The servers are located into two different geographical location.

    TCP: 135, 5718, 5719, 88, 389, 139, 445, 6075

    UDP: 53, 88, 389, 137, 138

    Do we have to open more ports, if so what are they? Or how can we get the connection?

    Thank you

    Abul Hasnat


    Abul Hasnat



    • Edited by Abul Hasnat Friday, November 30, 2012 9:40 PM
    Friday, November 30, 2012 9:37 PM
  • Hi Abul,

    Please refer to the link below :

    http://technet.microsoft.com/en-us/library/cc161377.aspx

    Other than this please check the Windows Firewall and try disabling the Profiles with Incoming connections Allowed as a test. If there is an external firewall then make sure that RPC communication on port 135 is enabled.

    Along with this could you please share the error which you are recieving while communicating with the protection agent on the Primary DPM server.


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All. Regards, AJ (MSFT)

    Friday, November 30, 2012 9:58 PM

  • Abul Hasnat

    Friday, November 30, 2012 10:16 PM
  • Hello Anuj,

    We open the ports based on this http://technet.microsoft.com/en-us/library/cc161377.aspx article. We can “telnet through port 135” from secondary to primary and vice versa. This is an enterprise environment and we have 12 Primary DPM servers and 4 Secondary DPM 2010 servers. All ports are open but during Agent installation or Attachment, we are having below message. I cannot upload Graphics into this windows. Please see below window

    Thank you


    Abul Hasnat



    • Edited by Abul Hasnat Friday, November 30, 2012 10:20 PM
    Friday, November 30, 2012 10:18 PM
  • Hi Abul,

    Looking at the Error message - Could you share the name of the Primary DPM server and the secondary DPM server.

    Also from the error message it seems that we are trying to install the agent on a Protected server and not on a DPM server.

    To further troubleshoot the issue, please check the Event viewer on the Primary DPM server. Also open the Network Sharing Console and check the Network Card Binding Order.

     To check the binding order - > Open the Network Sharing Console -> click on the Change Adapter Settings -> Now click on Advanced in the menu bar -> Advanced settings . Make sure that the network connection being used is at the top.

    Will wait for further updates.


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All. Regards, AJ (MSFT)

    Friday, November 30, 2012 10:53 PM
  • Hello Anuj,

    The servers name are like WASDC0022011 is Secondary and LONTM0022031 as Primary DPM 2010 server. Both of them are DPM 2010 server.

    I checked Event Viewer Application Log and system log but there is no error message.

    For bindings: the Primary server has one Team and one IP and Secondary server have three IPs and all are open to communicate.

    The primary server is located in London, UK and Secondary server at Washington, DC. I think it is firewall issue and we may have to open more ports other the Article: http://technet.microsoft.com/en-us/library/cc161377.aspx.

    Thank you


    Abul Hasnat



    • Edited by Abul Hasnat Monday, December 3, 2012 3:33 PM
    Monday, December 3, 2012 3:31 PM
  • Hi Abul,

    Could you made some connectivity tests :

    # From Primary DPM to Secondary DPM Server

    ping <protected server name> <---succeed or fail
     net view \\<protected server name> <---succeed or fail
     Sc \\<protected server name> query <---succeed or fail
     Wmic /node:"<protected server name>" OS list brief <---succeed or fail

    # From Secondary DPM to Primary DPM Server

    ping <protected server name> <---succeed or fail
     net view \\<protected server name> <---succeed or fail
     Sc \\<protected server name> query <---succeed or fail
     Wmic /node:"<protected server name>" OS list brief <---succeed or fail

    Let us know the results.

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Monday, December 3, 2012 4:34 PM