locked
Virtualized Sharepoint unable to send email RRS feed

  • Question

  • We have a WSS3 installation that was recently moved from a physical machine into a VM hosted on a hyper V server. (Sharepoint WSS3 runnig on 2003 R2)

    Ever since the virtualization, the sharepoint site has been unable to send mail. I've confirmed all outgoing mail settings and can successfully send an email via telnet from the sharepoint server.

    However, when the sharepoint server attempts to send mail (either through an alert or a notification of permission change) it just sits there and hangs. No errors are displayed.

    I've tried:

    Following this post: http://blogs.msdn.com/b/tehnoonr/archive/2009/10/13/sharepoint-alerts-emails-don-t-work-on-some-vmware-systems.aspx - This very much describes my problem, however in a hyper v enviroment.

    Clearing the Sharepoint Cache

    Disabling antivirus and non essential services.

    Disabling time sync in integration services on the hyper v server.

    Any ideas anyone?

    Tuesday, September 18, 2012 9:37 AM

Answers

All replies

  • Hi,

    This kB article may help you:http://support.microsoft.com/kb/2000689

    Please try the resolution in this aricle, this issue may be caused that SharePoint opens a socket to the SMTP server via port 25 without specifying the socket type.

     

    Regards,

    Xue-Mei Chang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tnmff@microsoft.com.


    Xue-mei Chang

    TechNet Community Support

    • Marked as answer by OliverTulloch Friday, September 21, 2012 11:46 AM
    Wednesday, September 19, 2012 2:08 AM
    Moderator
  • Hi,

    Please telnet to your SMTP server in port 25 from the virtual server.

    If it fails,Kindly enable the same.


    Regards, Pradeep

    Wednesday, September 19, 2012 9:55 AM
  • Thanks Xue-Mei Chang.

    I was unaware that SPORDER didn't change the order for x64. Sharepoint is now sending email!!

    Friday, September 21, 2012 11:47 AM