none
RD Connection Broker not working RRS feed

  • Question

  • I have a client who we built an RDS environment for.  When this was built originally it was all working as expected.  Something has changed in the past year and a half (which no one there seems to know what changed) and now the setup isn't working as expected.

    There are 8 servers involved total.

    1x License server

    1x Connection Broker/RD Gateway

    6x Session Hosts

    The problem is that the Connection Broker is no longer handing off desktop sessions to the session hosts.  In the past I could RDP to the Connection Broker (RDGateway.domain.local  -  farm name) and it would place me on one of the 6 session hosts.  Now it simply logs into the broker server itself.

    I have tried a multitude of different things to get this working and am beside myself as to why it isn't.  I believe that my configuration is correct as I have compared it to several online setup guides and walk-trough's.

    What could I be missing that would be causing this?


    • Edited by Kyle Kent Wednesday, January 13, 2016 10:08 PM
    Wednesday, January 13, 2016 10:08 PM

Answers

  • Hi Kyle,

    you can accesses session host by mstsc connection broker by changing default URL, otherwise its a default behavior. 

    To answer your question: Please check if your default setting is changed or not.

    replace your session host collection name on below loadbalancing info

    loadbalanceinfo:s:tsv://MS Terminal Services Plugin.1.CollectionName

    Login to connection broker and check below setting.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\ClusterSettings

    Create new stringValue: DefaultTsvUrl
    enter the loadbalancing info in Value data: tsv://MS Terminal Services Plugin.1.CollectionName


    Pankaj Singh

    Windows Engineer

    Please remember to mark the replies as answers if they help and un-mark them if they provide no help.

    Monday, January 18, 2016 3:57 PM

All replies

  • Hi Kyle,

    What’s the Operating System of your RDS servers?

    Does the RD Connection Broker have RD Session Host role installed and act as RD Session Host?

    On your Internet-faced firewall, please ensure TCP port 3389 is blocked, only TCP 443 (and UDP 3391 if Firewalls that have directional UDP analysis, such as TMG, require UDP "Send Receive" configured) is forwarded to your RD Gateway/Connection Broker server.

    More information for you:

    Which ports are used by a RDS 2012 deployment?

    http://social.technet.microsoft.com/wiki/contents/articles/16164.which-ports-are-used-by-a-rds-2012-deployment.aspx

    Firewall Ports for External RDP Access

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/81bba1e2-8a40-4bbc-8ac5-910200997b40/firewall-ports-for-external-rdp-access?forum=winserverTS

    RDS Gateway Port Configuration

    https://social.technet.microsoft.com/Forums/en-US/8227e107-e29f-43e8-89b0-c48e203cf92c/rds-gateway-port-configuration?forum=winserverTS

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 15, 2016 8:43 AM
    Moderator
  • Amy,

    Thanks for your response.  To answer your questions:

    All of the servers in this RDS deployment are running Server 2012 R2.

    The RD Connection Broker does not have the Session Host role installed.  It only has the Broker and Gateway roles installed.

    This is an internal only system and is not internet facing.

    Thank you,

    Kyle

    Friday, January 15, 2016 1:08 PM
  • Hi Kyle,

    Are you connecting via mstsc.exe?

    If yes, since there is no external client, what happens after checking the option Bypass RD Gateway Server for local addresses under Advanced tab ->Settings and connect?

    In addition, would you please confirm RDS server roles within RDS collection section?

    In my RDS deployment, it looks like this:

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 18, 2016 3:27 AM
    Moderator
  • Hi , I think that your mstsc file is missing the Load Balance and Workspace ID info

    https://technet.microsoft.com/en-us/library/ff393699%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    if you edit the file using notepad you should see these values, if you can not find them , then download an RDP icon from the remote desktop web page using a 3rd party web browser and copy them over. By default the connection broker will accept connections if those values are not specified.

    workspace id:s:connectionbroker.domain.com

    use redirection server name:i:1

    loadbalanceinfo:s:tsv://MS Terminal Services Plugin.1.CollectionName

    Monday, January 18, 2016 8:14 AM
  • When I manually edit my MSTSC file and add those values then I am able to connect successfully to the session hosts through the broker. 

    However, I thought that the setting "Automatically detect RD Gateway server settings" should pick up these settings and do the same thing?

    I am also able to connect successfully from RDWeb and by using the .RDP shortcut downloaded from this page.

    Again, I expect the default settings in MSTSC.exe on my local machine to be able to connect this way as well with the Auto-Detect settings enabled.

    Monday, January 18, 2016 1:29 PM
  • Well unfortunately the manual mstsc file does not contain those, so you must either edit the file and then send it to the clients , or instruct them to connect using the RDWeb. Alternatively you can use the RemoteApp and Desktops in the client control panel in order to have them generate the file automatically. You can also try to connect to a remote desktop server on the fly through the gateway , which in turn will automatically redirect you the server you where working , but you will run on all sorts of issues in the long run.

    Still my recommendation is to use the remoteapp control panel applet and have the users "register" to the RemoteApp resources.

    Monday, January 18, 2016 1:40 PM
  • Hi Kyle,

    you can accesses session host by mstsc connection broker by changing default URL, otherwise its a default behavior. 

    To answer your question: Please check if your default setting is changed or not.

    replace your session host collection name on below loadbalancing info

    loadbalanceinfo:s:tsv://MS Terminal Services Plugin.1.CollectionName

    Login to connection broker and check below setting.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\ClusterSettings

    Create new stringValue: DefaultTsvUrl
    enter the loadbalancing info in Value data: tsv://MS Terminal Services Plugin.1.CollectionName


    Pankaj Singh

    Windows Engineer

    Please remember to mark the replies as answers if they help and un-mark them if they provide no help.

    Monday, January 18, 2016 3:57 PM
  • Hope this will help

    Pankaj Singh
    Windows Engineer
    Please remember to mark the replies as answers if they help and un-mark them if they provide no help.

    Monday, January 18, 2016 9:01 PM