none
Set message size limit for individual user

    Question

  • Hi all,

    I'm using Exchange 2013 CU7, the default limit message size is 10MB at organizational , send/receive connectors , users setting level. As I know the applying privilege for limit message size : organizational > send/receive connectors > users setting , right ?
    How can I allow individual user to send out 20MB message without changing  organizational , send/receive connectors limit setting ?
    If I have to change organizational , send/receive connectors limit setting then how to apply 10MB limit to all users (including new users in future) except some individual users ?

    Thanks.

    Friday, October 7, 2016 4:16 AM

Answers

  • Hi Jun,

    Please find the below article which will help you on setting up the limit for individual mailboxes, for external emails aswell.

    https://www.simple-talk.com/sysadmin/exchange/increasing-email-size-limits-for-your-high-profile-users-in-exchange-2010/

    Regards,

    Kiran,

    • Proposed as answer by Kiran B.A Friday, October 7, 2016 7:11 AM
    • Marked as answer by Jack Chuong Friday, October 7, 2016 7:44 AM
    Friday, October 7, 2016 7:11 AM

All replies

  • Hi Jack,

    Use the following command,

    Set-Mailbox "User Name" -MaxSendSize 20mb -MaxReceiveSize 20mb

    OR

    Use the EAC to set message size limits

        • In the EAC, navigate to Recipients > Mailboxes.

        • In the list of user mailboxes, click the mailbox that you want to change the message size limits for, and then click Edit Edit icon.

        • On the mailbox properties page, click Mailbox Features.

        • Under Message Size Restrictions, click View details to view and change the following message size limits:

          • Sent messages   To set a maximum size for messages sent by this user, select the Maximum message size (KB) check box and type a value in the box. The message size must be between 0 and 2,097,151 KB. If the user sends a message larger than the specified size, the message will be returned to the user with a descriptive error message.

      • Received messages   To set a maximum size for messages received by this user, select the Maximum message size (KB) check box and type a value in the box. The message size must be between 0 and 2,097,151 KB. If the user receives a message larger than the specified size, the message will be returned to the sender with a descriptive error message.

    1. Click OK, and then click Save to save your changes.

    Regards,

    Kiran


    • Proposed as answer by Kiran B.A Friday, October 7, 2016 7:11 AM
    Friday, October 7, 2016 4:53 AM
  • Hi Kiran,

    I did, but limit setting at user level cannot overrides organizational , send/receive level , I get error "The recipient won't be able to receive this message because it's too large. The maximum message size that's allowed is 10 MB. This message is 11 MB."
    "Diagnostic information for administrators:Generating server: EXserver
    mygmail@gmail.com Remote Server returned '550 5.2.3 RESOLVER.RST.RecipSizeLimit; message too large for this recipient
    "

    Friday, October 7, 2016 5:01 AM
  • Hi Jun,

    If you are sending the mail externally, Please find the below answer.

    Do individual message size limits bypass the Organization message size limits?

    This is perhaps one of the most misunderstood part of message size limits, and therefore a frequently asked question: when you specify individual message size limits for a recipient, does it override other message size limits in your Exchange organization?

    In a nutshell, setting higher message size limits on an Exchange recipient bypasses the maximum message sizes in the Exchange Organization configuration, but only for internal messages, not for messages sent to or received from the Internet and other unauthenticated sources.

    Remember, for a message to be delivered successfully, the message size must be within the max message size limits applicable to both – the sender and the recipient. Because the identity of unauthenticated or anonymous senders and recipients can’t be established (because… they’re unauthenticated!), the organizational limit applies.

    Regards,

    Kiran

    Friday, October 7, 2016 5:42 AM
  • Hi Kiran,

    Thank you for your explaination, so in this case I still find a solution so that my individual user can send out a 20MB message to external recipient , assume that recipient's mail system approve for 20MB incoming message (gmail for example), if there is anyway somehow ?

    If I have to change send connector limit message size to 20MB then create a rule in mail flow (ECP) applying for all sending out messages : reject message with an explanation except some individual users ? It sounds complicated but I will use if force majeure occurs.

    Thanks.

    Friday, October 7, 2016 6:47 AM
  • Hi Jun,

    Please find the below article which will help you on setting up the limit for individual mailboxes, for external emails aswell.

    https://www.simple-talk.com/sysadmin/exchange/increasing-email-size-limits-for-your-high-profile-users-in-exchange-2010/

    Regards,

    Kiran,

    • Proposed as answer by Kiran B.A Friday, October 7, 2016 7:11 AM
    • Marked as answer by Jack Chuong Friday, October 7, 2016 7:44 AM
    Friday, October 7, 2016 7:11 AM
  • Thank you very much Kiran,

    I have same idea as solution 2 in your link, as I don't have to set limit message size for every new user mailbox.

    Friday, October 7, 2016 7:47 AM