locked
Open a Port RRS feed

  • Question

  • I have Server 2003 and need to open a specific port for my software program.  I opened the port in my router/firewall and verified that it is not being blocked by my ISP or security software, but it is still not open (when checking with canyouseeme.org).  Does anyone have any ideas of an settings that need to be changed with the server configuration to complete this process?
    Wednesday, April 18, 2012 9:27 PM

Answers

  • Hello,


    You mentioned that you’ve open the port in router/firewall. Do you mean the built-in Windows Firewall? Furthermore, I don’t think canyouseeme.org is accurate.


    Please use the below command to check whether the specific port is open.


    netstat -a

    It shows which ports are listening for connection. Run netstat /? for more information about this command.


    By the way, take a look at the below Microsoft KBs. Make sure you’ve opened the port in Windows Firewall correctly.

    Windows Firewall may block some programs from communicating over the Internet after you install Windows XP Service Pack 2
    http://support.microsoft.com/kb/842242

    How to configure TCP/IP Filtering in Windows Server 2003
    http://support.microsoft.com/kb/816792


    Thanks
    Zhang


    Thursday, April 19, 2012 2:29 AM

All replies

  • Is the correct port forwarding setup in router? (port forwarded to server's private ip address)

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Thursday, April 19, 2012 1:53 AM
  • Hello,


    You mentioned that you’ve open the port in router/firewall. Do you mean the built-in Windows Firewall? Furthermore, I don’t think canyouseeme.org is accurate.


    Please use the below command to check whether the specific port is open.


    netstat -a

    It shows which ports are listening for connection. Run netstat /? for more information about this command.


    By the way, take a look at the below Microsoft KBs. Make sure you’ve opened the port in Windows Firewall correctly.

    Windows Firewall may block some programs from communicating over the Internet after you install Windows XP Service Pack 2
    http://support.microsoft.com/kb/842242

    How to configure TCP/IP Filtering in Windows Server 2003
    http://support.microsoft.com/kb/816792


    Thanks
    Zhang


    Thursday, April 19, 2012 2:29 AM
  • It is forwarded to the server's private ip.  I have another port open for remote desktop connection and the new port is using the same server ip...
    Thursday, April 19, 2012 2:44 PM
  • Windows firewall is not in use.  I have a firewall in my router and another security program (which I verified is not blocking the port). 

    Using netstat -a, i could not find that the port is open. 

    I have used the microsoft suggestion of "Enable TCP/IP Filtering (All adaptors)" but that did not correct the issue.  Any other suggestions.  Do you think it is purely a network issue?  Thanks!

    Thursday, April 19, 2012 2:52 PM
  • Then it appears your app is not listening. Also try netstat -a -o and then match up the PID within task manager.

     

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    • Marked as answer by Boo_MonstersInc Wednesday, April 25, 2012 7:30 AM
    • Unmarked as answer by Brian Bohman Monday, April 30, 2012 4:35 PM
    Friday, April 20, 2012 2:04 AM