locked
Out of office stop working after 15 minutes RRS feed

  • Question

  •  

    For only few users, not all, when the user activate the OOF it works for about 15 minutes and after that delay, no autoreply email is sent anymore. Even if the OOF is still active. Even it's a new sender (I know that autoreply send only once to the same sender).

    - We have Exchange 2007 SP3 and client are Office 2007

    - Same behavior whether OOF is activated via OWA or Outlook

    - Same behavior wheter the email come from an internal sender or an external.  

    - We only have one Exchange 2007 server

    Thursday, February 23, 2012 6:09 PM

Answers

All replies

  • Have you checked your tracking logs to verify the messages are not being sent?  Are any of the users having the issue using Blackberry for their smartphone?

    JAUCG

    Thursday, February 23, 2012 11:15 PM
  • Hi,

    I have some suggestions for you:

    1 Enable the message tracking log on Exchange Server 2007 to check whether the OOF message is not generated or not delivered correctly.

    2 Check whether all the problematic users are in the same DB, if they are, create new mailbox database and move all effected users to new database.

    3 Disable and Reconnect Mailbox.

    Thanks.


    Rowen

    TechNet Community Support

    Friday, February 24, 2012 6:44 AM
  • Hi Could you please check PR_OOF_STATE is true or not ?

    If true then I should send out of office message if not then change it from false to true.

    One more thing need to observer it may change from true to false , so please observer that when its not sending and when its sending out of message replay.

    Steps are mentioned below.

    We can use  tool called MFCMAPI to confirm whether the Out of Office message is set or not. It can be useful to use something other than Outlook or OWA to verify this. MFCMAPI is a tool to directly view and modify the MAPI store and can be downloaded from the Microsoft downloads site here. This tool is supported on Windows 2000 SP4, Windows 2003 or Windows XPFirst run the MFCMapi.exe file which will launch the main MFCMapiwindow as well as an About MFCMAPIwindow which you can close straight away via the OKbutton.

    1. Back at the MFCMapi window, click the Sessionmenu option followed by the Logonand Display Store Tableoption. The familiar Outlook profile window will now be presented and here you’ll obviously want to choose the relevant profile you are working with.
    2. The connection should now be made and you’ll see the user connection in the main window. we’ve connected to User s mailbox.
    3. Select the mailbox profile from the list displayed
    1. In the lower pane, scroll down until you find the entry that has a name property of PR_OOF_STATE. Look in the Value column, where you should see either the letter T for true or F for false.

    yours feedback will help to others


    • Edited by satya11 Friday, February 24, 2012 7:38 AM
    Friday, February 24, 2012 7:35 AM
  • styall has a good idea please verify using mfcmapi. Also see if these users have any third party outlook plugins that may be overiding the settings. Have the user start Outlook in safe mode outlook /safe and have him use it for 30 mins and see if OOF still works.

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, February 24, 2012 4:18 PM
  • Any updates?

    JAUCG

    Friday, February 24, 2012 4:27 PM
  • Thanks for your help. I'm not sure exactly what do you want me to verify. Here is what I did after I read you post.  I turn off and turn on again the OOF with the user profile in Outlook.  I sent an email with my account and received an auto reply msg. After, I went to the Exchange console=>Toolbox=>Message Tracking. Select the recipients and the start and end time to include when I sent the test email. There are multiples eventID to check. Of course, when I select "Receive" I can see the test email I sent but I can't see anything when I selected the choice "SEND". However, I received an autoreply. ??  Should I see something in "SEND" for OOF msg? 

    I also tried DSN, DELIVER, BADMAIL etc. but nothing better to see.

    Yes the user has a Blackberry. You think it could be related?


    • Edited by squidididly Friday, February 24, 2012 6:50 PM
    Friday, February 24, 2012 6:25 PM
  • Thank for your post : I already moved the user from one DB to another and it didn't change anything. What do you mean by disable and reconnect the Mailbox? Disable it in the Exchange console?

    Friday, February 24, 2012 6:45 PM
  • Thank for your help. The state is True even after 15 mn when the OOF stops to send the reply email.
    • Edited by squidididly Friday, February 24, 2012 6:53 PM
    Friday, February 24, 2012 6:47 PM
  • I'm quite sure it's not related to Outlook because OOF stop working after 15 minutes even when the user isn't logged to a computer and I activated the OFF with OWA
    • Edited by squidididly Friday, February 24, 2012 6:54 PM
    Friday, February 24, 2012 6:49 PM
  • Your message tracking should've like below. Just did a test from external and internal user. If you don't see anything then the mailbox is probably not sending the OOF. You need to launch mfcmapi and look at the oof state, sometime mapi properties can get corrupted.

    EventId  Source   Sender                            Recipients                        MessageSubject
    -------  ------   ------                            ----------                        --------------
    RECEIVE  MAILB... jyoung@simplexity.com             {jchong@simplexity.com}           Automatic reply: test
    RECEIVE  MAILB... jyoung@simplexity.com             {jchong@simplexity.com}           Automatic reply: test
    DELIVER  STORE... jyoung@simplexity.com             {jchong@simplexity.com}           Automatic reply: test
    RECEIVE  MAILB... jyoung@simplexity.com             {jamestechman@gmail.com}          Automatic reply: test2
    RECEIVE  MAILB... jyoung@simplexity.com             {jamestechman@gmail.com}          Automatic reply: test2
    TRANSFER ROUTING  jyoung@simplexity.com             {jamestechman@gmail.com}          Automatic reply: test2
    SEND     SMTP     jyoung@simplexity.com             {jamestechman@gmail.com}          Automatic reply: test2


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, February 24, 2012 8:32 PM
  • Can you export items for a mailbox effected and import into a new mailbox and test.


    Sukh

    Friday, February 24, 2012 8:38 PM
  • Yes, the issue could most certainly be with the Blackberry.  Check out this BB article:

    http://supportforums.blackberry.com/t5/BlackBerry-Enterprise-Solution/Exchange-2007-Out-of-Office-OOF-stops-sending-notifications/td-p/19505

    I would verify that the BES server is up to the latest patch level and the device is as well.  This article may help as well:

    http://messagexchange.blogspot.com/2009/01/blackberry-users-setting-out-of-office.html


    JAUCG

    • Marked as answer by Rowen-Xu Tuesday, March 6, 2012 8:54 AM
    Friday, February 24, 2012 9:37 PM
  • Any updates on this?

    JAUCG

    Monday, March 5, 2012 6:10 PM
  • Your were right!! It was a Blackberry issue. As soon as I moved user to the new Blackberry server the problem stopped. Thanks for you help. I have this issue for couple of month. What a relief. :-)
    • Marked as answer by squidididly Tuesday, March 13, 2012 1:17 PM
    Tuesday, March 13, 2012 1:17 PM