locked
Exchange 2010 Recurring Meetings declines all if conflicts on some RRS feed

  • Question

  • Hi

    I hope someone can help please.  I have read a number of related threads - heres the technet blog ive read http://blogs.technet.com/b/exchange/archive/2011/02/07/3411956.aspx, however none explain the exact setting I need to apply through the gui rather than using powershell.

    Basically I have setup resource scheduling in Exchange 2010- all users can setup meetings to the resource but it does not allow ANY conflicts.  Which is what we want.  However when setting up recurring meetings, the whole series is declined because of 1 or two conflicts.

    We would much prefer the system to accept all non conflict meetiings, and decline the rest.

    I have read that using powershell cmdlet and set the following:

    • AutomateProcessing: Must be set to AutoAccept to allow automatic booking of any meeting requests, recurring or not. Note, the default is AutoUpdate.
    • AllowRecurringMeetings: Set to True by default. If it's changed to False, all recurring meeting requests are rejected.
    • AllowConflicts: The parameter determines whether conflicting meeting requests are allowed.

    Will allow for exactly what I need.  However when I run the following syntax in powershell:

    Set-CalendarProcessing -"Meeting Room - Training Room" -AutomateProcessing AutoAccept

    I receive the error:

    The term 'Set-CalendarProcessing' is not recognized as the name of a cmdlet, function, script file, or operable program
    . Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
    At line:1 char:23
    + Set-CalendarProcessing <<<<  -"Meeting Room - Training Room" -AutomateProcessing AutoAccept
        + CategoryInfo          : ObjectNotFound: (Set-CalendarProcessing:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    This just stops me right in my tracks and I cannot progress any further - I have only ever used powershell once or twice during a training course so I have limited knowledge - is there a simpler way I can achieve what I need to in the EMC?

    Many Thanks for your help

    ps: many apologies - the forum category/forum is incorrect but I could not find Exchange 2010 in the list when posting this thread...

    Carla

    Thursday, May 30, 2013 2:52 PM

All replies

  • Hi,

    1. are you trying from exchange shell or normal windows power shell.

    2. if you can not set -AutomateProcessing  from command.

    then open ECP -> Options -> select what to manage -> click on another user -> select resource mailbox -> Settings -> Resource.

    • Proposed as answer by p.th Monday, August 19, 2013 12:14 PM
    Monday, August 19, 2013 12:14 PM
  • Hi Carla

    You should not have "-" in front of your room name.

    use:

    Set-CalendarProcessing "roomname" -AutomateProcessing AutoAccept

    or for all rooms:

    Get-Mailbox | where {$_.RecipientTypeDetails -eq "RoomMailbox"} | Set-CalendarProcessing -AutomateProcessing AutoAccept

    Tuesday, July 1, 2014 5:18 AM