none
failed to connect to the Analysis Services RRS feed

  • Question

  • I installed Project Server 2016.  When I go to OLAP database management and click Build, I get an error:

    Error: Failed to connect to the Analysis Services server ServerName. Error: A connection cannot be made. Ensure that the server is running.

    Any idea why?  My SQL Server 2014 is installed as a named instance with an alias.  Sharepoint can connect to it fine.

    thanks,


    • Edited by bbatl Monday, August 8, 2016 9:03 PM more info
    Monday, August 8, 2016 8:29 PM

All replies

    • Marked as answer by bbatl Tuesday, August 9, 2016 6:10 PM
    • Unmarked as answer by bbatl Tuesday, August 9, 2016 6:28 PM
    Tuesday, August 9, 2016 9:59 AM
    Moderator
  • I followed these steps and when I do Build Database I still get the error that it couldn't connect to the analysis services server.
    I am able to open SQL Server Management Studio, select Connect to and connect to Analysis Services with no problem.

    • Edited by bbatl Tuesday, August 9, 2016 6:56 PM more info
    Tuesday, August 9, 2016 6:29 PM
  • Ensure you have the correct vesion of the AMO component installed as per the link.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Wednesday, August 31, 2016 8:44 AM
    Moderator
  • What Name are you using the OLAP build page?  SSAS does not respond to SQL Alias - that is only for the DBMS.  So you must reference SSAS as <Server>\<Instance>.

    also, the SQL Server hosting SSAS must have the same DBMS ALIAS setup.  the OLAP job will create a DS entry that points to the DBMS via the name of the DB Server that is referenced via Project Server / SharePoint.

    In other words SSAS must speak to DBMS over the same Alias, so it must be present on that box also.

    Let us know what the exact error is, please if this does not correct.

    Hope this helps,


    Thanks, Eric S. Pcubed

    Wednesday, August 31, 2016 3:42 PM