none
Unable to backup a VM due to VSS Writer Failures RRS feed

  • Question

  • I know this has been covered in many posts on many forums but I have been unable to resolve this particular issue.  I have a Windows 2008 R2 virtual server on a Windows 2008 Hyper-V cluster and I am unable to get a successful backup of it due to the following error in DPM:

    DPM encountered a retryable VSS error. (ID 30112 Details: VSSError: The writer experienced a transient error.  If the backup process is retried, the error may not reoccur. (0x800423F3)).

    The failed VSS writers are:

    Writer name: System Writer - State: [7] Failed - Last error: Timed out

    Writer name: IIS Config Writer - State: [7] Failed - Last error: Timed out

    Writer name: WMI Writer - State: [7] Failed - Last error: Timed out

    If the server rebooted or the VSS writers' corresponding are restarted the state of the writers changes back to stable, but as soon as DPM runs a job it fails and the writers go into the failed state again.

    I have checked the Hyper-V host's event logs and VSS writer states as well as the VM's event logs but there is not a lot of information which seems useful.  Does anyone know if some form of verbose logging can be configured to obtain more troubleshooting info?

    The server has had Oracle installed on it recently but no Oracle VSS writers are running.  I have also tried to stop all the Oracle services but this doesn't help.  We have had issues on another server with Oracle on it but have successfully implemented a work around for this as outlined in the following article:

    https://social.technet.microsoft.com/Forums/en-US/50ca9eb0-5bfd-4a73-9596-bc101020778a/hyperv-backup-oracle-vss-writer-error-vss00044?forum=dpmhypervbackup

    This work around does not work on this other server I am still having problems with.

    Any advice on troubleshooting VSS Writer errors would be warmly welcomed as I am beginning to go around in circles with this.

    Thanks

    Chris

    Wednesday, February 18, 2015 9:54 AM

All replies

  • Backup task fails with a time-out error in Windows

    http://support.microsoft.com/kb/2996928/

    Symptoms Section:

    Assume that you run a backup requester application to perform a backup task on the computer.

    In this scenario, the backup task fails, and you may receive the following error message that states the Volume Shadow Copy Service (VSS) failed because of a time-out:

    FAILED_AT_FREEZE (0x800423f2 - VSS_E_WRITERERROR_TIMEOUT)

    Around bad MS Patch 3000853

    Backup Jobs Failing Post Nov Rollup Install

    http://blogs.msdn.com/b/taylorb/archive/2014/11/19/backup-jobs-failing-post-nov-rollup-install.aspx

    November 2014 Update Rollup - KB3000853 - VSS Backups Broken

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/c78faf9a-e126-4f51-b8fe-69d547a9d365/november-2014-update-rollup-kb3000853-vss-backups-broken?forum=winserver8gen

    November 2014 update rollup for Windows RT, Windows 8, and Windows Server 2012

    http://support.microsoft.com/kb/3000853
    Wednesday, February 18, 2015 5:03 PM
  • Thanks for this Trekrod01.  I have checked the Hyper-V host and VM for this update but neither have it unfortunately so I don't think this applicable in my case.  The VMs that appear to have the issue have Oracle installed and the one I have the severest problem with doesn't have the Oracle VSS Writer installed.  I have stopped all the Oracle services on the VM but still get the VSS Writer failures.

    I have now raised a call with Microsoft so will update any useful info afterwards.

    Thursday, February 19, 2015 1:38 PM