none
Admin without admin rights

    Question

  • Hello all,

    My facther in law's computer (acer aspire V laptop) just started playing funny on me....

    We installed a driver for a USB/Rs232 dongle and it broke his 81 install, I still don't know why he never moved to 10 but that's besides the point now.

    We ran a system restore, the one that says it will restore windows but not delete your files, which it did.

    The only problem is that now his only user account which is supposed to have all admin rights has none of them.

    We can't open C: (there is a separate D drive, c being a SSD for the system), we can't run secpol.msc, we can't even run taskmgr or UAC to reduce its level.

    We can't right clic C to access the share options and allow his admin account a complete access to all the files.

    We can't create another account.

    How do I get the admin rights back to his admin account when I cannot run and elevated cmd or anything like that ?

    I launched a net user command with his account and all seems to be ok, the account is active, it's included in the admin group, it's not expired....nothing conspicous there.

    Thanks for the help.
    Friday, August 12, 2016 4:43 AM

Answers

All replies

  • Hello,

    See if this fix helps you (works on Windows 8.1 also):

    http://www.kapilarya.com/fix-lost-administrative-rights-in-windows-10

    Hope this helps, Good luck :)

    Windows Insider MVP, MS MVP (2014-2016)

    Friday, August 12, 2016 7:37 AM
  • Hello,

    Thanks for the tip, it helped a lot, we're almost there....

    So here's the current situation

    The fix created an administrator account, it did not correct my old account but created a new one that has SOME of the admin rights.

    I can open C and see everything, but I still can't right clic C and get to properties to allow other admins to access all files.

    I cannot install any program (eg Office) which wants to put files in a protected folder of C (program files, program data and so on).

    I've tried to find some command line tricks to modify the files authorization but to no avail....

    What can I try now ?

    Thanks a lot

    PS : In the fix procedure there is a small mistake, we are supposed to remove the 11 and not the 02 so either we go at the start of line 38 or if we go at the 2nd byte we need to press backspace and not delete. The pictures are correct so I based myself on them...

    Friday, August 12, 2016 6:07 PM
  • Update...

    I ran sfc /scannow and got some interesting results, it appears that all the "protected" folders are not owned by anybody.

    The cbs.mog tells me that the folders are not owned but they specify SDDL in component MS-windows wpfcorecomp.resources, Pa

    Whatever that means I don't know but I think that if I could tell these damn folder that i own them life would eb better.

    Thanks for the help

    Friday, August 12, 2016 7:19 PM
  • Update 2.

    I ran accessenum and accesscheck from sysinternals and I think I have found a problem...

    All the "protected" files have a path which does not exist such as "users\local\appdata\local\appdata\local\appdata\local\appdata\local.....etc etc" until it gets ti finally the proper thing, for example skype.

    So of course the files and directories are not where they are supposed to be....

    Is there anyway to solve this ? I'm sure by searching the filename (eg skype.exe) I would find them but is there a way to batch correct this ?

    Thanks

    Friday, August 12, 2016 7:40 PM
  • Hi,

    This situation happens because you are not the owner of this folder of file, The default owner of a file or folder is the person who creates the resource.

    Log on the computer with the account which created the folder of file, namely the owner, then you are permitted to modify the file or folder.

    Also, you can follow this article to assign ownership of files and folders:

    http://technet.microsoft.com/en-us/magazine/ff404240.aspx

    You can also reset the permission to default.

    http://www.bleepingcomputer.com/forums/t/509474/reset-all-user-permissions-to-default/

    Please Note: Since the websites are not hosted by Microsoft, the links may change without notice. Microsoft does not guarantee the accuracy of this information.

    https://support.microsoft.com/en-sg/kb/313222

    Best Regards,

    Tao


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 15, 2016 9:39 AM
    Moderator
  • Hi,

    We haven’t heard from you for a couple of days, have you solved the problem? How about the solution we have provided? We are looking forward to your good news.

    Best Regards,

    Tao


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 16, 2016 7:14 AM
    Moderator