locked
unable to register pdm.dll on Windows 10 Enterprise 2016 LTSB RRS feed

  • Question

  • I'm not able to register pdm.dll  on Windows 10 Enterprise 2016 LTSB.

    command: C:\Windows\SysWOW64>regsvr32 c:\Windows\SysWOW64\F12\pdm.dll

    got the below error

    ---------------------------
    RegSvr32
    ---------------------------
    The module "c:\Windows\SysWOW64\F12\pdm.dll" was loaded but the call to DllRegisterServer failed with error code 0x80070715.


    For more information about this problem, search online using the error code as a search term.
    ---------------------------
    OK   
    ---------------------------

    Can anyone know how to register this dll?

    Wednesday, February 14, 2018 4:19 AM

Answers

All replies

  • 0x80070715 is ERROR_RESOURCE_TYPE_NOT_FOUND

    As the dll is in SysWOW64: did you use the correct version of regsvr32?
    I assume you need to use the x86 one (which is in
    C:\Windows\SysWOW64, too), not the x64 one (which is in C:\Windows\System32).

    But the error code makes it sound like its just a problem of the dll, and you should contact the developer.
    Wednesday, February 14, 2018 6:09 AM
  • Yes, I'm using regsvr32 from SYSWOW64
    Wednesday, February 14, 2018 8:24 AM
  • Hi,

    Have you tried running the command with administrator privileges.

    Also please get the file from another same system version computer at same patch level.

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, February 15, 2018 4:19 AM
  • Yes, I tried as admin. Still its same issue
    Thursday, February 15, 2018 12:00 PM
  • I did not recognize this file belongs to Windows 10 and is no 3rd party dll.
    Seems to be used form Internet explorer for debugging.

    But why do you even try to register it?

    Thursday, February 15, 2018 6:47 PM
  • I have an application which uses this dll, since its not registered COM component creation is failing.
    Friday, February 16, 2018 11:19 AM
  • Friday, February 16, 2018 2:16 PM
  • Thanks for the information.
    Thursday, February 22, 2018 6:51 AM