none
Exchange 2007 & Outlook 2007 Out of Office not working RRS feed

  • Question

  • Hi there,

    been troubleshooting this for some time now. Anyways, I'm at a customer where they run Exchange 2007 (SP3 with all current updates) and Outlook 2007. I don't see any errors in the automatic email configuration test in outlook. Tried enabling the logging in outlook... but reading the .etl file hasn't succeeded so far. Either I have tools that don't know the guids and therefore do nothing, or I have tools that don't have the guids and thus leave me with a text file with nothing but guids in them (very useful...)

    The customer is also trying to use M+ Archive for importing e-mail from groupwise. From what I understand there's been a [b]lot[/b] of screwing around in settings in exchange to get that garbage running.

    I think I have an idea where it goes wrong. As I understand it, out-of-office (at least through outlook) requires the EWS virtual directory in IIS to function. Seriously doubt it does that, looking in IIS shows the virtual directory, however the powershell command get-webservicesvirtualdirectory outputs nothing whatsoever. Try to run set-webservicesvirtualdirectory gives errors too, so I just tried to remove it from IIS and run new-webservicesvirtualdirectory.

    This either fails with (not yet removed EWS from IIS):

    [PS] C:\Users\administrator\Desktop>New-WebServicesVirtualDirectory
    New-WebServicesVirtualDirectory : The virtual directory 'EWS' already exists under 'S110.DOMAIN.LOCAL/Default Web Site'.
    Parameter name: VirtualDirectoryName
    At line:1 char:32
    + New-WebServicesVirtualDirectory <<<<
        + CategoryInfo          : InvalidArgument: (S110\EWS (Default Web Site):ADObjectId) [New-WebServicesVirtualDirectory], ArgumentException
        + FullyQualifiedErrorId : 789D297B,Microsoft.Exchange.Management.SystemConfigurationTasks.NewWebServicesVirtualDirectory

    or (after removing EWS from IIS):

    [PS] C:\Users\administrator\Desktop>New-WebServicesVirtualDirectory
    New-WebServicesVirtualDirectory : An error occurred while creating the IIS virtual directory 'IIS://S110.DOMAIN.LOCAL/W3SVC/1/ROOT/EWS' on 'S110'.
    At line:1 char:32
    + New-WebServicesVirtualDirectory <<<<
        + CategoryInfo          : InvalidOperation: (S110\EWS (Default Web Site):ADObjectId) [New-WebServicesVirtualDirectory], InvalidOperationException
        + FullyQualifiedErrorId : 515D170,Microsoft.Exchange.Management.SystemConfigurationTasks.NewWebServicesVirtualDirectory

    Any ideas on how I can recreate the EWS properly? Apparently it has hooks in AD as well, haven't found out which ones yet tho'. Google isn't particularly useful on these errors. Due to all the messing around they did to get M+ Archive (somewhat) working, I doubt there will be much machines with similar issues :D.

    Monday, June 27, 2011 2:32 PM

Answers

  • When checking the application pool, I noticed that when I removed the EWS application from IIS, the application pool still had an application left. Restarting IIS several times didn't help.

    The application it pointed to was EWS\bin (in the applicationpool thus), which actually is just a subdirectory of the EWS application. Checked all the applications, but none had that path. Removed the following section from : C:\Windows\System32\inetsrv\config\applicationhost.config:

    <application path="/EWS/bin" applicationPool="MSExchangeServicesAppPool">
    <virtualDirectory path="/" physicalPath="C:\Program Files\Microsoft\Exchange Server\ClientAccess\exchweb\EWS\bin" />
    </application>

    Restarted IIS. After that the applicationpool no longer showed any applications (I didn't not remove the applicationpool).

    After that new-webservicesvirtualdirectory ran just fine. Now just have to test some things, but Outlook already shows an OOF URL and an Availability Service URL, neither of these showed up yesterday in the automatic configuration test, so it's starting to look good. Just using the internal URL now, which isn't in the cert. Since the external URL points to the internal IP internally I'm just going to set it to that and see what happens.

    Thanks for the re'

    Tuesday, June 28, 2011 8:20 AM

All replies

  • Freek,

    What happens if you try to access the service like this via Internet Explorer:

    https://s110.domain.local/EWS/Exchange.asmx

    Regards,

    Johan 


    Exchange-blog: www.johanveldhuis.nl
    Monday, June 27, 2011 8:52 PM
  • Well, nothing anymore since I removed it from IIS and Exchange doesn't want to add it again (not through the 'correct' procedure through the exchange powershell anyways).

    I can manually add the EWS application, but not sure about the permissions/settings it requires. I added an application in IIS, called it EWS, selected the MSExchangeServicesAppPool (the others all seem to map 1:1 to exchange services, like OWA, UM, this was the one that made most sense to me) and selected "C:\Program Files\Microsoft\Exchange Server\ClientAccess\exchweb\ews" as path.

    When I go to /ews/exchange.asmx then nothing happened.

    Did some searching, turns out IE tries to connect by default through IPv6. The default site had no IPv6 bindings. Changed the IP address on the HTTPS binding to *. After that I see:

    HTTP Error 401.2 - Unauthorized
    You are not authorized to view this page due to invalid authentication headers.

    Connecting directly on https://<ipv4address>/EWS/Exchange.asmx returns the same.

    Digging further...

    Tuesday, June 28, 2011 7:55 AM
  • When checking the application pool, I noticed that when I removed the EWS application from IIS, the application pool still had an application left. Restarting IIS several times didn't help.

    The application it pointed to was EWS\bin (in the applicationpool thus), which actually is just a subdirectory of the EWS application. Checked all the applications, but none had that path. Removed the following section from : C:\Windows\System32\inetsrv\config\applicationhost.config:

    <application path="/EWS/bin" applicationPool="MSExchangeServicesAppPool">
    <virtualDirectory path="/" physicalPath="C:\Program Files\Microsoft\Exchange Server\ClientAccess\exchweb\EWS\bin" />
    </application>

    Restarted IIS. After that the applicationpool no longer showed any applications (I didn't not remove the applicationpool).

    After that new-webservicesvirtualdirectory ran just fine. Now just have to test some things, but Outlook already shows an OOF URL and an Availability Service URL, neither of these showed up yesterday in the automatic configuration test, so it's starting to look good. Just using the internal URL now, which isn't in the cert. Since the external URL points to the internal IP internally I'm just going to set it to that and see what happens.

    Thanks for the re'

    Tuesday, June 28, 2011 8:20 AM
  • Free/Busy and out of office seem to work fine now.

    Thanks

    Tuesday, June 28, 2011 8:38 AM