locked
MDT failures but not sure how to pinpoint what failed and how to resolve the issue RRS feed

  • Question

  • Wow, what a convoluted tool!

    Anyway I am trying to understand which Task failed and how to correct the problem but I don't even know where to begin. Here is a screenshot of what happens when I try to install using the LiteTouch I burned onto a USB stick: "Operating system deployment did not complete successfully." 

    And then there are various cryptic failure codes but now what?

    Thanks for your help.

    Friday, August 16, 2019 5:22 PM

Answers

  • So are there any clues to indicate why the failures?
    • Marked as answer by gregtompkins Tuesday, August 27, 2019 3:43 PM
    Monday, August 19, 2019 5:11 PM

All replies

  • From the Deployment Screen You can't able to trace the failure cause . Check the Log (BDD),SMSTS or post it here by uploading in public shared drive.
    Saturday, August 17, 2019 7:42 AM
  • That’s another issue I can go into F8 and even open the log file in Notepad but can’t save the files to USB drives I even tried to net use to my laptop and I can see the share but it’s italicized and won’t let me save. What gives ?
    Saturday, August 17, 2019 1:43 PM
  • Don't need to save! Insert USB stick, Browse the file location. Right click or Long press on file or folder choose send to option, USB drive! 
    • Edited by JiteshKumar Sunday, August 18, 2019 3:57 AM
    Sunday, August 18, 2019 3:56 AM
  • Hi Jitesh,

    Here is the content from SMSTS log file around the part that contains ERR

    <![LOG[Set a global environment variable _SMSTSInstructionStackString=0]LOG]!><time="15:23:50.448+480" date="08-16-2019" component="TSManager" context="" type="0" thread="988" file="executionenv.cxx:662">
    <![LOG[Set a TS execution environment variable _SMSTSInstructionStackString=0]LOG]!><time="15:23:50.448+480" date="08-16-2019" component="TSManager" context="" type="0" thread="988" file="executionenv.cxx:418">
    <![LOG[Save the current environment block]LOG]!><time="15:23:50.448+480" date="08-16-2019" component="TSManager" context="" type="0" thread="988" file="executionenv.cxx:827">
    <![LOG[Failed to save environment to  (80070057)]LOG]!><time="15:23:50.448+480" date="08-16-2019" component="TSManager" context="" type="2" thread="988" file="environmentlib.cpp:747">
    <![LOG[Failed to save the current environment block. This is usually caused by a problem with the program. Please check the Microsoft Knowledge Base to determine if this is a known issue or contact Microsoft Support Services for further assistance.
    The parameter is incorrect. (Error: 80070057; Source: Windows)]LOG]!><time="15:23:50.464+480" date="08-16-2019" component="TSManager" context="" type="3" thread="988" file="executionenv.cxx:836">
    <![LOG[Failed to persist execution state. Error 0x(80070057)]LOG]!><time="15:23:50.464+480" date="08-16-2019" component="TSManager" context="" type="2" thread="988" file="executionenv.cxx:430">
    <![LOG[Failed to save execution state and environment to local hard disk]LOG]!><time="15:23:50.464+480" date="08-16-2019" component="TSManager" context="" type="2" thread="988" file="engine.cxx:286">
    <![LOG[Set a global environment variable _SMSTSLastActionRetryCount=0]LOG]!><time="15:23:50.464+480" date="08-16-2019" component="TSManager" context="" type="0" thread="988" file="executionenv.cxx:662">
    <![LOG[Start executing an instruction. Instruction name: Gather local only. Instruction pointer: 1]LOG]!><time="15:23:50.464+480" date="08-16-2019" component="TSManager" context="" type="1" thread="988" file="engine.cxx:143">
    <![LOG[Set a global environment variable _SMSTSCurrentActionName=Gather local only]LOG]!><time="15:23:50.464+480" date="08-16-2019" component="TSManager" context="" type="0" thread="988" file="executionenv.cxx:662">
    <![LOG[Set a global environment variable _SMSTSInstructionStackString=0]LOG]!><time="15:23:53.224+480" date="08-16-2019" component="TSManager" context="" type="0" thread="988" file="executionenv.cxx:662">
    <![LOG[Set a TS execution environment variable _SMSTSInstructionStackString=0]LOG]!><time="15:23:53.224+480" date="08-16-2019" component="TSManager" context="" type="0" thread="988" file="executionenv.cxx:418">
    <![LOG[Save the current environment block]LOG]!><time="15:23:53.224+480" date="08-16-2019" component="TSManager" context="" type="0" thread="988" file="executionenv.cxx:827">
    <![LOG[Failed to save environment to  (80070057)]LOG]!><time="15:23:53.240+480" date="08-16-2019" component="TSManager" context="" type="2" thread="988" file="environmentlib.cpp:747">
    <![LOG[Failed to save the current environment block. This is usually caused by a problem with the program. Please check the Microsoft Knowledge Base to determine if this is a known issue or contact Microsoft Support Services for further assistance.
    The parameter is incorrect. (Error: 80070057; Source: Windows)]LOG]!><time="15:23:53.240+480" date="08-16-2019" component="TSManager" context="" type="3" thread="988" file="executionenv.cxx:836">
    <![LOG[Failed to persist execution state. Error 0x(80070057)]LOG]!><time="15:23:53.240+480" date="08-16-2019" component="TSManager" context="" type="2" thread="988" file="executionenv.cxx:430">
    <![LOG[Failed to save execution state and environment to local hard disk]LOG]!><time="15:23:53.240+480" date="08-16-2019" component="TSManager" context="" type="2" thread="988" file="engine.cxx:286">

    <![LOG[!--------------------------------------------------------------------------------------------!]LOG]!><time="15:33:44.504+480" date="08-16-2019" component="TSManager" context="" type="1" thread="988" file="instruction.cxx:816">
    <![LOG[Could not find CCM install folder. Don't use ccmerrors.dll]LOG]!><time="15:33:44.520+480" date="08-16-2019" component="TSManager" context="" type="0" thread="988" file="String.cpp:1364">
    <![LOG[Failed to run the action: Install Operating System. 
    Unknown error (Error: 000015FB; Source: Unknown)]LOG]!><time="15:33:44.520+480" date="08-16-2019" component="TSManager" context="" type="3" thread="988" file="instruction.cxx:924">


    Any idea what is happening?

    Thanks for your help!

    Monday, August 19, 2019 3:37 PM
  • Please check the below reference link.. The Issue is mostly related to Format and Partitions steps. 

    Reference link 1

    Reference link


    • Edited by JiteshKumar Monday, August 19, 2019 4:40 PM
    Monday, August 19, 2019 4:38 PM
  • Hello,

    Under Task Sequence, I have a Preinstall > New Computer only Should I have both a Format and Partition Disk (BIOS) as well as a Format and Partition Disk (UEFI)?

    

    Monday, August 19, 2019 4:50 PM
  • Yes.. Both partitions steps should be there.. It is executing based on the conditions. You can check the condition by clicking on Options tab. 
    Monday, August 19, 2019 5:00 PM
  • So are there any clues to indicate why the failures?
    • Marked as answer by gregtompkins Tuesday, August 27, 2019 3:43 PM
    Monday, August 19, 2019 5:11 PM
  • Validate the Applied Answer file (Unattend.xml), Check the location DeploymentShare\Control\TS_ID\Unattend.xml
    Tuesday, August 20, 2019 6:19 AM
  • Hi,

    Where do I find the Unattend.xml file? I am not using WDS I am only using DeploymentWorkbench and then using the ISO to create a bootable USB drive.

    Thank You!

    Thursday, August 22, 2019 9:50 PM