none
Windows Update Step hanging - Windows 10 1607 RRS feed

  • Question

  • I have encountered an issue with the version of Windows and MDT. 

    Caputured a custom WIM and during deployment the Windows Update step finds a couple of updates and attempts to download and install them from WSUS server.  It just hangs when at installing update.

    I have also installed the latest WADK and created updated boot images etc.

    It looks like the updates are installing but are not moving onto the next one, as the update is showing in WU e.g. KB3176929 gets stuck at installing but seems to install.

    Any ideas?

    Tuesday, August 2, 2016 9:24 PM

Answers

  • KB3176929 is the Anniversary update. I am wondering if there are issues working with the earlier ADKs.  MS has released ADK version 1607 for download.
    Wednesday, August 3, 2016 9:22 PM

All replies

  • Also happening to me.

    Gets to 55% and locks up the computer.

    I'm suspecting its my Samsung NVME 950.

    What's up Microsoft ?

    Wednesday, August 3, 2016 6:00 AM
  • I am having the same issue.

    1607 Education x64 placed into my MDT build capture sequence.

    VM build is fine, stuck on the same update as mentioned in OP.

    Help..

    Wednesday, August 3, 2016 7:47 AM
  • Asked the question on Twitter too, and it's a bug it seems.

    If you remove WSUS and deploy it will download and install.

    Hopefully a MDT update will fix this issue soon?

    Wednesday, August 3, 2016 5:30 PM
  • I assume you are using MDT 2013 update 2,

    have any of you tried to block the updates that are hanging ? i guess it was you Stephen who tweeted to me ?

    WUMU_ExcludeKB001=whatever KB number the silverlight patch is


    Step by Step Configuration Manager Guides > https://www.windows-noob.com/forums/topic/13288-step-by-step-guides-system-center-configuration-manager-current-branch/


    Wednesday, August 3, 2016 7:30 PM
    Moderator
  • ok you guys are pointing to WSUS,

    try pointing to Windows Update instead until a fix/workaround is found


    Step by Step Configuration Manager Guides > https://www.windows-noob.com/forums/topic/13288-step-by-step-guides-system-center-configuration-manager-current-branch/

    Wednesday, August 3, 2016 7:37 PM
    Moderator
  • Hi Niall, it wasn't me who tweeted you but I did tweet last night and had replies that confirmed its an issue. Thanks.
    Wednesday, August 3, 2016 8:16 PM
  • KB3176929 is the Anniversary update. I am wondering if there are issues working with the earlier ADKs.  MS has released ADK version 1607 for download.
    Wednesday, August 3, 2016 9:22 PM
  • Hello,

    you can download the update from Microsoft update catalog. (https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3176929)

    Then use dism to add the update to your windows image and import your image with the update in MDT.

    Hope it helps

    Thursday, August 4, 2016 7:21 AM
  • Johann posted a good article on working around the issue. Add KB3176929 as a package in MDT then run the build.

    http://deploymentresearch.com/Research/Post/540/Building-a-Windows-10-v1607-reference-image-using-MDT-2013-Update-2

    Thursday, August 4, 2016 11:48 AM
  • Thanks everyone going to add the update into a package on my MDT.

    Cheers.

    Thursday, August 4, 2016 3:23 PM
  • Applying this update (along with the latest version of ADK to MDT) did not help. Windows Update is still getting stuck downloading updates when trying to create a reference image with 1607. Very frustrating! One thing I noticed is that it hangs on Office 2016 updates, but not Windows Updates. Has anyone successfully gotten past the Windows Update task sequence step with Windows 10 1607?
    Saturday, August 6, 2016 4:01 AM
  • Not working for me... :(

    Still stuck on Windows Update.

    Monday, August 8, 2016 10:25 AM
  • It has to be a bug when connected to WSUS.  A new Cumulative update for Win10 1607 came out today but that got stuck too.   Of course their were tons of Office 2016 updates too so maybe it is  the Office updates that are the problem.   I have posted in another thread about this using WSUS after the imaging process and not in MDT but it is a problem either way.

    If you run Windows update via WSUS after the machine is imaged you will notice tons of services crashing in the event log.   So if you are persistent you can get the machine to update.  After that I have found it will download defender definitions just fine.

    Looks like I am going to have to revert my group policy to go back to online until this is resolved.

    Wednesday, August 10, 2016 2:31 AM
  • I am getting installation failure 0x80070643 with the definition file being applied, then all subsequent updates fail.

    Excluding WSUS. TS works end to end.

    Wednesday, August 10, 2016 1:45 PM
  • Same here, I have applied KB3176495 in the standard Apply Patches step during Preinstall phase as Arwidmark described. I can see that the patch is installed through ARP when MDT tries the first Windows Update step. But the step is stuck in downloading.

    toxaris

    Sunday, August 14, 2016 7:19 PM
  • Same thing.  Hung in MDT TS, "Installing Microsoft Silverlight (KB3162593)".

    There's no place like 127.0.0.1

    Tuesday, August 16, 2016 8:32 PM
  • If you package I the latest Cumulative Update it seems OK now

    Richard P

    Tuesday, August 16, 2016 8:44 PM
  • If you package I the latest Cumulative Update it seems OK now

    Richard P

    All the blog posts I have seen on that seem to indicate that is true.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Wednesday, August 17, 2016 2:43 AM
    Moderator
  • Even if you include/package the cumulative update, it gets stuck on certain updates including ones for Office later on.
    • Edited by pbrrua42 Friday, August 19, 2016 4:10 PM
    Friday, August 19, 2016 4:09 PM
  • Hi,

    I am also experiencing issues using the ZTIWindowsUpdate.wsf in a SCCM TS. It helped when i added the cumulative update when installing OS without Office package. But it hangs on "downloading..." for Office updates. Anyone managed to solve this? I am trying to read the windowsupdate.log after i ran the get-windowsupdatelog powershell command but that log doesnt make any sence to me compared to the old windowsupdate.log

    Thanks

    Monday, August 22, 2016 12:43 PM
  • Well out of the Blue it started happening again? Been working fine since I made my image with the latest cumulative updates but now I just imaged 3 machines and all are hanging on office 2016 updates with the same services failing.

    How frustrating.
    Tuesday, August 23, 2016 5:04 PM
  • After packaging the CU, it's still hanging on Silverlight and Windows Defender updates.

    There's no place like 127.0.0.1

    Tuesday, August 23, 2016 7:01 PM
  • KB3176929 was superseeded by KB3176495. My guess is that KB3176495 caused the problem to occur again.
    Wednesday, August 24, 2016 6:40 AM
  • I just tried it with the newest CU - KB3176934 but stille the same problem.

    I then added KB3176936 (Servicing stack update for Windows 10) together with KB3176934 and now it install other updates without any problem and the image is captured :-)

    • Proposed as answer by Speedbird186 Tuesday, August 30, 2016 8:48 PM
    Thursday, August 25, 2016 9:32 AM
  • I think this is related to the general WSUS issues with 1607. I have tried a bunch of different combinations of hotfixes/CU etc and cant get it working. The wsus service crashed after client is deployed aswell, check your event logs.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/5521e7f1-fa2d-4867-a47c-b276c66e6a82/windows-10-anniversary-update-1607?forum=winserverwsus


    EDIT: I also tried adding the reg keys for Delivery Optimization and it didnt help.

    REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DeliveryOptimization" /v DODownloadMode /t REG_DWORD /d 100 /f

    It freezes on download update. I checked event log on the computer when this freeze happens during OS-deployment and i get application error event id 1000 svchost.exe_wuauserv crash..

    • Edited by danisaksson Monday, August 29, 2016 8:37 AM
    Monday, August 29, 2016 8:02 AM
  • Hey Guys,

    I was also having this issue, stuck downloading updates.. previously had KB3176929 injected to get around the issue.. but a week or two later.. same issue.. sits there never downloading:

    Today have imported the KB3176938 package..

    Now seems to be downloading:

    Task Sequence is proceeding past the Windows update stage.. all looks good... I'll let you know if it fails the post windows update task

    PS. I hate updates.

    Wednesday, August 31, 2016 11:53 PM
  • Nothing new? I still have this issue in MDT Windows update step with KB3176938 and KB3176929 slipstreamed. WSUS 3.2 running on 2008 R2 Server.

    Wednesday, September 7, 2016 8:30 AM
  • Adding update KB3176936 (servicing stack) and the most recent CU KB3176938 to Windows manually (or offline with DISM/MDT) appears to resolve the issue with hanging downloads & installs of updates from a WSUS server. E.g. Silverlight and Flash updates now get downloaded as expected.

    The servicing stack update makes all the difference. Purely including the most recent CU is not sufficient.

    Monday, September 12, 2016 10:21 PM
  • Unfortunately KB3176936 and KB3176938 didn't help in our case but finally KB3189866 (newest CU for Windows 10 1607) solved this problem - just include it as package into your deployment workbench (and take care that it will be used in the correct task sequence of cause...) and updates provided via WSUS will be installed properly again. Nothing more is necessary to be able to build a reference image for Windows 10 1607 if you have your infrastructure already on the newest patch level (especially no changes in the registry or IIS Settings - only the steps descriped in KB3159706 have to be done but this was already necessary before Win10 1607 was released!).

    Tuesday, September 13, 2016 8:41 PM
  • I would like to confirm that KB3189866 solves the issue. Updates are downloading and installing now. I included this into the image. Please notice that the KB3189866 states the following:

    "Important If you install a language pack after you install this update, you must reinstall this update. Therefore, we recommend that you install any language packs that you need before you install this update"

    In other words include your LP in the image. I was deploying the LP during final deployment of client. I have added the LP's to the image now and it seems to work.

    Wednesday, September 14, 2016 1:17 PM