none
Windows 10 Anniversary Update Breaks the DPM Client RRS feed

  • Question

  • The update made the client stop working. A little investigation shows that the update removed sisbkup.dll that the DPM client depended on. Is there a fix for this?

    [url="http://www.digitaldnagames.com"]DigitalDNA[/url]


    • Edited by DigitalDNA Saturday, August 13, 2016 11:51 PM
    Saturday, August 13, 2016 11:51 PM

All replies

  • Hello, I have the same problem with Windows 10 version 10.0.14393 and DPM 2012 R2 UR 10, client version 4.2.1473.0.

    PS: Windows 10 is not on DPM protection support matrix. https://technet.microsoft.com/en-us/library/jj860400(v=sc.12).aspx updated July 29, 2016.

    • Edited by Slowensko Monday, August 15, 2016 12:50 PM
    Monday, August 15, 2016 12:45 PM
  • Yes same issue here with Windows 10 1607 and DPM client, I've been wrestling with it for 2 weeks.  I tried both manual and push reinstalls of the client, removing malware protection etc.  The only thing I can add is that if you copy the sisbkup.dll from a Windows 10 1511 machine and put it into C:\Windows\System32 on machine with the Anniversary update, this will allow the client to be reinstalled without error.  However, after you add the client to a protection group in the DPM console it never performs it's automatic initial replica creation.  And you cannot trigger this via the client interface or the console.  I have not tried a powershell command yet but I will post if I find a way to do it.  I'm running DPM Server 2012r2 UR10 DPM Client 4.2.1473 and Windows 10 14393.51.
    Wednesday, August 17, 2016 6:32 PM
  • Yep, same issue on my end. 

    I'll try the sisbkup.dll trick you mentioned, and see if I can make any progress from there.

    It would be appalling if Microsoft decides not to have any System Center 2012 R2 support for Windows 10 1607 (and newer) whatsoever, forcing everyone to purchase new licenses for System Center Current Branch/2016...

    (Side Note: 1607/Anniversary also breaks Configuration Manager agents as well, but that issue is more hit-and-miss, and would be more appropriate to put in that particular forum). 

    Thursday, August 18, 2016 4:20 PM
  • Update on this issue:

    If the agent is already configured in the DPM console, simply copying the sisbkup.dll file to C:\Windows\System32 allows the agent to re-sync. 

    The initial sync is still a problem as Rambolini mentioned.


    Thursday, August 18, 2016 5:01 PM
  • New development on the initial replica creation: It worked on its own.  Unable to find a way to trigger the new replica, I had to go deal with other issues.  I left the newly re-installed client over night pending automatic replica creation, this time I left it waiting well over 24 hours.  I had done that once before (or so I had thought).  But finally this time it triggered replica creation on its own.  So now I am synced up again.  I don't have any proof but my best guess is that maybe a DPM maintenance cycle had to take place without interference from me before the next scheduled sync and recovery point (?).  Hopefully that averts the bad situation you mention for Microsoft, which, I agree, would be appalling. 
    Thursday, August 18, 2016 8:40 PM
  • From my SCCM forum posting, it looks like an even better solution for us is to upgrade to the Current Branch (System Center 2012 R2 with updates to 1511 and then to 1602), as apparently all System Center 2012 (R2) licenses have Software Assurance, removing the sticker shock of doing so. 

    EDIT: Getting conflicting information on the SA part.  You might want to check your VLSC portal or wherever you purchased your System Center 2012 R2 from to see if you have SA.  If you do, then update to the Current Branch for continued Windows 10 (and Server 2016) support.  If not, then your options are pretty much the following:

    DPM: The above sisbkup.dll workaround
    SCCM: Pretty much SOL at least according to the replies from my SCCM forum posting.
    SCOM/OpsMgr: Haven't run into any major problems with 2012 R2 SP1 and Windows 10 (Either UR9 or UR10 is current)
    SCVMM: Works fine with Windows 10, Server 2016 TP5 Guests.  The console does crash when installed on Server 2016 TP5 or Windows 10 Anniversary Edition because of .NET 4.6.2.

    Orchestrator, AppController, and Service Manager: Don't know. 

    NEW EDIT: Boy does Microsoft make this confusing!!!!!!

    The other System Center components are still in Technical Preview phase.  Config Manager is the only one that's in "Current Branch." 


    Monday, August 22, 2016 5:48 PM
  • Hello, I have the same problem with Windows 10 Anniversary update (10.0.14393) and DPM 2012 R2 UR 11 (4.2.1553.0)

    Does workaround with copying the sisbkup.dll work only if DPM agent was installed before Anniversary update?

    (I tried manual install DPM agent on Win 10 PC with Anniversary update and copying sisbkup.dll didnt help)

    Friday, September 30, 2016 8:55 AM
  • Once you install the Anniversary Update, sisbkup.dll disappears from C:\Windows\System32.

    Simply copy the file to C:\Windows\System32 before you install the DPM agent, and it should work without a problem.

    Tuesday, October 4, 2016 7:39 PM
  • It works - copying the sisbkup.dll before the DPM agent installation.

    Thanks!



    • Edited by TuminD Thursday, October 6, 2016 1:09 PM
    Thursday, October 6, 2016 12:26 PM
  • I can't get the sisbkup.dll workaround to help at all.  When I copy the dll to c:\windows\system32 and install the DPM 2012 R2 client, it seems like everything is working, but no files are backed up.  On the DPM console I am seeing this error message:

    The protection agent on <Computer Name> was temporarily unable to respond because it was in an unexpected state. (ID 60 Details: Internal error code: 0x809909B0)

    Is anyone else seeing this behavior or is it just me?

    Friday, October 7, 2016 7:01 PM
  • Same behavior. I have copied sisbkup.dll with DPM2012 r2 UR11 client (W10 AU 1607) seems ok but no files backup.

    Error The protection agent on <Computer Name> was temporarily unable to respond because it was in an unexpected state. (ID 60 Details: Internal error code: 0x809909B0)




    • Edited by nicogis Monday, October 10, 2016 1:53 PM
    Monday, October 10, 2016 1:50 PM
  • Make sure it's the correct sisbkup.dll file. 

    For example, don't copy C:\Windows\System32\sisbkup.dll from a 32-bit computer to a 64-bit computer or vice versa. 
    Monday, October 10, 2016 3:33 PM
  • Yes, I have made copy from 64bit to 64bit.


    • Edited by nicogis Monday, October 10, 2016 4:06 PM
    Monday, October 10, 2016 4:05 PM
  • I made the copy from 64-bit to 64-bit as well.  No luck here.
    Monday, October 10, 2016 4:12 PM
  • Hmmmm...that's weird. 

    I was able to get it working with machines in all of the following situations:
    a) In-place upgraded from Windows 7 to 10 Anniversary/1607
    b) In-place upgraded from 10 1511 to 10 Anniversary/1607
    c) Clean installed 10 Anniversary/1607.

    I wonder if there's an issue with the version of sisbkup.dll?  My file version is 10.0.10586.0, dated 10/30/2015, 2:17 AM. 

    Monday, October 10, 2016 4:15 PM
  • My sisbkup.dll is the same file version and date.  I am trying another clean install of 1607 now.
    Monday, October 10, 2016 5:13 PM
  • Same thing on a clean install.  It just sits there saying Idle on the client end.  It shows no protected items either.  I'm at loss here...

    Monday, October 10, 2016 7:23 PM
  • The clean install machine still isn't working, but yesterday afternoon the upgraded clients where I copied sisbkup.dll suddenly started working.



    • Edited by TigraoKen Wednesday, October 12, 2016 7:59 PM
    Wednesday, October 12, 2016 7:58 PM
  • Does DPM 2016 (Just released) fix this issue? Anyone have any experience in that yet? We are planning to upgrade in the next 14 days. Anniversary Update has been on hold since this issue (as well as the SCCM issue) became known.
    Friday, October 14, 2016 1:54 PM
  • We actually upgraded our DPM server to the 2016 evaluation and it didn't fix this problem.  We rolled back to 2012 R2.
    Friday, October 14, 2016 5:32 PM
  • I've been doing a lot of testing on this over the past few days (as you can tell by my flood of posts).  I can consistently get clients working now when they upgrade from build 1511 to build 1607.  I cannot, however, get clients to work when build 1607 is fresh installed.  The first thing I do is copy the build 1511 sisbkup.dll file to c:\windows\system32 and then I install the DPM 2012 R2 UR 11 client.  It just sits like this forever:

    On the server, when I try to initiate a consistency check it throws this error:

    So apparently the server hasn't received any communication from the client.

    I really don't understand why there would be a difference between an upgrade install and a fresh install when it comes to the DPM client.

    Anyone else out there seeing these results?



    • Edited by TigraoKen Friday, October 14, 2016 5:43 PM
    Friday, October 14, 2016 5:40 PM
  • This is strange...

    I think the problem is more with the Anniversary Update removing sisbkup.dll than any version of DPM. 

    For some reason, I'm having good luck with:
    A) Copying the dll file before installing the DPM client (must do with a clean install of Win10 1607).  It does take a while for the initial sync to work.  You may even have to restart the DPM Services on both the server and client. 

    B) Having the client already installed on an older version of Windows (Windows 7, Windows 8.1, Windows 10 1511, etc.), upgrading to 1607, copying the dll to the upgraded machine, and then in the DPM console, right-click the protected item and then "Create Recovery Point...".  Select "Create a recovery point after synchronizing."

    For those that are not having luck with either of the above, I wonder if the dll has to be registered (regsvr32) first? 

    Perhaps there could also be a permissions issue?


    Friday, October 14, 2016 5:41 PM
  • @Eerazor:

    For the SCCM issue, you have to upgrade to SCCM Current Branch for the Anniversary Update to be supported.
    (It's kinda messed up that the new SCCM is called "Current Branch" while the other System Center components have "2016" at the end of it.  The biggest reason for this may be because of how SCCM is updated compared to the rest).

    Anniversary Update clients are incredibly hit-and-miss with SCCM 2012 R2, and you're not going to get any support on fixing the "misses." 

    SCOM 2012 R2 seems to work fine with Win10 1607. 

    VMM 2012 R2 works fine with Win10 1607 Guests on Server 2012 R2 and 2016 hosts (Integration Services are upgraded with the guest operating system's Windows Updates, making life easier). 


    Friday, October 14, 2016 5:48 PM

  • For those that are not having luck with either of the above, I wonder if the dll has to be registered (regsvr32) first?


    Looks like regsvr32 isn't the answer:


    Friday, October 14, 2016 6:09 PM
  •   

    ...then in the DPM console, right-click the protected item and then "Create Recovery Point...".  Select "Create a recovery point after synchronizing."



    I know you put this quoted text in your "B" scenario, but I am trying it with the "A" scenario in desperate attempt to get a clean install of 1607 to work.  This is the error I get when trying to create a recovery point:

    If there was some way to manually create the replica then maybe I could get clean installed clients to work?

    Friday, October 14, 2016 8:01 PM
  • Yep, that's going to pop up if you add a new client and it hasn't had a chance to create a replica, regardless of OS.

    Try going to Monitoring -> All Jobs in Progress to see if it's actually creating the replica.  I think it even shows how much data is being copied. 

    Friday, October 14, 2016 8:04 PM
  • Yeah, I've been watching All Jobs in Progress.  There's been absolutely no sign of the clean install client connecting.

    I've tried this on a couple of laptops and a VM.  It's consistent behavior.

    For now we are installing build 1511 and upgrading to 1607.
    • Edited by TigraoKen Friday, October 14, 2016 10:04 PM
    Friday, October 14, 2016 10:02 PM
  • I have upgraded to DPM 2016 UC1 but it doesn't resolve. I also have removed sisbkup.dll


    • Edited by nicogis Monday, October 17, 2016 10:06 AM
    Monday, October 17, 2016 10:06 AM
  • I left a fresh install VM running over the weekend.  It looks like on Saturday at 2:00 p.m. or so it decided that it knew how to contact the DPM server and run a successful synchronization.  I guess you just have to wait for several days?  This makes zero sense to me.
    Monday, October 17, 2016 2:49 PM
  • @nicogis:

    Don't -REMOVE- sisbkup.dll!  If you remove that file, you -WILL- have problems using any version of DPM with any version of Windows!!!

    Monday, October 17, 2016 2:53 PM
  • @TigraoKen:

    ...yeah, unfortunately every System Center product (SCCM is the worst offender) has these moments of "wait a long time before things start to work."  Sometimes jobs can be started from the GUI, sometimes through Powershell or WMI queries, others are just "wait while you have absolutely no idea what's happening."
    Monday, October 17, 2016 2:57 PM
  • @Brandon

    I have removed only on windows 10 1607. In this version there isn't sisbkup.dll in system32 and when I have installed agent dpm2016 this file hasn't been installed. However it doesn't resolved the problem (without/with)



    • Edited by nicogis Monday, October 17, 2016 6:15 PM
    Monday, October 17, 2016 6:14 PM
  • @nicogis

    ...then you need to copy sisbkup.dll from a PC that has the file in C:\Windows\system32 over to your Windows 10 1607 PC. 

    ...as @tigraoken experienced, you need to wait a while before DPM starts syncing the replica. 

    Monday, October 17, 2016 6:22 PM
  • @Brandon

    ... so hasn't resolved Microsoft this problem with dpm2016 and I need copy sisbkup.dll  ? Isn't there an official document on this issue ? and then from where I copy this file: windows 2012r2, windows 7 ect ?





    • Edited by nicogis Monday, October 17, 2016 6:31 PM
    Monday, October 17, 2016 6:28 PM
  • After in-placed upgrade
    1. Open Task Manager
    2. Click the Details Tab and find DPMClient.exe and DPMClientUI.exe - close both of this process
    3. Copy the sisbkup.dll from C:\Windows.old\WINDOWS\System32 to C:\Windows\System32\
    4. Run DPM Client and should be able to sync now.

    • Edited by AncientUser Thursday, October 27, 2016 8:07 AM
    Thursday, October 27, 2016 8:06 AM
  • I have called support Microsoft and they confirm me that it is a bug


    for client windows 10 1607 & DPM 2016UR1 I have resolved:

    1) copy windows\system32\sisbkup.dll from client windows 10 1511 to windows\system32 of client windows 10 1607

    2) on every client windows 10 1607

    1. Open the Task Scheduler app.
    2. In the Task Scheduler library, find and select the scheduled job, ScheduledDPMClientBackup.

    3. In the Actions pane, click Export and save the xml output as a backup copy.

    4. In the Actions pane, click Properties.

      The properties dialog box for ScheduledDPMClientBackup opens.

    5. In the Properties dialog, select the Triggers tab, and click Edit.

    6. In the Edit Trigger dialog, from the Begin the task drop-down menu, select At log on.

    7. In Advanced settings, check Repeat task every and select 15 minutes. From the for a duration of menu, select Indefinitely, and then click OK.

    8. You must reboot the computer for these changes to take effect.




    • Edited by nicogis Wednesday, November 2, 2016 8:52 PM
    • Proposed as answer by Mitch_Phx Wednesday, November 2, 2016 10:14 PM
    Thursday, October 27, 2016 8:24 AM
  • Nicogis' answer solved the issue for me.
    Wednesday, November 2, 2016 10:14 PM
  • Thanks for this fix, it was driving me nuts trying to figure out why I was having this problem.  I'm really pissed Microsoft doesn't test any of their software in house anymore and instead is relying on the user community to test software. This is so disgusting for them not to mention how incredibly stupid they have become. From the huge security hole with the new peer to peer updating which was recently exploited and shown to being totally unsecure to this crap.  What in the heck Microsoft stop doing this crap. 
    Monday, November 7, 2016 7:46 PM
  • I'd just like to add the following....

    This fixed the issue for me.  I had to find a copy of the sisbkup.dll that was on a 'PRE-UPGRADED' copy of windows 10. This was the 'ONLY' one that worked for me.  Others i tried did not work.  I was able to find one in the copy of the windows.old folder..  Note that this folder gets removed/deleted after so many days.  (On another computer that had been updated about 60 days ago the folder was not on there so we had to grab it from a brand new one)

    Once you have the file first stop all DPM services.  (anything that says DPM related there are 3 total services however at least one is disabled) Then copy the file over to the location mentioned above.

    After that, restart services and find the backup task and Nicogis's instructions.

    I did this and mine are now working.  The one computer that had been upgraded a while back did not have the scheduled task on it so i'll have to create it manually somehow. I'll update to let you know if that works and how i did it.

    Wednesday, November 9, 2016 6:17 PM
  • Just a note that I had to do this on Windows Server 2016 to get DPM2012R2 DPMR service to start.

    Wednesday, November 16, 2016 10:21 PM
  • Hello, this issue is still present. Does anyone has information when Microsoft will fix it ?

    We have DPM 2016, Update Rollup 1 for SCDPM 2016 and still can't backup laptops with windows 10 1607 versions.

    Copy sisbkup.dll from some windows 10 without 1607 can't be solution. I can't believe thet Microsoft didn't solve it in DPM 2016....  

     
    Wednesday, December 7, 2016 7:16 AM
  • Hello, AlaskaWagner

    Could you please help me and upload this sisbkup.dll file on some filehosting or e-mail it to me on forregistrq@live.ru ?

    I can't find 1511 version, it seems all computers with anniversary update in my network have already deleted the Windows.old folder


    • Edited by rizev Wednesday, December 7, 2016 7:33 AM
    Wednesday, December 7, 2016 7:32 AM
  • Installing DPM 2012R2 agent on Windows server 2016 (windows 10)

    Overwrite the target server (win 2016 or windows 10) file "sisbkup.dll" in the folder "C: \ Windows \ System32". This file can be found on any server (Win7-2008-2012) where the agent is installed DPM 2012R2.

    Run the command regsvr32 C: \ Windows \ System32 \ sisbkup.dll

    Clean the target server on the DPM Agent traces (possibly appear in the case of failed attempts Agneta installation)
    1. Ensure that there is no installed agent DPM to install the removal program.
    2. Check for any remaining service agent (DpmCPWrapperService, DPMRA).
    3. Remove the folder c: \ Program Files \ Microsoft Data Protection Manager \ if any.

    Add the DPM server in the local target server.

    Install DPM 2012R2 agent from the Data Protection Manager Management Console
    Tuesday, December 27, 2016 12:48 PM
  • Hello, 

    I tried this today, and I can confirm that this workaround is working. I picked sisbkup.dll from server who is backed up with DPM2012 and paste it on windows 10 1607.

    Thanks 

    Thursday, January 5, 2017 11:55 AM
  • Hello.

    I have Windows 10 1607 build 14393.576 and like everybody here cant install DPM 2012 R2 agent.

    I tried to copy sisbkup.dll from another Windows 2012 R2 server to WIn10 host, but regsvr32 showed error and did not registered dll and DPM agent cant start/

    For me this problem is still actual. Reading this topic there is no 100% solution for every case!

    Wednesday, January 18, 2017 9:38 AM
  • I have been trying to get the remote agent installed onto a Windows 10 machine with anniversary update for sever weeks. I've copied the sisbkup.dll two different versions: 10.0.10240.16384 & 10.0.10586.0 with no results. Why people suggest running regsvr32 on it is odd ad they would have know that it would show an error.

    Our DPM server is 2012 R2 Rollup 11. I can't just reimage my computer to an older version of windows as I have tons of development tools on it.

    How is it that there is no way to get this agent to install onto a windows 10 enterprise with anniversary update.

    Friday, January 27, 2017 8:24 PM
  • I haven't tried it myself yet, but UR12 mentions some issues fixed regarding Windows 10 Anniversary Update.
    Wednesday, February 8, 2017 1:30 PM