none
Windows Media Player in Windows 8 Pro-64 Bit - Server Execution Failed RRS feed

  • Question

  • I'm running Windows 8 Pro - 64bit.  I have also installed Windows Media Center add-on.

    Windows Media Player returns an error "Server Execution Failed" when attempting to load any non-music media file, such as .avi, .mp4, .wmv, etc.   These files open and play properly in the base Windows 8 "app" Video, and in Windows Media Center.

    WMP opens OK from a desktop shortcut and updates it's music libraries.  It plays all types of audio-only media files properly. 

    I have tried all the various "fixes" for various versions of Windows and WMP including removing WMP as a feature, rebooting and "re-installing" it as a feature... I've run regserv.dll, etc. all to no avail...

    I just want WMP to be the default "media" player for all standard file types...

    Anyone have any suggestions... ?

    Thanks... MTGB

    Tuesday, December 4, 2012 2:07 PM

All replies

  • You can try the following suggestions.

    Method 1.
    1. Control Panel -> Administrative Tools -> Services. Find the Windows Media Player Network Sharing Service, stop it temporarily.
    2. Close Windows Media Player 12 if it is started.
    3. input %USERPROFILE%\Local Settings\Application Data\Microsoft\Media Player\ to Windows Explorer to find the folder.
    4. Move all files in the folder to another place as a backup. Move files in the specific folder will reset database.
    5. Restart service and Windows Media Player to check the result. 

    Method 2. 
    1. Open command prompt with Admin.
    2. In the command prompt type the following command

         net localgroup "Administrators" "NT Authority\Local Service" /add

    3. Restart the computer to check the result.


    Niki Han
    TechNet Community Support

    Wednesday, December 5, 2012 8:57 AM
    Moderator
  • Hy Niki Han, and thanks for the answer. I have the same problem, but unfortunately no one is listening. The proposed solutions are not working and this is really frustrating. I have WMP12 on Windows 8 x64, I have tried all the proposed solutions both for Win8 and Win7 (like the ones you propose, I have also tried registering the two missing dlls, uninstalling and reinstalling WMP), but no result. I have tried disabling my antivirus with no luck. It is really frustrating that Microsoft is proposing “the most modern operating system” and yet isn’t able to make a proper media player!!!

    Don’t know if this can help, but I have noticed that I have installed both the 32 and 64 bit version of WMP, I can’t imagine why. When I manually run the 64 bit version it runs fine. When I manually set that one as the default media player (by selecting “C:\Program Files\Windows Media Player\wmplayer.exe” as the default program to open a specific type of file), Windows is automatically making the 32 bit version of WMP as the default media player(?!?!?!). I mean, common, I cannot even decide what program to use to open my files?!? I’m telling you, it is incredibly frustrating!

    Wednesday, December 5, 2012 9:30 AM
  • Yes, thanks... these methods are just not working... the problem persists...MTGB

    Saturday, December 8, 2012 8:42 PM
  • I've been having a similar problem, all folders/directories are visible from the various media players that i stream to, yet all of them show all the folders as being empty of any files. Sharing folders over the network works fine, but when it comes to Windows Media Player's streaming server, nothing seems to work. I have exhausted all methods of fixing this problem, to no result. Ironically, the media servers created by the old media player on Windows 7 works just fine.  It is very frustrating that Microsoft has once again disappointing me when it comes to handling multimedia. 
    Sunday, April 7, 2013 8:55 PM
  • This killed me for a while.

    But following method 1, and then just disabling the Windows Media Player Network Sharing Service and leaving it off fixed the problem for me.

    Probably not the solution ppl are looking for if you're looking to share, but I only wanted it to have wmp play my music and video files

    Monday, May 27, 2013 11:15 PM
  • Niki Han thank you very much for the solution! Method 1 worked instantly!

    Guys make sure to make hidden folders visible and delete that one as well, that could be the reason why it didn't work for you as the hidden folder is a cache folder.

    Friday, August 23, 2013 2:02 PM
  • I tried all of the solutions and nothing worked... at first.

    Then I did the uninstall/reinstall.  Which didn't work until I also did this:

    1. Click Start, click Accessories, the right click on Command Prompt and choose "run as administrator", then type regsvr32 jscript.dll, and then hit enter.
    2. Type regsvr32 vbscript.dll then hit enter.
    3. Now type exit and hit enter. Now try media player and it should work.

    It worked!

    Monday, October 14, 2013 12:49 AM
  • None of the above have worked for me. I get this every 1/3 times loading a video.
    • Proposed as answer by tgaryharvey50 Tuesday, May 27, 2014 9:43 PM
    • Unproposed as answer by tgaryharvey50 Tuesday, May 27, 2014 9:44 PM
    Sunday, May 11, 2014 3:32 PM
  • This worked for me.

    1.  Rename the Windows Media Player folder in Program File (x86) (32 bit) folder to whatever you want 

    2. Copy the Windows Media Player folder in the Program Files (64 bit) folder and paste into Program File (x86) folder.

    3. This puts a non corrupted Windows Media Player into the default path,

    This worked great for me.  This also leaves a non corrupt version for future needs.

    Sometimes simple is better.


    • Proposed as answer by Arnav Akarsh Monday, September 1, 2014 3:34 AM
    Tuesday, May 27, 2014 9:44 PM
  • Thanks...worked for me.
    Monday, July 28, 2014 3:56 PM
  • that buttersoft solution.. worked like charm... super easy

    Arnav Akarsh (Social Technet)

    Monday, September 1, 2014 3:35 AM
  • superb solution ...

    Saturday, January 17, 2015 9:21 AM
  • thank you very much

    Saturday, January 17, 2015 9:21 AM
  • Thanks tgaryharvey50, that's working for me.

    Wednesday, April 22, 2015 2:25 AM
  • this method works 100%, thanks.
    Tuesday, February 2, 2016 1:18 PM