none
Purchased Key for Download of application RRS feed

  • Question

  • After entering the product key at www.office.com/setup the a download does not start.  I have "We're sorry for the wait.  The page is taking longer to load than expected" which has been on the screen for an hour....has anyone experienced this?
    Saturday, April 5, 2014 5:13 PM

Answers

  • I had your same issue while trying to download access which had already been paid for. I tried different machines on different networks ranging from windows 7, 8 and 10. Firefox, Chrome and IE, all of them hung at "We’re sorry for the wait. The page is taking longer to load than expected." and showed my target, the download button grayed out in the background. 

    The fix: 

    the URL you are led to is https://stores.office.com/myaccount/home.aspx

    remove the /home.aspx in the address bar so you are going to https://stores.office.com/myaccount

    The install button lights up. 

    Tuesday, December 1, 2015 3:19 PM

All replies

  • Rick,

    You may try the download with another browser.  Make sure you keep the key data where you can reference it again.

    • Proposed as answer by rdeces Tuesday, December 1, 2015 3:15 PM
    • Unproposed as answer by rdeces Tuesday, December 1, 2015 3:15 PM
    Sunday, April 6, 2014 5:17 PM
    Moderator
  • I had your same issue while trying to download access which had already been paid for. I tried different machines on different networks ranging from windows 7, 8 and 10. Firefox, Chrome and IE, all of them hung at "We’re sorry for the wait. The page is taking longer to load than expected." and showed my target, the download button grayed out in the background. 

    The fix: 

    the URL you are led to is https://stores.office.com/myaccount/home.aspx

    remove the /home.aspx in the address bar so you are going to https://stores.office.com/myaccount

    The install button lights up. 

    Tuesday, December 1, 2015 3:19 PM
  • Worked for me
    Tuesday, December 1, 2015 9:24 PM
  • Yep it worked right away after deleting that part of address... Wish I would have read earlier would have save an hour!
    Wednesday, December 2, 2015 1:04 AM
  • Thanks rdeces, worked like a charm.

    Dear MS, this problem was reported in April 2014... please fix. kthx.

    Thursday, December 3, 2015 9:15 AM
  • thank you, you the real mvp
    Sunday, December 13, 2015 7:23 AM
  • worked for me too, thanks!
    Sunday, December 13, 2015 7:46 AM
  • Thanks for you it's working for me too I also waste my 2 hours without using this link

    Now its Done


    Friday, December 18, 2015 11:27 AM
  • worked for me
    Friday, February 12, 2016 8:05 PM