none
Modify the HAT string RRS feed

  • Question

  • Hello,

    I am using UAG SP3. With IAG I used to be able to change the HAT string in Admin -> Advanced Configuration (the fields Unique Identifier and Encryption key). But now with UAG these fields are disabled:

    Do you know how to do to enable them?

    Thank you !

    Friday, March 8, 2013 4:14 PM

All replies

  • Hi FLaroc,

    I'm having the same issue with SP1 Update 1, did you get an answer to this?

    I've found the key in the registry and in a .egf config file, have tried changing these with no success.

    Thanks

    Ian.

    Sunday, March 10, 2013 1:38 PM
  • Hi Ian,

    No I didn't get any answer...

    This is a blocking issue for me :(

    • Proposed as answer by IanD193 Tuesday, March 12, 2013 8:37 AM
    • Unproposed as answer by IanD193 Tuesday, March 12, 2013 8:37 AM
    Monday, March 11, 2013 4:18 PM
  • I've also posed the question to our appliance supplier and if they come back with anything I'll let you know.

    Monday, March 11, 2013 6:41 PM
  • Hi FLaroc,

    I've just received the following steps which worked for me using SP1, Up1 so hopefully should still do the trick in SP3.

    You can change the HAT settings, but it’s not an “official” capability.

    1. Close UAG management console.
    2. Make system drive backup.
    3. Make backup of this file:
    "C:\Program Files\Microsoft Forefront Unified Access Gateway\common\conf\UAG.egf"
    4. Run Notepad as administrator.
    5. Open this file for edit in Notepad:
    "C:\Program Files\Microsoft Forefront Unified Access Gateway\common\conf\UAG.egf"
    6. Locate these lines in file:
    m_csEncrypt_key=XXXXXXX
    m_csEncrypt_iv= XXXXXXXX
    7. Change values for both properties after “=” sign to the needed ones (from another UAG server, from its UAG.egf file).
    8. Save file.
    9. Start command prompt as Administrator
    10. Run this command in that command prompt:
    "C:\Program Files\Microsoft Forefront Unified Access Gateway\utils\ConfigMgr\ConfigMgrUtil.exe" –a
    11. Enter following values as response to the started utility:
    1 (Reset)
    1 (Output)
    0 (Debug)
    12. Wait until utility execution is completed.
    13. Open UAG management console and verify that key is changed.

    Hope that helps...

    • Proposed as answer by IanD193 Tuesday, March 12, 2013 8:43 AM
    Tuesday, March 12, 2013 8:42 AM
  • Hi Ian,

    Thanks a lot; it works fine with SP3.

    But even when specifying the same identifier and key as my IAG and publishing the same hostname, my UAG creates a different HAT :(

    Maybe what I'm trying to do is impossible.

    Thanks anyway.

    Tuesday, March 12, 2013 4:56 PM