Sharepoint Server 2013: Have DNS set up, yet unable to access a web application from local server


  • Hello Friends,

    We are hosting a subsite under main sharepoint site with port 80.

    We have dns set up with host entry 'ABC'. When i ping this website('ABC') from different servers over the intranet, it gets resolved to the correct IP. The site is also working fine when i try to access it from different servers.

    Problem arises only when i try to access it locally on the server where it is hosted. When i type the URL http://ABC, it asks me for authentication three times and shows me blank page. Interestingly, when i try to access the website using server name, it works fine, from within the server and from other client machines.

    Any help would be appreciated.  Thanks.
    Wednesday, October 16, 2013 9:06 AM


All replies

  • It could be down to the loop back check.

    Interesting that the servername approach works, but i seem to remember something about that in my dim and distant past...

    • Marked as answer by Zaggy Thursday, October 17, 2013 6:38 AM
    Wednesday, October 16, 2013 10:55 AM
  • Yes, it should be loop-back check

    • Proposed as answer by romeo doncaMVP Wednesday, October 16, 2013 11:53 AM
    Wednesday, October 16, 2013 11:41 AM
  • I appreciate your response Guys.

    When I disable loop back check using the registry editor and restarted the machine, I found out that my central admin site got deleted. Not sure if it was because of the change i did in the regedit

    The site worked once as desired when i had refreshed the http://ABC url on local machine but i had read that i need to restart the machine after regedit, so i did. and after that i lost my central admin site.

    Also now  http://ABC gives me http 500 internal server error. Infact all the IIS sites is giving me this error.

    Any clues?

    Wednesday, October 16, 2013 12:40 PM
  • It is not likely that disabling the loop back check is responsible for this. The restart is more probable as a cause.

    Have you checked that the services have restarted and that the web sites are started in IIS?

    Wednesday, October 16, 2013 5:52 PM
  • Thanks a lot Alex and Rumesh!!!

    Disabling the loop back using regedit worked for me.

    Also, after the system restart, some of the SP sites were stopped. Unfortunately, i was just concentrating on the app pools. Restarting the sites worked.

    You made my day and saved me a lot of time.


    Thursday, October 17, 2013 6:44 AM