How to really disable page zooming in IE11 on Windows 8.1. RRS feed

  • Question

  • Simple really.

    GPEDIT "turn off page zooming functionality" does not seem to work in 8.1 on my Toughpad 4K.

    Am I missing something? A check of the registry shows that "ZoomDisabled" or whatever it was = 1 yet pinch zoom still works on 8.1

    Notes: 10 is not an option, this is for embedded. Chrome et cetera are also not options for the same reason.

    Registry, real working GPEdit good.

    Requiring specially coded HTML if it works might be an option but I would prefer not to have to explore that canal.


    Friday, March 4, 2016 4:10 AM

All replies

  • Hi,

    your touchpad settings are controlled from Start>Control Panel>Mouse. Different vendors may have different options to disable multi-touch touchpad/mouse options.

    On mobile devices using IE11 or other mobile friendly/latest browsers, you can customize scaling with the viewport meta tag in your web pages.


    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to


    Sunday, March 6, 2016 10:41 PM
  • Nice try, I appreciate it.

    This is a Toughpad 4K, no mouse, no touchpad.

    I was most disappointed to find that the GPEDIT / registry setting for IE11 pinch zoom does not work. But then several other things are broken with GPEDIT on WES 8.1 IP.

    Given that IE does not function as advertised, is my only other option going to be some css { touch-action: pinch-zoom no } type of thing?

    (Not actually a consumer question, I will have several of these next month and a lot more after that. So settings need to survive sysprep.)


    Monday, March 7, 2016 1:27 AM
  • Hi P 'Bunny' E,


    Based on your description, since different manufactured has different application to control or disable pinch zoom.


    As a workaround, we may try to use CSS to see if it helps.


    body  {    /* Block area from manipulation actions (zoom, pan) */   -ms-touch-action: none;  }


    Please refer to the link:



    Best Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact

    Monday, March 7, 2016 11:20 AM
  • I'm afraid your link is the same basic thing, 

    As of IE 11, that is just "touch-action" I followed a few links and arrived here: touch-action

    The main issue I have is that the GPEDIT / Registry does not work as advertised.

    Either IE11 should be fixed to actually disable pinch zoom, or documentation (particularly the horrific mess that is gpedit) should be fixed to reflect that "does not work on IE11 under windows 8." (Sorry %WIN_BLUE% because gpedit is full of errors like this.)

    I seem to remember it worked on WES7's IE11, but that might be a delusion.


    Tuesday, March 8, 2016 12:52 AM
  • Hi P 'Bunny' E,

    Unfortunately since the Pinch to Zoom feature found on touch devices use manufacturer specific drivers, for native Internet Explorer, seems like there is no official way to do that for all webpages. The regular option is to use Web Browser Control during development for certain webpage or application.

    Also you could look to your manufacture of the device to see how to disable the feature. Depending if your computer supports it, for Windows 8.1 you could disable pinch zoom feature in control panel Mouse Settings, but it might also affects this feature in other application.

    Best Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact

    Wednesday, March 9, 2016 1:11 AM
  • Thank you for checking. Once again That just leaves IE11 vs GPEDIT not working as advertised. In my book, that is a bug. Where do I go to file it?

    Remember, this is not a laptop, it is a $4K tablet being re-purposed to run signage. There is no mouse, there is no keyboard.

    The whole reason for using the GPEDIT "disable page zooming" was for WES7 with multi-touch screens to stop people screwing around with the display and leaving it hosed.

    The first couple of times, I thought it was me, had I missed the GPEDIT setting? I ended up looking for the registry entry, double-checking etc.

    For what it is worth, "touch-action: none" works, but that requires re-writing stuff that IE should be taking care of.


    Looking at the GPEDIT "Turn off page-zooming functionality" it states 

    If you enable this policy setting, applications that host MSHTML do not respond to user input that causes the content to be re-rendered at a scaled size"

    Implying I might have misread this to mean "turn off the blooming pinch zoom in IE" When it actually means "turn off the blooming pinch zoom in anything *NOT* IE"

    Oh, for some clarity in the GPEDIT help...


    • Edited by P 'Bunny' E Wednesday, March 9, 2016 5:03 AM update
    Wednesday, March 9, 2016 3:46 AM
  • Hi P 'Bunny' E,

    Since we have limitation of our test environment, I tested on traditional environments and following registry entry might be helpful.

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\ZOOM]


    This value may disable zoom feature of Internet Explorer 11 in general Windows edition.

    Best Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact

    Monday, March 14, 2016 1:08 AM
  • "may" or in this case, "may not"

    The only thing that works so far is putting in some CSS. To whit, the GPEDIT setting which actually writes that to the registry, does not work as advertised.

    Either change the advertisment in GPEDIT to say "this does not actually work on W 8.1 ..." or fix IE so it actually does work.

    ergo. Not actually an answer.


    Thursday, April 7, 2016 6:42 AM