locked
MS Word 2010 - Preview Error RRS feed

  • Question

  • In MS Word 2010 when I select a *.docx via the FILE -- OPEN process in the right panel I see an error essage about the file can not previewed because of an error in the Microsoft Word Previewer.  What causes this and can it be corrected and how?

     

    Thanks

    Jim

    Tuesday, February 15, 2011 3:03 PM

Answers

All replies

  • It's a bug that has not yet been fixed.


    Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "heretodaygonetomorrow" wrote in message news:359c6f3f-95ee-48bf-8801-ce3bae4050c0@communitybridge.codeplex.com...

    In MS Word 2010 when I select a *.docx via the FILE -- OPEN process in the right panel I see an error essage about the file can not previewed because of an error in the Microsoft Word Previewer.  What causes this and can it be corrected and how?



    Thanks

    Jim


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Tuesday, February 15, 2011 8:16 PM
  • Use one of the following methods to work around this problem.

    Method 1 

    Preview the file in Windows Explorer. 

    Method 2 

    Preview the file in a different Microsoft Office application. For example, to preview a Word file, use either Excel or PowerPoint.

     

    For more information review :  http://support.microsoft.com/kb/983097

     

    Thanks,

    Susan

     Microsoft Community Support

    Monday, February 21, 2011 9:01 PM
    Answerer
  • I'm sorry, Susan, but I think this is ridiculous.  I purchased the software recently (in May, 2011), and Microsoft still hasn't worked this bug out?  This is a feature that I use extensively, and it's a great inconvenience not to have it working property in Microsoft Word.  The company needs to fix this.
    Monday, May 9, 2011 4:13 AM
  • I'm sorry, Susan, but I think this is ridiculous.  I purchased the software recently (in May, 2011), and Microsoft still hasn't worked this bug out?  This is a feature that I use extensively, and it's a great inconvenience not to have it working property in Microsoft Word.  The company needs to fix this.

    I completely agree.
    Friday, September 30, 2011 5:30 PM
  • I agree totally. I used to use this feature numerous times daily in an earlier version of Word and it is causing me additional work to view a document and costing me billable hours. For what Microsoft charges for their software they should be all over this bug and get it fixed.
    Tuesday, November 8, 2011 3:18 PM
  • Agreed. Just saw this exact "Fix" on multiple posts on this forum. Stop making new versions of Office every year for us to buy and fix the ones you have made first. 
    Thursday, February 2, 2012 8:50 PM
  • Still no answer from Susan or Microsoft. 

    Thursday, February 9, 2012 2:16 PM
  • Method 1 doesn't work for .docX files and only for some .doc files.

    When will the bug be fixed.  This is most annoying.

    Monday, February 13, 2012 9:03 PM
  • I agree this has been a known issue for sometime now.  Every blog i find gives work around It would be nice to at least know if MICROSOFT is at least WORKING ON THIS!!!!!!!!!!!!!
    Friday, February 17, 2012 5:33 PM
  • Boggles the mind. The issue has been around for yeeaaarrsssss. Fix it!
    Monday, March 5, 2012 9:58 PM
  • I have found the cause of this issue, but may need help finding a way to make a surefire fix for it that only affects MS Office (Any MS Office developers out there?)

    The Cause: When Word is closed ("Xed out of") it caches system files so that when you reopen the program, it will launch faster. Upon re-launching the cached program, your MS Word Previewer will NOT work. I do not know of any settings within the program to disable this, nor am I able to contact Microsoft directly with this information to provide a hotfix.

    Workaround 1: When you have Word open, you must launch task manager and KILL the "WINWORD.EXE" process. For obvious reasons, terminating the program while it's running is not a great idea. However, this is much faster than rebooting your computer every time you want to use the previewer.

    Workaround 2: Push Windows key+R for a Run prompt. Type in "services.msc" to bring up the system services window. Navigate to "Application Experience" and double-click to open properties.
    Stop this service, and change the "Startup type" to "Disabled"
    After rebooting your computer, you will notice that Word launches from the ground up, so to speak, each time you use it. This should allow MS Word Previewer to work properly.

    The description of the Application Experience service is simply worded: "Processes application compatibility cache requests for applications as they are launched"

    The problem with Workaround 2 is that I do not know the other side effects of turning off this service apart from not being able to quick-launch any programs on your computer.

    I do not work for Microsoft and these methods are not endorsed by any company. Use at your own risk and always be sure to create backups or restore points before doing anything potentially harmful to your system!

    Any and all feedback is always appreciated.

    • Proposed as answer by TSS-Ralph Wednesday, March 21, 2012 5:49 PM
    Wednesday, March 21, 2012 5:48 PM
  • At Techsupport.Eric

    Workaround 1: As you mentioned, this workaround would not make sense, especially in a business environment.

    Workaround 2: This workaround is a hit and miss.  I also noticed that it causes Word to be unstable.  At times, Word would open after clicking 3 or 4 on the Icon.

    • Proposed as answer by OC_PC_Guy_ Thursday, May 10, 2012 9:49 PM
    • Unproposed as answer by OC_PC_Guy_ Thursday, May 10, 2012 9:49 PM
    Monday, May 7, 2012 3:31 PM
    • Edited by OC_PC_Guy_ Thursday, May 10, 2012 9:50 PM
    Thursday, May 10, 2012 9:50 PM
  • This Hotfix is already installed at our site and the Previewing of docx files in Word is still broken.

    You have to laugh at Microsoft creating a new document format (docx) that can't be previewed in the program that it's designed for.

    Tuesday, September 18, 2012 11:54 AM
  • What you really have to laugh at is that the problem continues to occur in the new version, Office  2013, according to the Applies to section of the article linked above:

    For more information review : support.microsoft.com/kb/983097

    Pathetic.

    • Proposed as answer by thosewhowait Tuesday, November 27, 2012 7:50 PM
    Thursday, November 22, 2012 6:12 AM
  • As it turns out, I'm writing this almost exactly one year to the day of the last post that I see here.  This most annoying problem apparently still exists - I just got a new pc with Home & Student 2013 installed, and apparently none of the geniuses at Microsoft have managed to resolve this issue, that I think I read started with office 2007. 

    I just finished trying to find out what's wrong with the preview file function, and here I see it's been ongoing and, yet, still exists!  Not even a patch?  MICROSOFT, WHAT IS WRONG WITH YOU PEOPLE!  I told myself I needed to learn the latest, which turns out to be not even close to the greatest! I just may end up going back to Office 2003. Now that was a good version, Word, Excel, and Access!

    It is really unacceptable that new program versions should keep coming out loaded with the same known issue. Not to mention loaded down with unnecessary layers in order to accomplish what was once simple and straight to the point.  I've only been using Office 2013 a few weeks, I just can't wait to see what other unpleasant surprises I'm in store for . . .


    • Edited by louisejc Saturday, November 23, 2013 6:05 PM
    • Proposed as answer by ykal Thursday, January 30, 2014 11:12 PM
    • Unproposed as answer by ykal Thursday, January 30, 2014 11:12 PM
    • Proposed as answer by ykal Thursday, January 30, 2014 11:16 PM
    • Unproposed as answer by ykal Thursday, January 30, 2014 11:16 PM
    Saturday, November 23, 2013 6:03 PM
  • The previewer works in both LibreOffice 4.x and OpenOffice 4.x -- both free open source programs.  They show  it can be done, Microsoft.
    Thursday, January 30, 2014 11:15 PM
  • Had a customer with this issue after digging into it with process monitor, it seems the main cause of this is winword.exe not closing properly causing the files to be locked to the second process. Further scrutiny shows this problem only occurs with the file preview enabled, if you never preview a file before opening it winword.exe terminates normally.

    Running as admin, winword /a, nothing seems to help as it's some kind of design issue, which is why they are not fixing it, it would require another level of checks and balances that they won't fix for a small number of people using this feature. Susan's workarounds work also but some customers don't want to change their own way of doing things.

    The solution (well workaround actually) for this user was to create a batch to help them kill orphaned winword.exe processes to fix the file preview.

    It will first try a graceful exit in case they run the script and forget to save any files, then on second keypress it does a forceful termination, this clears the problem for the next execution of winword.exe and will work on every document opened after that point but if they close every VISIBLE word window, the remaining parent process will then cause all the future word windows to have issues.

    So the good news is the problem only occurs when they've closed all documents and then open a new word window and see the problem, at that point just run the script and we're golden again.

    @ECHO OFF
    ECHO This will close any open Word Documents you have, please save first!
    pause
    taskkill /im winword.exe
    tasklist | find /i "winword.exe"
    IF %ERRORLEVEL% equ 1 goto EOF
    :RUNNING
    ECHO Save any open files now! After next key Word will close
    pause
    taskkill /f /im winword.exe
    :EOF
    

    Tuesday, February 25, 2014 4:52 PM
  • Thank you to the MAX

    this worked for me

    Tuesday, April 29, 2014 4:08 AM