none
Windows 10: Automatic Registration failed at join Phase (Event 304) RRS feed

  • Question

  • hi All,

    it has been highlighted in our environment that "Windows 10 devices are trying to register to Azure AD and failing".

    we have Azure AD (infra) configured but we don't want to register our Windows 10 devices, which are on-prem AD joined to register to Azure AD.

    do anyone know what is causing this error? and how to stop devices trying to register to azure AD.

    Here is the screenshot of the error event:

    Thanks in advance.

    Thursday, March 30, 2017 11:08 PM

All replies

  • I am not sure about the error, but has someone set a GPO to automatically register the machines? I would do a gpresult /scope computer /h gpresult.html one of the machines and see if there has been a GPO set.

    The GPO can be found at Computer Configuration > Policies > Administrative Templates > Windows Components > Device Registration. Right-click Register domain-joined computers as devices or Computer Configuration > Policies > Administrative Templates > Windows Components > Workplace Join > Automatically workplace join client computers
    Friday, March 31, 2017 2:48 AM
  • Thanks for your reply Nick.

    The problem is that I have already set "Computer Configuration > Policies > Administrative Templates > Windows Components > Device Registration. Right-click Register domain-joined computers as devices " as Disabled

    Also, I can't find Computer Configuration > Policies > Administrative Templates > Windows Components > Workplace Join > Automatically workplace join client computers

    Friday, March 31, 2017 4:47 AM
  • Automatically workplace join client computers is older. It doesn't matter.

    Can you do a gpresult like mentioned above to see that it isn't picking up a GPO from somewhere else to automatically register? And that it is picking up your disabled GPO.


    Friday, March 31, 2017 5:04 AM
  • Sorry my bad. I realised that after I posted my comment. Thanks for highlighting that.

    The policy where I have disabled (Computer Configuration > Policies > Administrative Templates > Windows Components > Device Registration. Right-click Register domain-joined computers as devices)

    is getting deployed. I am currently checking all the other policies that are currently deployed to the windows 10 devices.

    But I have noticed on these devices that:

    1. the scheduled task (Automatic-Device-Join) is disabled

     

    2) The Registry value (AutoWorkplacejoin) = 0)

     

    Friday, March 31, 2017 5:38 AM
  • Also, confirmed that in all the other GPOs (applied to windows 10 devices), this setting is not configured
    Friday, March 31, 2017 5:40 AM
  • Hi,

        Yes I have tested if join a Win10 1607 device into on-premises domain, the 304 event log error will appear even I disable the device registration GPO like you have configured, also no device registration is configured/enabled and no ADFS is used. I'm not sure if it is by designed, so I think you'd better request a support ticket with Microsoft CSS for help to confirm this.

        A similar thread like yours here:

    https://social.technet.microsoft.com/Forums/windows/en-US/e094da79-42c0-4b02-a821-2582169073b1/windows-10-1607-microsoftwindowsuser-device-registrationadmin-error-after-joing-a-domain?forum=win10itprosetup

    Regards,

    Jimmy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 31, 2017 10:12 AM
    Moderator
  • I experience the same issue. We want to prevent our WS2016 Servers from Azure AD join. Even when  Register domain-joined computers as devices is disabled they continue with Azure AD domain join. I have noticed they do it even after policy is disabled and i do gpupdate. For the moment i could say this happens when RDH role is installed on servers.

    Thursday, December 21, 2017 7:38 AM
  • Anyone find a solution for this?

    Having the same problem with Windows Server 2016 LTSB.

    GPO applied.

    Task Scheduler shows the task disabled, but history continues to log the task executing, then being disabled again.

    Events 304 and 307 keep occurring.


    There's no place like 127.0.0.1

    Monday, May 14, 2018 10:35 PM
  • Any solution so far for this?

    Have the same Problem with Windows 10 1803 Clients US-version...no problem on DE-versions!

    Monday, November 26, 2018 8:21 AM
  • Same issue here... does anyone have a solution?

    I also get the message in Eventlog: 

    "Error: 'invalid_tenant' Description: 'Tenant <domainname.local.com> not found. This may happen if there are no active subscriptions for the tenant. Check with your subscription administrator'. TraceId: {ebf91047-a1a6-48f2-81ef-fe13c8dac807}"

    Friday, December 7, 2018 11:23 AM
  • anyone have any luck in stopping devices from registering with azure?
    Friday, July 5, 2019 10:21 PM
  • Setting the GPO to Disabled does not stop me from seeing the event log messages where it is trying to do something.  I do not want my servers to even try to reach out to Azure AD so can this be stopped?

    Computer Configuration (Enabled)hide
    Policieshide
    Administrative Templateshide
    Policy definitions (ADMX files) retrieved from the central store.
    Windows Components/Device Registrationhide
    Policy Setting Comment
    <span gpmc_settingdescription="This setting lets you configure how domain joined computers become registered as devices.

    When you enable this setting, domain joined computers automatically and silently get registered as devices with Azure Active Directory.

    Note: Additional requirements may apply on certain Windows SKUs. Refer to Azure Active Directory Device Registration Overview.

    http://go.microsoft.com/fwlink/?LinkId=307136
    " gpmc_settingname="Register domain joined computers as devices" gpmc_settingpath="Computer Configuration/Administrative Templates/Windows Components/Device Registration" gpmc_supported="At least Windows Server 2012 R2 or Windows 8.1" tabindex="0">Register domain joined computers as devices
    Disabled

    Monday, July 15, 2019 6:39 PM
  • Log Name:      Microsoft-Windows-User Device Registration/Admin
    Source:        Microsoft-Windows-User Device Registration
    Date:          7/15/2019 1:32:16 PM
    Event ID:      304
    Task Category: None
    Level:         Error
    Keywords:      
    User:          SYSTEM
    Computer:      TESTxxx.xxx.com
    Description:
    Automatic registration failed at join phase.  Exit code: Unknown HResult Error code: 0x801c03f2. Server error: empty. Debug Output:\r\n joinMode: Join
    drsInstance: azure
    registrationType: sync
    tenantType: managed
    tenantId: bx1400-f938-4x49-xx
    configLocation: undefined
    errorPhase: join
    adalCorrelationId: undefined
    adalLog: undefined
    adalLog: undefined
    adalResponseCode: 0x0
    .
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-User Device Registration" Guid="{2xxxx-67xD-4xA3-xx36-D43E5xx5" />
        <EventID>304</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2019-07-15T18:32:16.062888600Z" />
        <EventRecordID>358</EventRecordID>
        <Correlation />
        <Execution ProcessID="3572" ThreadID="3576" />
        <Channel>Microsoft-Windows-User Device Registration/Admin</Channel>
        <Computer>TESTxxxx.xxx.vom</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="ExitCode">-2145647630</Data>
        <Data Name="ServerErrorMessage">empty</Data>
        <Data Name="TenantName">joinMode: Join
    drsInstance: azure
    registrationType: sync
    tenantType: managed
    tenantId: bccc61400-f9c38-49c49-8caf-cc24
    configLocation: undefined
    errorPhase: join
    adalCorrelationId: undefined
    adalLog: undefined
    adalLog: undefined
    adalResponseCode: 0x0
    </Data>
      </EventData>
    </Event>
    Monday, July 15, 2019 6:46 PM
  • Run this Powershell command on each of the clients:

    Get-ScheduledTask  *-join | Unregister-ScheduledTask -Confirm:$False

    Should work on W10/server 2012/2016/2019.

    Ciao,

    Claudio


    MCSA, MCSE, MCT, MCITP:EA

    Sunday, October 20, 2019 10:01 PM