none
issues with Out of office RRS feed

  • Question

  • We currently have a hybrid Exchange environment with some users on Exchange 2007, others on 2013. Some users on the 2007 servers have had issues where their out of office assistant does not switch off when it should or when they manually stop it. To fix this I have been launching Outlook using the /cleanrules switch, this deactivates out of office and deletes all delivery rules so all appears good (as long as the rules have been exported and are then reimported)

    However, it is now coming to light that the users who have had the /cleanrules switch run cannot get out of office to send responses when they try to activate it the next time.

    I found an article saying this may be because of a corrupt mailstore, create a new one and move the users to this. I did as instructed, no joy, out of office still looks like it is on but refuses to send the reply.

    The only solution I have found is to migrate users to Exchange 2013. This is not viable as we have some major issues with the 2013 servers blue screening and locking up, so until these issues are resolved (by our vendor) I cannot move more users to 2013 even though it is known to resolve the out of office issue.

    All users are running Outlook 2010 on Windows 7, both OS and Office are updated once a month shortly after patch Tuesday so they are up to date. Only users who had the /cleanrules switch used are affected.

    Does anyone have another solution to this?

    Wednesday, November 19, 2014 8:22 PM

Answers

  • I found a fix.

    Re-running the /cleanrules switch then resetting the out of office resolves this issue.

    • Marked as answer by GADavies Friday, December 19, 2014 5:41 AM
    Friday, December 19, 2014 5:41 AM

All replies

  • Hi   GADavies

    Thank you for your question.

    You can check your out of office rule by the following link:

    Notice: in order to those operations, you   need to giving our exchange administrator account full delegation rights of   user who cannot use OFF in exchange 2007.

    http://social.technet.microsoft.com/wiki/contents/articles/24792.exchange-oof-ghost-rule.aspx

    If there are any questions, please let me know.

    Best Regard,

    Jim

    Saturday, November 22, 2014 3:09 AM
    Moderator
  • Thanks Jim, but the issue described in that article is not relevant to what we are seeing. The issue we have looks like it has been caused by a fix for another issue with OOF. The initial issue was that users who had OOF activated, and working, were cancelling/deactivating OOF, everything looked to be cancelled in Outlook and/or OWA but the auto responses were still being sent.

    The solution, using the /cleanrules switch, resolved this.

    However, this appears to have caused the issue we now have, not seen until users tried to set OOF to reply next time thy were out of the office. The issue is that although OOF is set to reply, it looks good in Outlook and OWA, but it does NOT send any auto responses. Cancelling and resetting the OOF options makes no difference. Looking at the contents of the associated contents table I see that this thinks OOF is on.

    Only users that have had the /cleanrules switch run to cure the first issue are affected by this.

    Monday, November 24, 2014 3:56 PM
  • Hi  GADavies

    When you send email to user who enable OFF, is there any NDRs or feedback errors?

    If it is, you can post those NDR or errors.

    You can try to reset user profile in client.

    You can refer to the following link to troubleshoot:

    http://www.msoutlook.info/question/394

    Waiting your reply.

    Best Regard,

    Jim

    Tuesday, November 25, 2014 9:27 AM
    Moderator
  • there are no NDRs or bouncebacks, the issue is not related to what happens after the auto reply is sent, it is the fact that no auto replies are being sent. If nothing is sent there cannot be an NDR or bounceback.

    Tuesday, November 25, 2014 3:12 PM
  • hi GADavies

    You can try to modify the body of auto-reply and restart the transport service in exchange 2007.

    Best Regard,

    Jim


    Wednesday, November 26, 2014 7:22 AM
    Moderator
  • I found a fix.

    Re-running the /cleanrules switch then resetting the out of office resolves this issue.

    • Marked as answer by GADavies Friday, December 19, 2014 5:41 AM
    Friday, December 19, 2014 5:41 AM