locked
SharePoint Products and Technology Configuration step 3 error RRS feed

  • Question

  • Dear,

    I have a situation that I disconnected to the current farm using SharePoint Products and Technology Configuration.  But When I tried to reconnect to the current farm it gives me an belew error

    Exception: System.IO.IOException: The process cannot access the file 'C:\inetpub\wwwroot\wss\VirtualDirectories\80\_app_bin\Microsoft.SharePoint.ApplicationPages.dll' because it is being used by another process.

    Is there any one to solve this situation?

    We have two SharePoint Servers and this server was hosting the centeral administration.  Because of this disconnection, the site disabled many functions...

    Tuesday, April 26, 2011 5:11 AM

Answers

  • Thanks Leoyi Sun.

    I finally found out that the file was hold by the vaccine program.   After I restarted the server, I was able to connect to the current server using SharePoint Product and Technology Configuration tool. 

    Thanks


    • Marked as answer by Leoyi Sun Friday, April 29, 2011 8:47 AM
    • Unmarked as answer by Leoyi Sun Friday, April 29, 2011 8:47 AM
    • Marked as answer by Emir Liu Friday, April 29, 2011 8:48 AM
    Friday, April 29, 2011 8:46 AM

All replies

  • Hi,

    Thanks to share your post.

    For the issue, please try to follow these steps:

    1.       Click Start, click Run, type cmd in the Open box, and then click OK.

    2.       At the command line, change to the following directory:
    \Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN

    3.       At the command prompt, type the following command to create a new configuration database:
    psconfig -cmd configdb -create -server ServerName -database ConfigDBName -user Domain\User -password Password

    4.       Rerun the SharePoint Products and Technologies Wizard.

    And please follow this article for reference:

    http://support.microsoft.com/kb/927156.

    Hope this could help you!

    Leo

    • Marked as answer by Leoyi Sun Friday, April 29, 2011 8:47 AM
    • Unmarked as answer by Leoyi Sun Friday, April 29, 2011 8:47 AM
    • Marked as answer by Emir Liu Friday, April 29, 2011 8:48 AM
    • Unmarked as answer by Mike Walsh FIN Friday, April 29, 2011 9:52 AM
    Thursday, April 28, 2011 9:21 AM
  • Thanks Leoyi Sun.

    I finally found out that the file was hold by the vaccine program.   After I restarted the server, I was able to connect to the current server using SharePoint Product and Technology Configuration tool. 

    Thanks


    • Marked as answer by Leoyi Sun Friday, April 29, 2011 8:47 AM
    • Unmarked as answer by Leoyi Sun Friday, April 29, 2011 8:47 AM
    • Marked as answer by Emir Liu Friday, April 29, 2011 8:48 AM
    Friday, April 29, 2011 8:46 AM